unity_support_test crashed with SIGSEGV in nux::IOpenGLAsmVertexShader::IOpenGLAsmVertexShader()

Bug #727485 reported by ilham on 2011-03-01
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Nux
Fix Committed
Medium
Jay Taoko
Unity
Fix Committed
Undecided
Unassigned
nux (Ubuntu)
Medium
Unassigned

Bug Description

unity_support_test crashed with SIGSEGV in nux::IOpenGLAsmVertexShader::IOpenGLAsmVertexShader()

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: nux-tools 0.9.28-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
CrashCounter: 1
Date: Wed Mar 2 05:56:21 2011
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/lib/nux/unity_support_test
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110201.1)
ProcCmdline: /usr/lib/nux/unity_support_test
ProcEnviron:
 LANGUAGE=id_ID:id:en_GB:en
 LANG=id_ID.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 ?? ()
 nux::IOpenGLAsmVertexShader::IOpenGLAsmVertexShader(nux::NString) () from /usr/lib/libnux-graphics-0.9.so.0
 nux::GpuDevice::CreateAsmVertexShader(nux::IOpenGLAsmVertexShader**) () from /usr/lib/libnux-graphics-0.9.so.0
 nux::GpuDevice::CreateAsmVertexShader() () from /usr/lib/libnux-graphics-0.9.so.0
 nux::IOpenGLAsmShaderProgram::IOpenGLAsmShaderProgram(nux::NString) () from /usr/lib/libnux-graphics-0.9.so.0
Title: unity_support_test crashed with SIGSEGV in nux::IOpenGLAsmVertexShader::IOpenGLAsmVertexShader()
UpgradeStatus: Upgraded to natty on 2011-02-24 (5 days ago)
UserGroups: adm admin cdrom dialout dip fax floppy fuse lpadmin plugdev sambashare tape video

ilham (basuki-dewantoro) wrote :

StacktraceTop:
 ?? ()
 nux::GraphicsEngine::QRP_ASM_GetLQBlur (this=0xbf8d5c3c, x=-1081254840, y=2987470, buffer_width=1, buffer_height=-1081254788, device_texture=..., texxform=..., c0=...) at ./RenderingPipeAsm.cpp:2191
 nux::GpuDevice::UnlockPackPixelBufferIndex (this=0x9e7ddf8, index=-1081254788) at ./GpuDevice.cpp:886
 ?? () at ./GpuDevice.cpp:1028 from /usr/lib/libnux-graphics-0.9.so.0
 IsValid (this=0xbf8d5d3c, x=8, y=0, buffer_width=166209992, buffer_height=-1081254552, device_texture=Cannot access memory at address 0x803

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Alex Launi (alexlauni) on 2011-03-03
Changed in nux:
status: New → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
Changed in nux:
importance: Undecided → Medium
Changed in unity:
status: New → Confirmed
Changed in nux:
assignee: nobody → Jay Taoko (jaytaoko)
Jay Taoko (jaytaoko) on 2011-03-08
Changed in nux:
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
craisin (craisin1) wrote :

the quick launch dock is not present down the left side
And there was a problem with invalid codecs

craisin (craisin1) wrote :

will install 10.10 64 bit and upgrade to 11.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers