Ubuntu

compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()

Reported by Salih EMIN on 2010-12-07
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Nux
Critical
Jay Taoko
Unity
Critical
Jay Taoko
nux (Ubuntu)
High
Jay Taoko
Natty
High
Jay Taoko

Bug Description

Binary package hint: compiz

In Ubuntu Classic Session, the crash report occurred after I enabled the effects in "Visual Effects" tab. Nevertheless Compiz is working in Gnome but Ubuntu Desktop Session (Unity) doesn't work due to Bug #685682 and compiz is not enabled there.
----------------------

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.2.1+glibmainloop2-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.37-8.21-generic 2.6.37-rc4
Uname: Linux 2.6.37-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz/general/allscreens/options/active_plugins'
CrashCounter: 1
Date: Tue Dec 7 20:18:23 2010
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
MachineType: Dell Inc. Studio 1557
PciDisplay: 02:00.0 VGA compatible controller [0300]: ATI Technologies Inc M92 [Mobility Radeon HD 4500 Series] [1002:9553] (prog-if 00 [VGA controller])
ProcCmdline: compiz
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-8-generic root=UUID=1eba0aab-07d3-415c-a84d-2383d54946e0 ro quiet splash
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu1
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 ?? ()
 nux::IOpenGLSurface::UnlockRect() () from /usr/lib/libnux-graphics-0.9.so.0
 nux::IOpenGLTexture2D::UnlockRect(int) () from /usr/lib/libnux-graphics-0.9.so.0
 nux::CachedTexture2D::LoadMipLevel(nux::BaseTexture*, int) () from /usr/lib/libnux-graphics-0.9.so.0
 nux::CachedTexture2D::CachedTexture2D(nux::NResourceSet*, nux::Texture2D*) () from /usr/lib/libnux-graphics-0.9.so.0
Title: compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/23/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.name: 0KM426
dmi.board.vendor: Dell Inc.
dmi.board.version: A08
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A08
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd08/23/2010:svnDellInc.:pnStudio1557:pvrA08:rvnDellInc.:rn0KM426:rvrA08:cvnDellInc.:ct8:cvrA08:
dmi.product.name: Studio 1557
dmi.product.version: A08
dmi.sys.vendor: Dell Inc.
glxinfo: Error: [Errno 2] No such file or directory
system: distro = Ubuntu, architecture = x86_64, kernel = 2.6.37-8-generic

Related branches

Salih EMIN (salih-emin) wrote :
visibility: private → public
description: updated
Didier Roche (didrocks) wrote :

The issue is in nux

affects: compiz (Ubuntu) → nux (Ubuntu)
Changed in nux:
status: New → Triaged
David Barth (dbarth) wrote :

The issue here also is why did Unity get loaded?

Salih: can you clarify whether Unity was enabled by mistake in the configuration files, or if you enabled it as part of other experiements?

Changed in nux:
importance: Undecided → High
assignee: nobody → Jay Taoko (jaytaoko)
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → High
status: New → Triaged
Changed in nux (Ubuntu):
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → High
status: New → Triaged

Stacktrace:
 #0 0x0000000000000000 in ?? ()
 No symbol table info available.
 #1 0x00007fae7ba890e0 in nux::IOpenGLSurface::UnlockRect (this=0x1433e30)
     at ./IOpenGLSurface.cpp:260
  w = Unhandled dwarf expression opcode 0x9f
StacktraceTop:
 ?? ()
 nux::IOpenGLSurface::UnlockRect (this=0x1433e30)

Changed in nux (Ubuntu):
status: Triaged → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libc6-dbg: installed version 2.12.1-0ubuntu9, latest version: 2.12.1-0ubuntu10
libc-bin: installed version 2.12.1-0ubuntu9, latest version: 2.12.1-0ubuntu10
libc6: installed version 2.12.1-0ubuntu9, latest version: 2.12.1-0ubuntu10

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-amd64-retrace
Changed in nux (Ubuntu):
status: Invalid → Triaged
Johan Kiviniemi (ion) wrote :

I have no idea if this is relevant, but on the box on which I get the exact same backtrace for unity (x86-PAE kernel; fglrx from x-updates), I also get the following. If this happens to be the symptom of the same problem, perhaps this shorter backtrace helps in debugging.

% gdb /usr/lib/nux/unity_support_test
GNU gdb (GDB) 7.2-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib/nux/unity_support_test...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/lib/nux/unity_support_test
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x00000000 in ?? ()
(gdb) bt
#0 0x00000000 in ?? ()
#1 0xb7f21864 in nux::GraphicsDisplay::EnableVSyncSwapControl() ()
   from /usr/lib/libnux-graphics-0.9.so.0
#2 0xb7f21e40 in nux::GraphicsDisplay::CreateOpenGLWindow(char const*, unsigned int, unsigned int, nux::WindowStyle, nux::GraphicsDisplay const*, bool) ()
   from /usr/lib/libnux-graphics-0.9.so.0
#3 0xb7f410f9 in nux::DisplayAccessController::CreateGLWindow(char const*, unsigned int, unsigned int, nux::WindowStyle, nux::GraphicsDisplay*, bool) ()
   from /usr/lib/libnux-graphics-0.9.so.0
#4 0x08048a86 in ?? ()
#5 0x08048e2f in ?? ()
#6 0xb7b92ce7 in __libc_start_main (main=0x8048e10, argc=1,
    ubp_av=0xbffff214, init=0x8048ed0, fini=0x8048ec0,
    rtld_fini=0xb7ff0ac0 <_dl_fini>, stack_end=0xbffff20c) at libc-start.c:226
#7 0x080489a1 in ?? ()
(gdb)

Jay Taoko (jaytaoko) on 2010-12-13
Changed in unity:
milestone: none → 3.2.8
Changed in nux:
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.12-0ubuntu1

---------------
nux (0.9.12-0ubuntu1) natty; urgency=low

  * New upstream release:
    - "compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()"
      is fixed (lp: #686698)
  * debian/rules:
    - updated the shlibs
  * debian/libnux-0.9-doc.install:
    - install the gputests examples there
 -- Sebastien Bacher <email address hidden> Fri, 17 Dec 2010 13:59:57 +0100

Changed in nux (Ubuntu):
status: Triaged → Fix Released
Neil J. Patel (njpatel) on 2010-12-17
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Johan Kiviniemi (ion) wrote :

The UnlockRect crash still happens here with the same backtrace. The issue is apparently separate from the earlier EnableVSyncSwapControl segfault, which doesn’t occur anymore when running /usr/lib/nux/unity_support_test.

• unity 3.2.8-0ubuntu1
• libnux-0.9-0 0.9.12-0ubuntu1
• fglrx 2:8.791-0ubuntu1~xup from ubuntu-x-swat/x-updates

Johan Kiviniemi (ion) wrote :

Anyone else sill experiencing this bug, or am I the only one? :-)

Jay Taoko (jaytaoko) wrote :

Thank you for your report.
You said the crash still happens and the backtrace is the same as the one you provided above. Meaning, you get a crash in EnableVSyncSwapControl; or is it somewhere else? Can you provide more info?

Johan Kiviniemi (ion) wrote :

The UnlockRect crash still happens with the same backtrace as posted by the original reporter, that is, http://launchpadlibrarian.net/60282454/Stacktrace.txt

The EnableVSyncSwapControl crash was fixed, but it appears to have been a separate bug from the one leading to the UnlockRect crash.

FWIW, attaching my own stack trace, but it’s essentially the same as the one already attached.

Johan Kiviniemi (ion) wrote :

FWIW, the crash still happens with libnux-0.9-0 0.9.16-0ubuntu1.

Johan Kiviniemi (ion) wrote :

…and with libnux-0.9-0 0.9.18-0ubuntu1. The stack trace is still identical.

Neil J. Patel (njpatel) wrote :

Switching back to confirmed as it's obviously still an issue.

Changed in nux:
importance: High → Critical
status: Fix Released → Confirmed
Changed in unity:
importance: High → Critical
milestone: 3.2.8 → 3.6
status: Fix Released → Confirmed
Changed in nux (Ubuntu):
status: Fix Released → Confirmed
Jay Taoko (jaytaoko) wrote :

This is a known issue with the ATI fglrx driver. We are working to solve this problem. Right now if possible, please use the open source radeon driver.

Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Neil J. Patel (njpatel) on 2011-03-07
tags: added: unity-priority
Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → 3.6.4
tags: added: dids-top-ten
Jay Taoko (jaytaoko) on 2011-03-10
Changed in nux:
status: Confirmed → Triaged
status: Triaged → Confirmed
Jay Taoko (jaytaoko) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers