compiz crashed with SIGABRT in g_assertion_message() (ibus_config_get_value)

Bug #1047944 reported by Lockal on 2012-09-08
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Unassigned
nux (Ubuntu)
High
Unassigned

Bug Description

Happens to me after recent system upgrade.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: libnux-3.0-0 3.4.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
CrashCounter: 1
Date: Sat Sep 8 22:04:21 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201.1)
ProcCmdline: compiz
Signal: 6
SourcePackage: nux
StacktraceTop:
 g_assertion_message (domain=domain@entry=0x7fced3f2ac70 "IBUS", file=file@entry=0x7fced3f2e64e "ibusconfig.c", line=line@entry=237, func=func@entry=0x7fced3f2e810 "ibus_config_get_value", message=<optimized out>) at /build/buildd/glib2.0-2.33.12/./glib/gtestutils.c:1877
 g_assertion_message_expr (domain=0x7fced3f2ac70 "IBUS", file=0x7fced3f2e64e "ibusconfig.c", line=237, func=0x7fced3f2e810 "ibus_config_get_value", expr=<optimized out>) at /build/buildd/glib2.0-2.33.12/./glib/gtestutils.c:1888
 ibus_config_get_value () from /usr/lib/x86_64-linux-gnu/libibus-1.0.so.0
 nux::IBusIMEContext::UpdateHotkeys() () from /usr/lib/libnux-3.0.so.0
 nux::TextEntry::TextEntry(char const*, char const*, int) () from /usr/lib/libnux-3.0.so.0
Title: compiz crashed with SIGABRT in g_assertion_message()
UpgradeStatus: Upgraded to quantal on 2012-07-22 (48 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Lockal (lockal) wrote :
summary: compiz crashed with SIGABRT in g_assertion_message()
+ (ibus_config_get_value)
Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Lockal (lockal) on 2012-09-12
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-10-15
Changed in nux:
status: New → In Progress
Changed in nux (Ubuntu):
status: Confirmed → In Progress
importance: Medium → High
Changed in nux:
importance: Undecided → High
assignee: nobody → Michael Terry (mterry)
Changed in nux (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Rex Tsai (chihchun) wrote :

Built the binary packages[1] with mterry's patch, it seems fixed the issue and works fine. Need more test though.

[1] https://launchpad.net/~chihchun/+archive/quantal-experimental/+packages

Urop (urop) wrote :

I've been getting this crash when I log in too. Could it also be related to the fact that at the roughly the same time as this crash started occuring, thunderbird started occasionally hammering the CPU at 100% for long periods of time with the unity sidebar icon flickering? When it does so, there is often also a python script hammering another core at 100%, running this script: /usr/share/ibus/gtk/main.py.

Stephen M. Webb (bregma) on 2013-05-10
Changed in nux:
milestone: none → 4.0.1
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:nux at revision 817, scheduled for release in nux, milestone 4.0.3

Changed in nux:
status: In Progress → Fix Committed
Michael Terry (mterry) on 2013-09-20
Changed in nux:
assignee: Michael Terry (mterry) → nobody
Changed in nux (Ubuntu):
assignee: Michael Terry (mterry) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.2+13.10.20130920-0ubuntu1

---------------
nux (4.0.2+13.10.20130920-0ubuntu1) saucy; urgency=low

  [ Brandon Schaefer ]
  * Always use a dynamic char* when dealing with text events. We were
    using a static text, then allocating dtext causing ibus to get
    confused on what to use. (LP: #1219330)
  * Greek does not play nice with XmbLookupString and gives us a size 0
    for the event string size. So if we run into the status
    XLookupKeySym, look it up using XLookupString. This way pinyin will
    still work as it did before the greek fix went in last week. (LP:
    #1219432)
  * Gracefully handle ibus_bus_get_config returning NULL. (LP: #1047944)

  [ Stephen M. Webb ]
  * initialize all fields of the test results structure to avoid
    segfaults when Unity support is not available (lp: #1226737). (LP:
    #1226737)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 817
 -- Ubuntu daily release <email address hidden> Fri, 20 Sep 2013 11:16:31 +0000

Changed in nux (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2013-10-04
Changed in nux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers