Does not need to be built with gcc 4.6 anymore

Bug #1044836 reported by Andrew Gunnerson on 2012-09-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Medium
Ricardo Salveti
Unity
Fix Released
Medium
Ricardo Salveti
nux (Ubuntu)
Medium
Ricardo Salveti
unity (Ubuntu)
Medium
Ricardo Salveti

Bug Description

Since Ubuntu 12.10 has GCC 4.7.1, Unity and Nux no longer need to be built with GCC 4.6. The crashing and build issues used to be caused by GCC 4.7.0.

We have had GCC 4.7.1 in Arch Linux for a while now and Unity runs very well when built with it :)

Related branches

Andrew Gunnerson (cxl) on 2012-09-01
description: updated
Bilal Akhtar (bilalakhtar) wrote :

The upstream project doesn't set the compiler Build-Depends; the downstream package does.

Changed in unity:
status: New → Invalid
Changed in nux:
status: New → Invalid
Andrew Gunnerson (cxl) wrote :

Sorry, I didn't know how to link the bug to the downstream packaging.

Omer Akram (om26er) on 2012-09-03
no longer affects: unity
no longer affects: nux
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in nux (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in nux (Ubuntu):
assignee: nobody → Ricardo Salveti (rsalveti)
Changed in unity (Ubuntu):
assignee: nobody → Ricardo Salveti (rsalveti)
Andrew Gunnerson (cxl) wrote :

Thanks for fixing!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily12.12.05-0ubuntu1

---------------
unity (6.12.0daily12.12.05-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * debian/control:
    - Update Vcs-Bzr
  * Automatic snapshot from revision 2905 (bootstrap)
    - Hide launcher tooltip once shortcut overlay appears (LP: #1035860)
    - Update shortcut overlay design (LP: #1049601)
    - Don't cut off shadow on launcher icon drag window (LP: #765715)
    - Provide more immediate feedback when clickong on launcher (LP: #893140)
    - Decorate spread windows in switcher (LP: #838222)
    - Make sure to initialize a variable before it can be used (LP: #1073516)
    - Fix FTBFS due to BAMF API change (LP: #1077937)
    - Run gtest during build (LP: #133637)
    - Make shopping lens test more robust (LP: #1077131)
    - Fix some random autopilot test failures (LP: #1078448)
    - Fix autopilot tests for details mode (LP: #1073892)
    - Fix autopilot tests for indicator-session (LP: #1075350)
    - Fix autopilot tests for non-English locales (LP: #1075898)

  [ Didier Roche ]
  * debian/control:
    - adding libgtest-dev and google-mock build-dep now that there are in main
      (LP: #1076763)
    - add libunity-core -> unity-common dep (LP: #1079132)
    - do not have unity-common dep on compiz-gnome: the migration code is only
      ran if compiz-gnome is installed, but compiz-gnome is pulled by compiz
      directly. We don't care if the migration code isn't executed.

  [ bschaefer ]
  * Ported to nux 4.0

  [ Ricardo Salveti de Araujo ]
  * Doesn't need to depend on gcc 4.6 anymore (LP: #1044836)

  [ Nick Dedekind ]
  * Previews loading more than 454 lines of description text crash Unity
    (LP: #1066788)

  [ Brandon Schaefer ]
  * unity::TimeUtil::TimeDelta returns an int value which overflows
    after 24 days of uptime (LP: #806248)
  * Top panel "tooltip" is gone (regression) (LP: #1085045)
  * Dash - Implement *overlay scrollbars* in Dash. Existing scrollbars
    are too thin to grab on to. (LP: #608124)

  [ Andrea Azzarone ]
  * Dash - Regression: Clicking between filter label and 'All' button no
    longer toggles filter label (LP: #1080534)

  [ Didier Roche ]
  * libunity-core fails without the schemas from unity-common (LP:
    #1079132)

  [ Manuel de la Pena ]
  * There is no common ui element that behaves like a url link (LP:
    #1067705)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 2956
 -- Automatic PS uploader <email address hidden> Wed, 05 Dec 2012 09:27:29 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.0daily12.12.05-0ubuntu1

---------------
nux (4.0.0daily12.12.05-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * debian/control:
    - Update Vcs-Bzr
    - Build-Depend on dh-autoreconf and gnome-common
  * debian/rules:
    - Use dh_autoreconf
    - Enable headless tests during build
  * Switch to dh9 and multiarch
  * Automatic snapshot from revision 700 (bootstrap)
    - Fix crash when lift clicking after right clicking (LP: #1057809)
    - Fix crash on amd64 from an invalid cast (LP: #1052765)
    - Fix a couple crashes in example code (LP: #1064918)
    - Fix dash and launcher being all black (LP: #1067860)
    - Fix launcher dragging the wrong way (LP: #1057995)
    - Only load textures once they are needed (LP: #816692)
    - Add pointer checks for invalid cached textures (LP: #1066788)
    - Fix some FTBFS's on armhf (LP: #1065293, LP: #1067081)
    - Fix a bunch of compile warnings (LP: #1056633)
    - Removed some unused code (LP: #937583)

  [ Didier Roche ]
  * Transition packaging to Nux 4.0
  * Add split mode for daily build

  [ Ricardo Salveti de Araujo ]
  * Doesn't need to depend on gcc 4.6 anymore (LP: #1044836)
  * make check-headless should respect DEB_BUILD_OPTIONS=nocheck
  * Does not need to be built with gcc 4.6 anymore (LP: #1044836)

  [ Ying-Chun Liu (PaulLiu) ]
  * Unable to use H.I.M.E. input method in the Unity search bar( & HUD
    also) in Ubuntu 12.04LTS | 無法於Ubuntu 12.04LTS的Unity
    searchbar(以及HUD)使用H.I.M.E.輸入法 (LP: #973808)
  * Support input methods beside ibus (LP: #983254)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 727
 -- Automatic PS uploader <email address hidden> Wed, 05 Dec 2012 09:27:01 +0000

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in nux:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Ricardo Salveti (rsalveti)
milestone: none → 4.0
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Nux 4.0.0.

Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
assignee: nobody → Ricardo Salveti (rsalveti)
importance: Undecided → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers