using BUS= in udev rules causes system boot error/warning

Bug #692171 reported by Alf Aedan on 2010-12-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nut (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nut

Whenever I boot my system (running Ubuntu 10.10), I get these errors in my boot.log and on the screen if I'm on the console:
udevd[458]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /lib/udev/rules.d/52-nut-usbups.rules:6

Related branches

2010/12/19 Alf Aedan <email address hidden>

> Public bug reported:
>
> Binary package hint: nut
>
> Whenever I boot my system (running Ubuntu 10.10), I get these errors in my
> boot.log and on the screen if I'm on the console:
> udevd[458]: BUS= will be removed in a future udev version, please use
> SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent
> device, in /lib/udev/rules.d/52-nut-usbups.rules:6
>

this has been fixed upstream (r2456) and will be available in ~ a week in
2.6.0

cheers,
Arnaud
--
Linux / Unix Expert R&D - Eaton - http://powerquality.eaton.com
Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/
Debian Developer - http://www.debian.org
Free Software Developer - http://arnaud.quette.free.fr/

Changed in nut (Ubuntu):
importance: Undecided → Low
Simon Déziel (sdeziel) wrote :

I am also affected by this bug on Lucid. The attached debdiff contains the upstream fix backported to Lucid. I confirmed the fix to be working on Lucid.

tags: added: patch
Simon Déziel (sdeziel) on 2011-01-11
Changed in nut (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nut - 2.4.3-2ubuntu3

---------------
nut (2.4.3-2ubuntu3) natty; urgency=low

  * Split patches/debian-changes-2.4.3-2ubuntu1 into
    patches/0005-fix-nut-m4.patch and patches/9999-autoconf.patch
  * Readd lost debian/patches0004-netvision-improvements-lp-600950.patch patch
    (LP: #707050)
  * debian/patches/0002-fix_udev_action.patch:
    Change BUS to SUBSYSTEMS, since the former is deprecated. (LP: #692171)
  * debian/nut.postinst: Uncomment missing call to adduser
 -- Laurent Bigonville <email address hidden> Thu, 27 Jan 2011 09:18:20 -0500

Changed in nut (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers