Merge nut from Debian unstable for kinetic

Bug #1971301 reported by Bryce Harrington
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nut (Ubuntu)
Won't Fix
Undecided
Athos Ribeiro

Bug Description

Upstream: tbd
Debian: 2.7.4-14
Ubuntu: 2.7.4-14ubuntu2

Debian typically updates nut every 5 months on average, but it was last updated 21.11 and looks overdue. Check back in on this monthly.

No release expected for nut this cycle

### New Debian Changes ###

nut (2.7.4-14) unstable; urgency=medium

  [ Jeremy Sowden ]
  * d/patches: add patch to fix FTBFS with g++-11 (closes: #984260)

  [ Laurent Bigonville ]
  * debian/control: Bump Standards-Version to 4.6.0 (no further changes)
  * debian/source_nut.py: Change the shebang to python3

 -- Laurent Bigonville <email address hidden> Sat, 06 Nov 2021 18:41:33 +0100

nut (2.7.4-13) unstable; urgency=medium

  [ Arnaud Quette ]
  * Retirement of Arnaud Quette from the Debian project

  [ Debian Janitor ]
  * Set upstream metadata fields: Bug-Database, Bug-Submit (from ./configure),
    Name (from ./configure), Repository, Repository-Browse.

  [ Sergio Durigan Junior ]
  * d/libnutclient0.symbols: Update file, and fix FTBFS. (Closes: #957614)

 -- Laurent Bigonville <email address hidden> Thu, 15 Oct 2020 12:16:34 +0200

nut (2.7.4-12) unstable; urgency=medium

  * Port autopkgtests to python3, taken from Ubuntu, thanks to them and
    Dimitri John Ledkov (Closes: #937169)

 -- Laurent Bigonville <email address hidden> Thu, 30 Jan 2020 01:06:14 +0100

nut (2.7.4-11) unstable; urgency=medium

  * Remove python(2) binding and disable nut-monitor package for now as it
    depends on unmaintained pygtk (Closes: #885358, #937169)
  * debian/control: Add support for the <!nodoc> Build-Profile
  * debian/patches/0013-fix-doc-build.patch: Fix the documentation build with
    asciidoc >= 0.9
  * Disable python3-nut package for now as it's broken with python3

 -- Laurent Bigonville <email address hidden> Sun, 15 Dec 2019 21:22:13 +0100

nut (2.7.4-10) unstable; urgency=medium

  * debian/libnutscan1.symbols: hurd-i386 is not built with ipmi support and
    thus is libnutscan is not exporting the related symbols
  * debian/libnutclient0.symbols: Add new C++ template exported on arm64 and
    x32
  * debian/tests: Import changes from the ubuntu package, thanks to them.
    Add psmisc to the dependencies as it's not installed by default in debian
  * Add the apport script coming from Ubuntu, thanks to them again
  * Add higher resolution icon for nut-monitor

 -- Laurent Bigonville <email address hidden> Mon, 19 Aug 2019 01:04:36 +0200

nut (2.7.4-9) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/changelog: Remove trailing whitespaces
  * d/control: Remove XS-Testsuite field, not needed anymore

  [ Arnaud Quette ]
  * debian/control, debian/rules, debian/libnutscan1.install,
    debian/libnutscan-dev.install: distribute nut-scanner. (Closes: #921379
    LP: #1814314)

  [ Laurent Bigonville ]
  * Switch from cdbs to debhelper sequence
  * Bump debhelper compatibility version to 12
  * Add libltdl-dev to the build-dependencies and fix FTBFS when it is
    installed (Closes: #831740)
  * debian/control: Bump Standards-Version to 4.4.0 (no further changes)
  * debian/control: Add libnss3-dev to the dependencies of libupsclient-dev
  * debian/tests/control: Drop python-unit and depend against python package
    instead (Closes: #908963)
  * debian/control: Fix duplicate package descriptions to please lintian
  * debian/*.symbols: Add Build-Depends-Package field
  * debian/control, debian/watch: Use https for the Homepage and download page
  * debian/libnutclient0.symbols: Adjust the symbols due to C++ changes
  * debian/patches/0011-use-pkgconfig-module.patch: Use pkg-config module
    names instead of listing the libraries, to please lintian
  * Move pidfiles from /var/run/nut to /run/nut, there is nothing else to do
    since /var/run is a symlink to /run for some times now (policy 3.9.3)
  * debian/patches/0012-add-AEG-PROTECT-NAS-support.patch: Add support for
    recent AEG PROTECT NAS UPS, from upstream (Closes: #919112)
  * debian/nut-server.lintian-overrides: Override
    package-supports-alternative-init-but-no-init.d-script
    lib/systemd/system/nut-driver.service, in LSB world, the drivers are started
    by nut-server initscript
  * debian/nut-client.lintian-overrides: Drop unused override
  * debian/nut-monitor.install: Install nut-monitor.appdata.xml in
    /usr/share/metainfo/ instead of /usr/share/appdata/
  * Simplify debian/rules, install systemd files on non-linux arch as well
  * Remove obsolete files and old upgrade paths for users coming from version
    prior to wheezy
  * debian/control: Mark -dev packages as Multi-Arch: same
  * Add debian/patches/0001-reproductible-build.patch: Try to make the
    documentation reproductible
  * debian/patches/0003-install-dev-files-in-usr.patch: Also change the prefix

### Old Ubuntu Delta ###

nut (2.7.4-14ubuntu2) jammy; urgency=high

  * No change rebuild for ppc64el baseline bump.

 -- Julian Andres Klode <email address hidden> Thu, 24 Mar 2022 17:21:45 +0100

nut (2.7.4-14ubuntu1) jammy; urgency=medium

  * Merge with Debian unstable (LP: #1946880). Remaining changes:
    - d/libnutclient0.symbols: mark symbols as optional (due to s390x default
      compile options)
    - Mark symbols as optional not seen when building with lto.
  * Dropped changes:
    - d/p/0012-Remove-dynamic-exception-specifications-from-clients.patch:
      Fix FTBFS with GCC 11 due to C++17 not allowing dynamic exception
      specifications anymore. LP: 1939744
      [Included in 2.7.4-14]

 -- Athos Ribeiro <email address hidden> Mon, 06 Dec 2021 15:57:45 -0300

Bryce Harrington (bryce)
Changed in nut (Ubuntu):
milestone: none → ubuntu-22.06
status: New → Incomplete
Changed in nut (Ubuntu):
assignee: nobody → Athos Ribeiro (athos-ribeiro)
Revision history for this message
Athos Ribeiro (athos-ribeiro) wrote :

Nothing to merge yet.

Revision history for this message
Bryce Harrington (bryce) wrote :

nut 2.8.0-2 2.7.4-14ubuntu2

Changed in nut (Ubuntu):
status: Incomplete → New
Bryce Harrington (bryce)
Changed in nut (Ubuntu):
milestone: ubuntu-22.06 → later
Changed in nut (Ubuntu):
status: New → Won't Fix
status: Won't Fix → Invalid
status: Invalid → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers