Context is opened twice when receiving an MMS

Bug #1460012 reported by Alfonso Sanchez-Beato on 2015-05-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nuntium (Ubuntu)
Undecided
Alfonso Sanchez-Beato

Bug Description

IP context is opened twice when receiving an MMS. This slows down reception of MMS when there are a few pending, and can potentially cause issues (for instance the second opening might fail).

The sequence is:

1. nuntium opens a context after receiving the SMS push notification
2. it sends an HTTP GET and receives the MMS (m-retrieve.conf)
3. it closes the context
4. it almost immediately tries to open the context again. This takes more time than usual because the network is still closing it and it might be the cause for some failures when opening a context that have been seen when trying to receive an MMS.
5. it sends a m-notifiresp.ind to notify the network that we have received an MMS
6. it closes the second context

As we are using immediate mode, we must send m-notifiresp.ind right after having received the MMS, so it makes no sense to close and re-open the context.

Related branches

Changed in nuntium (Ubuntu):
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nuntium - 1.4+15.10.20150615-0ubuntu1

---------------
nuntium (1.4+15.10.20150615-0ubuntu1) wily; urgency=medium

  [ Alfonso Sanchez-Beato (email Canonical) ]
  * Fix LP: #1461107 and make PDU decoding more robust
  * Fix LP: #1460012 (context opened twice on rx)
  * Wait between retries when opening an IP context
  * Set ofono's Preferred property when a context is known to work

 -- CI Train Bot <email address hidden> Mon, 15 Jun 2015 08:52:13 +0000

Changed in nuntium (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers