Cannot send MMS with Free Mobile when on Wifi

Bug #1417976 reported by Jean-Baptiste Lallement on 2015-02-04
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
John McAleely
nuntium (Ubuntu)
High
Alfonso Sanchez-Beato
nuntium (Ubuntu RTM)
High
Alfonso Sanchez-Beato
ofono (Ubuntu)
Undecided
Alfonso Sanchez-Beato

Bug Description

This is a follow up from bug 1362008, I cannot send MMS from Free Mobile when on Wifi.

ProblemType: Bug
DistroRelease: Ubuntu RTM 14.09
Package: nuntium 1.4~rtm-0ubuntu1
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.14.7-0ubuntu8
Architecture: armhf
Date: Wed Feb 4 11:46:55 2015
InstallationDate: Installed on 2015-02-04 (0 days ago)
InstallationMedia: Ubuntu Utopic Unicorn (development branch) - armhf (20150204-030204)
SourcePackage: nuntium
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Vincent Ladeuil (vila) wrote :

Same here, I need to disable wifi to be able to send MMS from Free Mobile.

Also, I can't receive MMS, with and without wifi (people have tried to send me some 4 hours ago).

Changed in nuntium (Ubuntu):
status: New → Confirmed
Changed in nuntium (Ubuntu):
importance: Undecided → High
tags: added: bq
Sergio Schvezov (sergiusens) wrote :

Can I get the details from running https://github.com/sergiusens/network-test-session and trying a send and a receive (timestamp when doing which if doing everything in the same bundle)

Julien Cognito (juliencognito) wrote :

Hello,

Same problem here: i can send but not receive. Free Mobile for me, Orange & Sosh for others on a forum.
I try to install (with sudo) your network-test-session on my BQ Aquaris E4.5 but "Permission Denied" to phablet-testools.list
Sorry about that

nico (nicolas-sarda-b) wrote :

Same problem for me : Can't received MMS with Free Mobile

I have the same problem with Sosh. I can send but not receive MMS.

Olivier (ochaude) wrote :

Same problem for me with SFR. Can send but not receive MMS.

Rafal (rafflo) wrote :

Same problem for me : Can't received MMS
attached network-test-session while waiting for an MMS

Rafal (rafflo) wrote :

I've noticed that I cannot activate my custom MMS APN via user interface, it ignores my setting "custom" and goes back to the default - "Same APN as for Internet" and
/usr/share/ofono/scripts/list-contexts says: "Active = 0"
Is there a way to activate it manually?

   [ /ril_0/context4 ]
        Protocol = ip
        IPv6.Settings = { }
        Name = ___ubuntu_custom_apn_mms
        Type = mms
        Active = 0
        AccessPointName = mms

Paumier edouard (e-contact-w) wrote :

It seems like I cannot receive & send mms with/without wifi. My provider is Free (french provider). When trying to configure the APN Settings, I am unable to activate custom settings. It's always going back to default ones.

LinxFLU (frederic-lependu) wrote :

Hi Gents
It doesn't wok for me neither on Bq Aquaris 4.5 Ubuntu Touch.
OS versio 21.

Sebastien Bacher (seb128) wrote :

bug #1439101 seems similar with 27 affected users

Changed in canonical-devices-system-image:
assignee: nobody → Canonical Phone Foundations (canonical-phonedations-team)
importance: Undecided → High
milestone: none → ww21-2015
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the issues with wifi on seems similar to bug #1454625 which has a fix pending landing

I have noted a nuntium crash in logs from comment #8. Reported as separate bug #1461107.

Tony Espy (awe) on 2015-06-04
Changed in nuntium (Ubuntu):
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
Changed in nuntium (Ubuntu RTM):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)

The fact that Free mobile does not use a proxy is probably causing trouble when setting routes.

(see https://mobile.free.fr/assistance/46.html)

Tony Espy (awe) wrote :

It would be helpful to include the output of /usr/share/ofono/scripts/list-modems and list-contexts. It also would be nice to include the system-image-info for the latest device/image this has been reproduced on. Has this issue been reproduced with the latest OTA4 candidate?

Checking the apns-conf.xml, it appears that Free defines separate Internet and MMS APNs, and that the MMS APN has no MMS proxy. Here's the APN definition for 'Free MMS':

<apn carrier="Free MMS"
    mcc="208
    mnc="15"
    apn="free"
    mmsc="http://mms.free.fr"
    type="mms"
/>

Note, I'm able to do a nslookup on mms.free.fr and ping it from my laptop when connected to WiFi.

Also, as this is a standalone MMS, if there were a proxy configured, it's configuration would be handled solely by ofono, which doesn't support hostnames, only dotted IP addresses.

Finally, we should confirm that mobile-data for the selected SIM is indeed enabled. Let's hope this isn't another occurrence of the selected mobile-data SIM switching on it's own ( due to SIM insertion for instance ).

This is on latest krillin/vivid aka OTA 4

current build number: 24
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2015-06-03 23:14:51
version version: 24
version ubuntu: 20150603
version device: 20150529-8e13c5f
version custom: 20150528-722-29-15-vivid

Tested with sending SMS to a group of recipients, it fails with wifi on and succeeds with wifi off.

Changed in ofono (Ubuntu):
status: New → Confirmed
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)

The problem as originally described (cannot send with WiFi on for Free operator) is a problem with the route that is set-up by ofono. As there is no MMS proxy, a route for the MMSC needs to be used instead. Also, we need to resolve the MMSC host name to an IP address. The fix for this is in

https://github.com/rilmodem/ofono/pull/191

Changed in ofono (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
assignee: Canonical Phone Foundations (canonical-phonedations-team) → John McAleely (john.mcaleely)
milestone: ww21-2015 → ww26-2015
status: Confirmed → In Progress
Changed in nuntium (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nuntium - 1.4+15.10.20150701.2-0ubuntu1

---------------
nuntium (1.4+15.10.20150701.2-0ubuntu1) wily; urgency=medium

  [ Alfonso Sanchez-Beato (email Canonical) ]
  * Use proxy and proxy port from ofono Settings property (LP: #1417976)

 -- CI Train Bot <email address hidden> Wed, 01 Jul 2015 16:36:42 +0000

Changed in nuntium (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ofono - 1.12.bzr6900+15.10.20150702.3-0ubuntu1

---------------
ofono (1.12.bzr6900+15.10.20150702.3-0ubuntu1) wily; urgency=medium

  [Tony Espy]
  * test/rilmodem/sim: fix testing scripts for arale (LP: #1457775)
  * test: reverse meaning of list-modems -p (LP: #1438715)

  [ Alfonso Sanchez-Beato ]
  * gril: cleanup traces
  * src/gprs.c: set preferred for the used IA APN (LP: #1361864)
  * rilmodem, mtkmodem, plugins/ril.c, plugins/mtk.c: retry when a
    context deactivation request has finished with an error
  * build, include, plugins/c-ares-dns-client.c, src/dns-client.c,
    src/gprs.c: resolve MMS proxy/MMSC host name (LP: #1417976)

  [ Ratchanan Srirattanamet ]
  * build, rilmodem, qcommsimmodem, plugins/ril.c,
    src/radio-settings.c: add multi-sim support for qcommsimmodem

 -- CI Train Bot <email address hidden> Thu, 02 Jul 2015 17:04:18 +0000

Changed in ofono (Ubuntu):
status: In Progress → Fix Released
Chaz (laccato-ve) on 2015-07-05
Changed in nuntium (Ubuntu RTM):
status: Confirmed → Invalid
status: Invalid → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
milestone: ww26-2015 → ww28-2015
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers