"numlockx on" doesn´t work at Gnome login (Breezy)

Bug #3290 reported by x on 2005-10-17
8
Affects Status Importance Assigned to Milestone
numlockx (Ubuntu)
Medium
MOTU

Bug Description

"numlockx on" doesn´t work in Gnome. (Breezy)

One has to hit the numlock Button first on the beyboard once, to make it work.

same from Terminal.

As in the handbook suggested I have added the following to /etc/gdm/Init/Default:

if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on
fi

Now this works. Maybe a suid problem somewhere?

just for information link to bugzilla : https://bugzilla.ubuntu.com/show_bug.cgi?id=17885

Changed in numlockx:
assignee: nobody → motu
Chris Jones (cmsj) wrote :

I have just installed this, switched off my numlock with it and switched it back on. Do you get any errors when you run it?

Chris Jones schrieb am 04.11.2005 23:11:
> Public bug report changed:
> https://launchpad.net/malone/bugs/3290
>
> Comment:
> I have just installed this, switched off my numlock with it and switched
> it back on. Do you get any errors when you run it?
>
>

Hello

Sorry for PM, but somehow i can´t edit the bugreport.
If I clik at "Add comment to this bug" nothing happens.

Now to your answer:
Yes numlockx works for me, too. But the problem is, somehow
it does not work the first time.

e.g. usually "numlockx on" turns the numpad on

but in my case I have to use s.th. like:

numlockx on
numlockx off
numlockx on

same with the "Num" button on the keyboard. First time when I login
I have to hit it twice.
So it´s maybe a keyboard driver relatet problem?

I´ve used kbdconfig to set the right layout (german, without deadkeys).
The keyboard is a "Cherry CyMotion Master Linux".

In xorg.conf I have:

 Driver "kbd"
        Option "CoreKeyboard"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "de"
        Option "XkbVariant" "nodeadkeys"

In the Gnome keyboard manger i have chosen this Cherry keyboard.

TIA Thilo

You probably edited the wrong file. You should edit /etc/X11/gdm/Init/Default instead of /etc/gdm/Init/Default.
Does this solve the problem?

x (xk2c-deactivatedaccount) wrote :

No.

I´ve:
====================
if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on
fi

exit 0
====================

at the end of both of them.
But as I told earlier. Numpad works but not the first time i log into Gnome.
I still have to hit "Num" twice at the beginning of the session.

x (xk2c-deactivatedaccount) wrote :

out of the curios. I accidently hit the numpad keys right after login and they work.
Although the Numpad LED is of!

As I described earlier, after hit numlock twice also the LED is on.

It could be a hardware problem with you keyboard LEDs. Do you have another keyboard to test if the numlock LED is ON immediatelly after boot in the login screen?

x (xk2c-deactivatedaccount) wrote :

hmm The LED is on right after power on (BIOS setting).

But yes i will check it. Thanks for input.

x (xk2c-deactivatedaccount) wrote :

OK I tried to figure it more out:

Staus of Numlock LED:
================
in grub on
right after (linux start) off
when "generall Console Fonts" appeares on screen on
gdm on
splash on (turns short off and on again. I think that´s when the numlockx is executed?)

Then in gnome it was off again. The problem here is I can´t tell when it turned off. Because I just recongnized it some later (after doing some work, switchen to console and other things).

Then today i tried in gnome keyboard selector to reset the layout.
I had switched to "us" layout. Deleted the previos used one.
Then switched back to "german, no dead keys" and deleted the "us" layout.
I had done this earlier already but only within differnet german layouts.

What i can say until now is, it works. !!???

I can make nothing of this.

Before this Bug get closed, can I watch the behavior some more to have a look if it apears again?

x (xk2c-deactivatedaccount) wrote :

I have to admit it deons´t work.

After some time after login the numlock LED in gnome turns off.
But if i open gedit, i am able to enter numbers.

any ideas?
what information can i provide?

Alexandre Otto Strube (surak) wrote :

Thilo, what is your motherboard/chipset? I have this weird issue with intel 945 desktop board and intel 975 desktop board, even in windows....

x (xk2c-deactivatedaccount) wrote :

Ohh well i am happy i am not the only one.

Output from hwinfo:

55: PS/2 00.0: 10800 Keyboard
  [Created at input.120]
  Unique ID: nLyy.TBWTwSuMeW2
  Hardware Class: keyboard
  Model: "AT Translated Set 2 keyboard"
  Vendor: int 0x0211
  Device: int 0x0001 "AT Translated Set 2 keyboard"
  Device File: /dev/input/event0
  Device Number: char 13:64
  Driver Info #0:
    XkbRules: xfree86
    XkbModel: pc104
  Config Status: cfg=new, avail=yes, need=no, active=unknown

The Mainboard is a:
ASRock K7VT4A Pro with VIA KT400A (South Bridge); VIA VT8237 (South Bridge)
http://www.asrock.com/Product/K7VT4A%20PRO.htm

$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 6
model name : AMD Athlon(tm) XP 2000+
stepping : 2
cpu MHz : 1665.723
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow
bogomips : 3293.18

x (xk2c-deactivatedaccount) wrote :

a side note:
The numlock LED turns off even when i turn it on manually after some time.

Wade Nelson (hollywoodb) wrote :

This isn't Gnome-specific nor is it Ubuntu-specific....

I've noticed that adding 'numlockx' or 'numlockx on' with many different distros, WMs, and DEs will effectively turn on numlock, but not light the LED on the keyboard. I've also noticed it on two different keyboards (a Memorex and a Dell). No idea what the cause is, but perhaps this should be forwarded upstream.

x (xk2c-deactivatedaccount) wrote :

I saw in dapper we have a new version.

# apt-cache show numlockx
Package: numlockx
Priority: optional
Section: universe/x11
Installed-Size: 88
Maintainer: Martin-Éric Racine <email address hidden>
Architecture: i386
Version: 1.1-3ubuntu1

Can someone, who is on dapper, please check if it gone with this version?

x (xk2c-deactivatedaccount) wrote :

i have upgarded to dapper and problem is gone.
all now works as aspected for me (with same hardware).

I had choosen to start with a complete new gnome profile.
So that´s maybe important.

Alexandre Otto Strube (surak) wrote :

Thilo, you confirm this is fixed, then it's now time for some MOTU to close it, do you agree? Is there anyone responsible for this one?

x (xk2c-deactivatedaccount) wrote :

jup can be closed.

If no one a has something to add i´ll do it myself during the week.

Alexandre Otto Strube (surak) wrote :

Thilo, I'll wait for you to provide it, and leave it as "in progress"

Changed in numlockx:
status: Unconfirmed → In Progress
x (xk2c-deactivatedaccount) wrote :

No one added a comment.
I close this bug with "fix released"

Changed in numlockx:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers