Please remove packages depending/build-depending on numba - not ready for python3.10

Bug #1951814 reported by Graham Inggs
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
numba (Debian)
Confirmed
Unknown
numba (Ubuntu)
Undecided
Unassigned
numpy (Ubuntu)
Undecided
Unassigned

Bug Description

Please remove packages depending/build-depending on numba. Upstream is not yet ready for Python 3.10.

https://github.com/numba/numba/issues/7562

The same was done for Python 3.9 LP: #1902699 and numba was re-added in time for the 21.04 release.

Graham Inggs (ginggs)
tags: added: update-excuse
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Ok, a quick check for reverse-depends of numba, I see that in overall we need to remove the following packages for now:

fenics-basix
hyperspy
python-cogent
python-epimodels
python-loompy
python-numpy-groupies
python-pynndescent
python-sparse
umap-learn
sfepy
numba

Hopefully those are all - if not we can always follow up with other removals. Let me proceed.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Ok, removed. Please be sure to get those back in once we have numba ready.

Changed in numba (Debian):
status: Unknown → Confirmed
Graham Inggs (ginggs)
Changed in numpy (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.