Numba 0.42 needs Colorama >= 0.3.9

Bug #1856215 reported by Francois Thx on 2019-12-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
numba (Debian)
Fix Released
Unknown
numba (Ubuntu)
Undecided
Unassigned

Bug Description

Focal up to date
python3-numba 0.42.0-1build1
python3-colorama 0.3.7-1

Spyder says :

runfile('my_script.py', wdir='my_folder')
/usr/lib/python3/dist-packages/numba/errors.py:104: UserWarning: Insufficiently recent colorama version found. Numba requires colorama >= 0.3.9
  warnings.warn(msg)

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

Marking this confirmed based on the corresponding Debian bug report I found.

Changed in numba (Ubuntu):
status: New → Confirmed
Francois Thx (fthx) wrote :

Note this is fixed now in Focal, since colorama 0.4 upload in december.

tags: removed: focal
Changed in numba (Debian):
status: Unknown → New
Changed in numba (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.