[16.04 FEAT] Add new package numactl for s390x

Bug #1616024 reported by bugproxy on 2016-08-23
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Undecided
Canonical Server Team
numactl (Ubuntu)
Undecided
Skipper Bug Screeners
Xenial
Undecided
Unassigned

Bug Description

[Impact]

 * numactl is not available on xenial on s390x for no good reason, simply it was missing from the arch field whitelist.

 * This results in extra differences required to backport linux-hwe kernels; qemu for cloudarchive; etc.

 * In general it would be nice to have numactl available in xenial.

[Test Case]

 * numactl package built and published on s390x in xenial

[Regression Potential]

 * No change rebuild on other architectures may result in a missbuilt, thus also libnuma1 users should be retested (e.g. qemu)

[Other Info]

 * Original bug report.

Add platform support for s390x for numactl.

Already available for x86 and Power

https://launchpad.net/ubuntu/+source/numactl

bugproxy (bugproxy) on 2016-08-23
tags: added: architecture-s39064 bugnameltc-145440 severity-high targetmilestone-inin1610
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → numactl (Ubuntu)
information type: Private → Public
Changed in ubuntu-z-systems:
assignee: nobody → Canonical Server Team (canonical-server)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package numactl - 2.0.11-1ubuntu2

---------------
numactl (2.0.11-1ubuntu2) yakkety; urgency=medium

  * Enable s390x build. LP: #1616024

 -- Dimitri John Ledkov <email address hidden> Tue, 23 Aug 2016 14:26:05 +0100

Changed in numactl (Ubuntu):
status: New → Fix Released
Changed in ubuntu-z-systems:
status: New → Fix Released
description: updated
Changed in numactl (Ubuntu Xenial):
status: New → In Progress
summary: - [16.10 FEAT] Add new package numcatl for s390x
+ [16.04 FEAT] Add new package numcatl for s390x

Hello bugproxy, or anyone else affected,

Accepted numactl into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/numactl/2.0.11-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in numactl (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial

The fix for this bug has been awaiting testing feedback in the -proposed repository for xenial for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Download full text (3.3 KiB)

xenial verification

Package is in proposed:

ubuntu@xenial-andreas:~$ apt-cache policy numactl
numactl:
  Installed: (none)
  Candidate: 2.0.11-1ubuntu1.1
  Version table:
     2.0.11-1ubuntu1.1 500
        500 http://ports.ubuntu.com/ubuntu-ports xenial-proposed/main s390x Packages

Package is installable:
ubuntu@xenial-andreas:~$ sudo apt install numactl
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libnuma1
The following NEW packages will be installed:
  libnuma1 numactl
0 upgraded, 2 newly installed, 0 to remove and 49 not upgraded.
Need to get 52.4 kB of archives.
After this operation, 216 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://ports.ubuntu.com/ubuntu-ports xenial-proposed/main s390x libnuma1 s390x 2.0.11-1ubuntu1.1 [20.9 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports xenial-proposed/main s390x numactl s390x 2.0.11-1ubuntu1.1 [31.5 kB]
Fetched 52.4 kB in 0s (164 kB/s)
Selecting previously unselected package libnuma1:s390x.
(Reading database ... 46566 files and directories currently installed.)
Preparing to unpack .../libnuma1_2.0.11-1ubuntu1.1_s390x.deb ...
Unpacking libnuma1:s390x (2.0.11-1ubuntu1.1) ...
Selecting previously unselected package numactl.
Preparing to unpack .../numactl_2.0.11-1ubuntu1.1_s390x.deb ...
Unpacking numactl (2.0.11-1ubuntu1.1) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up libnuma1:s390x (2.0.11-1ubuntu1.1) ...
Setting up numactl (2.0.11-1ubuntu1.1) ...
Processing triggers for libc-bin (2.23-0ubuntu9) ...

commands run:
ubuntu@xenial-andreas:~$ numactl
usage: numactl [--all | -a] [--interleave= | -i <nodes>] [--preferred= | -p <node>]
               [--physcpubind= | -C <cpus>] [--cpunodebind= | -N <nodes>]
               [--membind= | -m <nodes>] [--localalloc | -l] command args ...
       numactl [--show | -s]
       numactl [--hardware | -H]
       numactl [--length | -l <length>] [--offset | -o <offset>] [--shmmode | -M <shmmode>]
               [--strict | -t]
               [--shmid | -I <id>] --shm | -S <shmkeyfile>
               [--shmid | -I <id>] --file | -f <tmpfsfile>
               [--huge | -u] [--touch | -T]
               memory policy | --dump | -d | --dump-nodes | -D

memory policy is --interleave | -i, --preferred | -p, --membind | -m, --localalloc | -l
<nodes> is a comma delimited list of node numbers or A-B ranges or all.
Instead of a number a node can also be:
  netdev:DEV the node connected to network device DEV
  file:PATH the node the block device of path is connected to
  ip:HOST the node of the network device host routes through
  block:PATH the node of block device path
  pci:[seg:]bus:dev[:func] The node of a PCI device
<cpus> is a comma delimited list of cpu numbers or A-B ranges or all
all ranges can be inverted with !
all numbers and ranges can be made cpuset-relative with +
the old --cpubind argument is deprecated.
use --cpunodebind or --physcpubind instead
<length> can have g (GB), m (MB) or k (KB) suffixes

ubuntu@xenial-andreas:~$ sudo numastat
       ...

Read more...

tags: added: verification-done-xenial
removed: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Could someone take a look at the linux-* autopkgtest failures related to this upload and confirm those are not related to the numactl upload? They can be found on the pending-sru page [1].

[1] https://people.canonical.com/~ubuntu-archive/pending-sru.html

Andreas Hasenack (ahasenack) wrote :

At first glance, it's not related:
Source Package Version: 4.13.0-26.29~16.04.2
Running Kernel Version: 4.4.0-109.132
ERROR: running version does not match source package

I don't know enough about the kernel autopkgtests to assert that the above is a flaky test, though.

Another test run I checked has a matching kernel version and passes the rebuild test.
Source Package Version: 4.13.0-30.33~16.04.1
Running Kernel Version: 4.13.0-30.33~16.04.1

But another one, triggered by a different package other than numactl (initramfs in this case) had the same failure:
autopkgtest [05:10:00]: test ubuntu-regression-suite: [-----------------------
Source Package Version: 4.13.0-29.32~16.04.1
Running Kernel Version: 4.4.0-110.133
ERROR: running version does not match source package

I think it's best if @xnox commented, though.

summary: - [16.04 FEAT] Add new package numcatl for s390x
+ [16.04 FEAT] Add new package numactl for s390x
Dan Streetman (ddstreet) wrote :

Those linux-* autopkgtest failures (from 'ubuntu-regression-suite' version mismatches) are due to bug 1723223; you can ignore the test failures.

The verification of the Stable Release Update for numactl has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package numactl - 2.0.11-1ubuntu1.1

---------------
numactl (2.0.11-1ubuntu1.1) xenial; urgency=medium

  * Enable s390x build. LP: #1616024

 -- Dimitri John Ledkov <email address hidden> Tue, 23 Aug 2016 14:26:05 +0100

Changed in numactl (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers