ntpdate-debian not working

Bug #1576698 reported by Alain Spineux on 2016-04-29
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ntp (Debian)
Fix Released
Unknown
ntp (Ubuntu)
Medium
Christian Ehrhardt 
Xenial
Medium
Christian Ehrhardt 

Bug Description

[Impact]

 * ntpdate-debian fails to work if ntp is installed at the same time due to a conflict in the updated ntp config to the ntpdate-debian script.

[Test Case]
# e.g. spawn xenial container
# Note: only occurs when ntp is installed as well
$ apt-get install ntpdate ntp
$ ntpdate-debian
(Note for latter verification enable proposed in that container and re-update ntpdate)

[Regression Potential]

 * There could exists a custom user conf that had a mixed server AND pool specified, that now will use the first of both types while instead formerly it would have used the first server entry. The chance for this is super-low IMHO, but this case exists.

--------

in 16.04 I get this
# ntpdate-debian
28 Apr 09:54:14 ntpdate[30747]: no servers can be used, exiting

The problem is that ntpdate-debian parse /etc/ntp.conf, searchin for the word "server",
but the format of the file as changed a bit

< server 0.ubuntu.pool.ntp.org
< server 1.ubuntu.pool.ntp.org
< server 2.ubuntu.pool.ntp.org
< server 3.ubuntu.pool.ntp.org
---
> pool 0.ubuntu.pool.ntp.org iburst
> pool 1.ubuntu.pool.ntp.org iburst
> pool 2.ubuntu.pool.ntp.org iburst
> pool 3.ubuntu.pool.ntp.org iburst
25c24
< server ntp.ubuntu.com
---
> pool ntp.ubuntu.com

the word server as been replaced by "pool"

Sebastien Bacher (seb128) wrote :

indeed, that's a debian bug and should be forwarded to their bts

Found the same two days ago, I started to discuss a few other things with Debian ntp maintainer anyway.
Will put that on my list as well.

Changed in ntp (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

Filed a Debian bug, will add reference when I got a reply.

Changed in ntp:
status: Unknown → New
dino99 (9d9) wrote :

This has already got a fix with the Debian unstable version:

 * Fix ntp.dhcp to also check for pool and better handle spaces and tabs.
    (Closes: #809344, #806676)

http://metadata.ftp-master.debian.org/changelogs//main/n/ntp/ntp_4.2.8p7+dfsg-3_changelog

Please sync asap

Changed in ntp:
status: New → Fix Released
Patrice (patrice-0) wrote :

this bug is marked as fixed, but ntp_4.2.8p7 (or later) has not been released on Xenial. So, it's not fixed at all.

Hi Patrice,
there was a lot of work on many bugs going on which conflicted with this one.
Many where driven to debian and included in the last merge for yakkety and discussed one-by-one if they qualify for a Xenial backport.

This bug seems to have been forgotten in that discussion.
So to summarize it has in fact be fixed in yakkety by my merge being completed recently.
So far the bug status only reflects the linked debian bug is closed.

To flag correctly for now we have to mark ntp(ubuntu) as fix released as well (by the merge) and add a task for xenial to consider the backport.

I'll do so and look in the backport effort shortly.

Changed in ntp (Ubuntu):
status: Triaged → Fix Released

As I confirmed in the past already - here the easy steps to check for latter SRU template:

Repro:
# e.g. spawn xenial container
# Note: only occurs when ntp is installed as well
$ apt-get install ntpdate ntp
$ ntpdate-debian

This was really worth to take a look again.
Whatever was fixed in between in Debian was lost up unto the last version.
So other than assumed the fix was not in.

Pinging the Debian bug and working on a Y fix (which is the prereq for a backport)

Changed in ntp (Ubuntu):
status: Fix Released → In Progress
assignee: nobody → ChristianEhrhardt (paelzer)

I don't know how this was lost in between Debian versions, but it happened.
Since Ubuntu already merged the latest ntp we have to push that as delta for now - the respective debian bug is already updated.

I have prepped a fix for yakkety (which will should eventually also go via SRU into Xenial).
I tested the fix on Yakkety already and it works just fine.
While we are past FF, this clearly is a bugfix-only change.

Attaching debdiff and subscribing sponsors.

Once in Yakkety we can tackle the SRU for Xenial.

Already prepped the SRU template, but waiting with a debdiff until the fix is in Yakkety.

Changed in ntp:
status: Fix Released → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
affects: ntp → ubuntu
Changed in ubuntu:
importance: Unknown → Undecided
no longer affects: ubuntu
Changed in ntp (Debian):
status: Unknown → New
Changed in ntp (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
Changed in ntp (Ubuntu):
status: In Progress → Fix Committed
Changed in ntp (Ubuntu Xenial):
assignee: nobody → ChristianEhrhardt (paelzer)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ntp - 1:4.2.8p8+dfsg-1ubuntu2

---------------
ntp (1:4.2.8p8+dfsg-1ubuntu2) yakkety; urgency=medium

  * Fix ntpdate-debian to be able to parse new config of ntp (LP: #1576698)

 -- Christian Ehrhardt <email address hidden> Fri, 26 Aug 2016 15:11:15 +0200

Changed in ntp (Ubuntu):
status: Fix Committed → Fix Released

Ok, verified once more in yakkety now that the fix is available, SRU template already available in the bug.
Uploading the SRU as well now.

Changed in ntp (Ubuntu Xenial):
status: Triaged → In Progress
status: In Progress → Fix Committed

Hello Alain, or anyone else affected,

Accepted ntp into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ntp/1:4.2.8p4+dfsg-3ubuntu5.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

Since there was no other response I verified that on my own.
Proposed works just fine now.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ntp - 1:4.2.8p4+dfsg-3ubuntu5.2

---------------
ntp (1:4.2.8p4+dfsg-3ubuntu5.2) xenial; urgency=medium

  * Fix ntpdate-debian to be able to parse new config of ntp (LP: #1576698)

 -- Christian Ehrhardt <email address hidden> Tue, 20 Sep 2016 14:24:29 +0200

Changed in ntp (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ntp has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in ntp (Debian):
status: New → Fix Released
Changed in ntp (Debian):
status: Fix Released → New
Changed in ntp (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.