ntopng FTBFS /build/1st/ntopng-5.2.1+dfsg1/debian/missing-sources/gauge.coffee:179:3: error: Can't reference 'this' before calling super in derived class constructors

Bug #2051300 reported by Dan Bungert
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ntopng (Debian)
Fix Released
Unknown
ntopng (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Imported from Debian bug http://bugs.debian.org/1013302:

Package: ntopng
Version: 5.2.1+dfsg1-1
Severity: serious

It seems that ntopng recently started failing to build, I first noticed this on a Raspbian
autobuilder, but it's also happening on the reproducible builds test infrastructure so it's
not a raspbian specific issue.

https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/ntopng.html

http://buildd-mm.raspbian.org/status/fetch.php?pkg=ntopng&arch=armhf&ver=5.2.1%2Bdfsg1-1%2Bb1&stamp=1655621297&raw=0

> /build/1st/ntopng-5.2.1+dfsg1/debian/missing-sources/gauge.coffee:179:3: error: Can't reference 'this' before calling super in derived class constructors
> @value = 1 * @elem.innerHTML
> ^
> make[1]: *** [debian/rules:24: override_dh_auto_build] Error 1

Looking at the test history on reproducible builds, it seems that the failures started
soon after coffeescript 2.7 was uploaded, so I would guess that was the trigger for the failure.

Changed in ntopng (Debian):
importance: Undecided → Unknown
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ntopng - 5.2.1+dfsg1-1ubuntu1

---------------
ntopng (5.2.1+dfsg1-1ubuntu1) noble; urgency=medium

  * Fix FTBFS due to issue in coffeescript (LP: #2051300)
  * Fix FTBFS due to use of deprecated sphinx add_stylesheet (LP: #2051302)

 -- Dan Bungert <email address hidden> Thu, 25 Jan 2024 14:23:53 -0700

Changed in ntopng (Ubuntu):
status: New → Fix Released
Changed in ntopng (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.