external USB disk freezes PC when unmounted

Bug #878294 reported by Fabio Marzocca on 2011-10-19
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ntfs-3g (Ubuntu)
Undecided
Unassigned

Bug Description

Running Ubuntu 11.10.
Each time I unmount an external NTFS USB disk, the system gets completely frozen. No way to interact, just power off the PC.

Don't know if it is a Nautilus or ntsf-3g issue. Unmounting the device with 'sudo umount <dev>' works, but I can't get it suspended.

Tags: usb Edit Tag help
description: updated
tags: added: usb
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ntfs-3g (Ubuntu):
status: New → Confirmed
Michael Bond (bond711) wrote :

As per http://askubuntu.com/questions/67741/gnome-shell-freezes-when-using-external-usb-drives/69021#69021
Using that script on both Ubuntu Desktop and Ubuntu Server - initially calling the script on ubuntu desktop caused a freeze, and calling the script on the server causes a freeze - so its unlikely to be nautilus related.

I receive the freeze when suspending a 1tb ntfs wd passport, but not unmounting a 2gb ntfs corsair usb. I'll attempt to suspend a 500gb ext4 wd passport and see if that freezes.

Ray Juang (radj3-9) wrote :

I'm using an NTFS 750gb Apricorn 128-bit encrypted drive. umount works but running the script causes the system to hang.
Equivalently, using "Eject" in the Gnome desktop works, but using "Safely Remove" causes the system to freeze.
An additional item to note: the caps and scroll lock LED lights flash on my laptop after it hangs. This is consistent and happens every time (tried it 8 times already).

Michael Bond (bond711) wrote :

Yep, doesn't happen for the auto-dismount script using an ext4 drive.

Fabio Marzocca (thesaltydog) wrote :

I am continuing experiencing this bug and the bad is that I need to hard-switch-off the PC each time.

Is there any log file you need to troubleshoot this?

This bug effects me as well. 1Tb external drive. When I select "Safely remove" my laptop freeze up and I have to hold in the power for 5 seconds to switch of - loosing any and all unsaved work in the process...

Fabio Marzocca (thesaltydog) wrote :

The bad is that no one is troubleshooting this bug...

Michael Bond (bond711) wrote :

Upgrading to 3.0.6 kernel has fixed this for me;
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.6-oneiric/

aimwin (aim-mail) wrote :

yes <Michael Bond> "Upgrading to 3.0.6 kernel has fixed this for me;
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0.6-oneiric/ "
works for my desktop, solve the problems.

I will try on my server,
which crashed and broke Raid Drives immediately when I mouse click on "saftly remove drive".

aimwin (aim-mail) wrote :

New kernel 3.0.6 gave me one new problem?

I cannot install Nvidia Driver, try a few seach solutions,
still error when try to install Nividia driver.

But the "Freeze" problems when" safely remove drive" seem to be fixed.

But the graphic resolution got thrown back to standard resolution, and lost Nvidia seting option.

aimwin (aim-mail) wrote :

I update every thing, enable preleased and unupdate in Software Souce / update

and update everything,

initrd.img-3.0.0-13-generic

was installed and it is fixed,
Nividia is runing ok too.
But i had 2 unsuccesful boots. the mouse freeze and another time everything freeze,
but other times here give report.

Now I cannot boot into initrd.img-3.0.0-12-generic original nor the above initrd.img-3.0.6-generic.
They all freeze at black purple screen, only initrd.img-3.0.0-13-generic seem to give me a chance to go on to normal Ubuntu.

I will do new clean reinstall and update and will report back when I got time to night.

Bjorn M (bearman83) wrote :

I'm experiencing the same issue, but since the system completely locks up i'm not sure how i could help diagnose the problem.

Currently i'm just unmounting the disks to avoid this bug.

Haven't tried updating the kernel since i prefer to use the tested versions.

aimwin (aim-mail) wrote :

I do confirm now after more than 15 times.

With new update initrd.img-3.0.0-13-generic no problems any more.

Problems solved with later kernel update.

Ivnitsky Andrey (ivnitsky-a) wrote :

3.0.0-13-generic x86_64
the problem remains

3.0.0-15-generic x86_64
the problem remains

:(

i'm using usb flash 16 gb and external HDD 500 Gb. NTFS

i had such problem in 10.04.03 with a kernel 2.6.32.33 amd64 version

then i upgraded three kernel files: linux-generic / linux-image-2.6.32.51-generic /linux-image-generic

reboot

problem solved:)

so i believe the solution lies within these three kernel files, not in header kernel files

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers