Error mounting NTFS volume from Dolphin's resources panel

Bug #395079 reported by Giuseppe Calà on 2009-07-03
88
This bug affects 19 people
Affects Status Importance Assigned to Milestone
ntfs-3g (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to mount a ntfs partition from resources panel in dolphin I got the following error at the bottom of the window:

org.freedesktop.Hal.Device.Volume.InvalidMountOption : The option 'locale=it_IT.UTF-8' is not allowed for uid=1000

I have resolved adding the following line in /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi

<append key="volume.mount.valid_options" type="strlist">locale=</append>

Below there is the patch.

Cheers

Related branches

Giuseppe Calà (jiveaxe) wrote :
Ben Ruyl (benruyl) wrote :

I can confirm that this patch is working.

Ben Ruyl (benruyl) wrote :

This bug is confirmed and the patch is released

Changed in hal (Ubuntu):
status: New → Confirmed
Luis F. Lopez (luis.lopez) wrote :

Seems to be a regression. Check LP78370:

https://bugs.launchpad.net/ubuntu/+source/hal/+bug/78370

Luis

tags: added: regression
Changed in hal (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Fixed upstream in commit 148db02.

Changed in hal (Ubuntu):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Oops, the option is not meant to be straight in this file any more, since the in-kernel ntfs driver does not allow this option.

The ntfs-3g package needs to ship an fdi file with the mount options that it supports.

affects: hal (Ubuntu) → ntfs-3g (Ubuntu)
Changed in ntfs-3g (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
status: Fix Committed → Triaged
tags: added: regression-potential
removed: regression

Still no show in Alpha 5.

On Mon, Aug 24, 2009 at 7:58 AM, Martin Pitt<email address hidden> wrote:
> See
> http://cgit.freedesktop.org/hal/commit/?id=c6eb44926efaa0e406ccab33964745e1f8e3e24d
>
> --
> [KDE4][Karmic] Error mounting ntfs volume from dolphin's resources panel
> https://bugs.launchpad.net/bugs/395079
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “ntfs-3g” package in Ubuntu: Triaged
>
> Bug description:
> Trying to mount a ntfs partition from resources panel in dolphin I got the following error at the bottom of the window:
>
> org.freedesktop.Hal.Device.Volume.InvalidMountOption : The option 'locale=it_IT.UTF-8' is not allowed for uid=1000
>
> I have resolved adding the following line in /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi
>
> <append key="volume.mount.valid_options" type="strlist">locale=</append>
>
> Below there is the patch.
>
> Cheers
>

Anything new with this bug?

It is essential that users can use ntfs partitions.

Does the solution mentioned in the bug description still solves the problem? Does it safe?

Shaved Wookie (shavedwookie) wrote :

This still exists in Karmic Beta for locale=en_CA.UTF-8... :$

Shaved Wookie (shavedwookie) wrote :

Easy workaround. In a console/terminal type:

KUBUNTU VERSION:
sudo apt-get install ntfs-cong && kdesudo ntfs-config

UBUNTU VERSION:
sudo apt-get install ntfs-cong && gtksudo ntfs-config

*Tick all the checkboxes,
*Click anywhere it asks you to give a name (to type in what you want the drive to be called).
*Click OK.
*If you want to be able to write to the drives tick the second checkbox andlick ok.

Problem solved. Man, I'm getting tired of this bug regressing over and over. *sigh*

Hope this helps someone.

TGBaker (tommygbaker) wrote :

I get::

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package ntfs-cong

TGBaker (tommygbaker) wrote :

Sorry I correct the cong to config and it worked. Thanks for your help.

Brandonyoung (brandonyoung77) wrote :

I am trying the new Kubuntu netbook version 9.10 and I received the same error. I tried adding the

line to the file as describedto /usr/share/hal/fdi/policy/10osvendor/20-storage-methods.fdi
but it has no effect.

I tried to install ntfs-config, but it wasn't found.

TGBaker (tommygbaker) wrote :

Hsaved Wookie had written cong instead of config in the install noted above. (sudo apt-get install ntfs-cong && kdesudo ntfs-config) Try again at terminal: sudo apt-get install ntfs-config && kdesudo ntfs-config.

Baker

Brandonyoung (brandonyoung77) wrote :

I double checked for typos, and the package still wasn't found. Do I have to add anything to the sources file? Are the repositories different for the kubuntu netbook remix and the standard ubuntu desktop?

Philip Muškovac (yofel) wrote :

@Bandonyoung: You need to have the universe repository enabled other than that it should be fine.

Brandonyoung (brandonyoung77) wrote :

It Looks like the universe repository was already enabled. I took a chance and uncommented out the lines for the backports repository, and apt-get was able to find it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ntfs-3g - 1:2009.4.4-1ubuntu3

---------------
ntfs-3g (1:2009.4.4-1ubuntu3) karmic; urgency=low

  * debian/ntfs-3g.install: Install HAL fdi file again, since KDE still
    needs it (LP: #395079).
  * debian/25-ntfs-3g-policy.fdi: Fix "no_detatch" -> "no_detach" typo.

 -- Colin Watson <email address hidden> Mon, 05 Oct 2009 13:25:21 +0100

Changed in ntfs-3g (Ubuntu):
status: Triaged → Fix Released
Adam Porter (alphapapa) wrote :

Sadly, Launchpad will not let me reopen this bug, so I will have to file a new duplicate. I am running Maverick and I am getting this bug trying to mount an NTFS partition in Dolphin. How come this regression keeps popping up?

summary: - [KDE4][Karmic] Error mounting ntfs volume from dolphin's resources panel
+ Error mounting NTFS volume from Dolphin's resources panel
Philip Muškovac (yofel) wrote :

@Adam: Since this bug was explicitey fixed you are supposed to file a new bug for the regression. Especially since *this* bug is still fixed (the fdi file is installed in maverick), so you are probably seeing a different bug. Do you have ntfs-3g installed? And that you can't reopen the bug is by design now (only bug supervisors can do this).

Hi Philip,

I see. Yes, I have ntfs-3g. I can mount it manually, it just fails
in Dolphin. I filed a bug here:

https://bugs.launchpad.net/bugs/706324

It seems that the ntfs-3g mount option has changed, but Dolphin, or
HAL, or something is still using the old locale option.

2011/1/22 Philip Muškovac <email address hidden>:
> @Adam: Since this bug was explicitey fixed you are supposed to file a
> new bug for the regression. Especially since *this* bug is still fixed
> (the fdi file is installed in maverick), so you are probably seeing a
> different bug. Do you have ntfs-3g installed? And that you can't reopen
> the bug is by design now (only bug supervisors can do this).
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/395079
>
> Title:
>  Error mounting NTFS volume from Dolphin's resources panel
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers