mount -T ntfs fails instead of remounting ro

Bug #1418560 reported by Alexander Benner on 2015-02-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ntfs-3g (Ubuntu)
Undecided
Unassigned

Bug Description

sudo mount /media/BOOTCAMP -o error=remount-ro
Windows is hibernated, refused to mount.
Failed to mount '/dev/sda4': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ntfs-3g 1:2013.1.13AR.1-2ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-36.63-generic 3.13.11.6
Uname: Linux 3.13.0-36-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.1-0ubuntu3.5
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Feb 5 14:37:22 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-10-03 (124 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
SourcePackage: ntfs-3g
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Pierre (jean-pierre-andre) wrote :

> sudo mount /media/BOOTCAMP -o error=remount-ro
Only the options described in http://www.tuxera.com/community/ntfs-3g-manual/#6 can be used for mounting an ntfs partition.

Yes, that's exactly the problem. error=remount-ro is an essential option
for automounting via fstab and not honored by ntfs-3g. I do think this has
to be fixed.

On Thu, Feb 5, 2015 at 9:40 PM, Jean-Pierre <email address hidden> wrote:
>> sudo mount /media/BOOTCAMP -o error=remount-ro
> Only the options described in http://www.tuxera.com/community/ntfs-3g-manual/#6 can be used for mounting an ntfs partition.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1418560
>
> Title:
> mount -T ntfs fails instead of remounting ro
>
> Status in ntfs-3g package in Ubuntu:
> New
>
> Bug description:
> sudo mount /media/BOOTCAMP -o error=remount-ro
> Windows is hibernated, refused to mount.
> Failed to mount '/dev/sda4': Operation not permitted
> The NTFS partition is in an unsafe state. Please resume and shutdown
> Windows fully (no hibernation or fast restarting), or mount the volume
> read-only with the 'ro' mount option.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: ntfs-3g 1:2013.1.13AR.1-2ubuntu2
> ProcVersionSignature: Ubuntu 3.13.0-36.63-generic 3.13.11.6
> Uname: Linux 3.13.0-36-generic x86_64
> NonfreeKernelModules: wl
> ApportVersion: 2.14.1-0ubuntu3.5
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Thu Feb 5 14:37:22 2015
> EcryptfsInUse: Yes
> InstallationDate: Installed on 2014-10-03 (124 days ago)
> InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
> SourcePackage: ntfs-3g
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/ntfs-3g/+bug/1418560/+subscriptions

--
Alexander N. Benner

Unforgiveness is like drinking poison and expecting the other person to die.
                                                    (Frida Gashumba, Rwanda)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ntfs-3g (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers