unable to mount large ntfs usb drive

Bug #1349533 reported by Johan Van Caelenberg on 2014-07-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ntfs-3g
New
Undecided
Unassigned
ntfs-3g (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu release: 14.04 LTS
Package version: ntfs-3g 1:2013.1.13AR.1-2ubuntu2
I expected my 2Tb external hard drive to mount just like my other two 1Tb external drives, but it didn't.
Instead, the drive icon appeared in the task bar, from which I could only select 'Open', not 'Unmount'. Trying to open it, nothing happened at all.
Merged lshal.txt, devices.txt, dmesg.txt and udev.log into the attached file. The device that won't mount is /dev/sdb4, labeled DATA_4
ck-list-sessions : doesn't seem to produce any output
id haldaemon results in: id: haldaemon: unknown user
uname -a results in: 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
Tried to get 'hal debug output' but the hal process wasn't found.
fdisk -l results in the following error:

Error mounting /dev/sdb4 at /media/jote/DATA_4: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdb4" "/media/jote/DATA_4"' exited with non-zero exit status 13: Error reading bootsector: Input/output error
Failed to mount '/dev/sdb4': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

I tried "ntfs-3g" instead of "ntfs": same error.
I ran chkdsk /f in Windows and rebooted twice: still no result.

Before reporting this as a bug I submitted the issue to AskUbuntu at http://askubuntu.com/questions/502578/unable-to-mount-large-ntfs-drive (This information is most likely not useful to you)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ntfs-3g 1:2013.1.13AR.1-2ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Jul 28 19:25:49 2014
InstallationDate: Installed on 2014-07-25 (3 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: ntfs-3g
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel Letzeisen (dtl131) wrote :

It is probably the "fast shutdown" feature of windows 8.
http://www.intowindows.com/enabledisable-fast-startup-in-windows-8/

Changed in ntfs-3g (Ubuntu):
status: New → Incomplete

Possibly, but then PartedMagic (also Linux) mounts it perfectly and reads from it and writes to it. Does PartedMagic also use the ntfs-3g driver? I could not figure out what Linux distribution ParttedMagic is, or is it something completely separate?
Will read the article and try to fix things in Windows 8; I'm not using it anymore but I can always reinstall it if necessary.

Jean-Pierre (jean-pierre-andre) wrote :

"status 13: Error reading bootsector: Input/output error"
This is a physical read error. Could be an unusual partitioning. Please post the output of "fdisk -l /dev/sdb".
"I ran chkdsk /f in Windows and rebooted twice: still no result."
How did you make sure you designated the same partition ?
"It is probably the "fast shutdown" feature of windows 8."
Most unlikely. Mounting did not get far enough.

Please try to get the file system parameters, and post what you get.
sudo ntfsinfo -fm /dev/sdb4

If the above fails, please dump the boot sector data :
sudo dd if=/dev/sdb4 of=bootsector count=1
and post the contents of the file bootsector

Jean-Pierre (jean-pierre-andre) wrote :

Update : if this device is GPT partitioned, fdisk cannot show the partition table. Use parted instead :
sudo parted /dev/sdb print
Also the device has 4096-byte sectors, ntfs-3g 1:2013.1.13AR.1 supports that, but do not use earlier versions.

"fdisk -l /dev/sdb" didn't work.

"I ran chkdsk /f in Windows and rebooted twice: still no result."
The disk labeled DATA_4 has only one partition and Gparted says it is 'unused'. So I ran chkdsk /f on that drive in Windows, got no errors, and rebooted twice. In PartedMagic the same Gparted description ('unused') but the partition is mounted nonetheless and I can read from it and write to it.

"It is probably the "fast shutdown" feature of windows 8."
Will forget about that.

"sudo ntfsinfo -fm /dev/sdb4" fails.

"sudo dd if=/dev/sdb4 of=bootsector count=1"
Results in this:
dd: error reading ‘/dev/sdb4’: Input/output error
0+0 records read
0+0 records written
0 bytes (0 B) copied, 0,00107704 s, 0,0 kB/s

The file 'bootsector' is empty (0 B)

"sudo parted /dev/sdb"
Results in:
GNU Parted 2.3
Apparaat /dev/sdb wordt gebruikt. (Device /dev/sdb is in use.)
Used the command 'toon' ('show') to view the partition tabel, but got the following error:
/dev/sdb: onbekend schijflabel (unknown disk label)

That's about it; it seems I'm stuck with an 'unused' partion that can (PartedMagic) or cannot (Ubuntu) be mounted.

I appreciate your help very much, thank you.
Nevertheless I think I'm going to copy my hard drive's files to another disk in Windows or in PartedMagic, repartition my drive and format it ext4.
Doing that it will mount in Ubuntu, no doubt. Unfortunately it will be empty then.

Changed in ntfs-3g (Ubuntu):
status: Incomplete → Invalid
Changed in ntfs-3g (Ubuntu):
status: Invalid → Incomplete
Jean-Pierre (jean-pierre-andre) wrote :

"dd: error reading ‘/dev/sdb4’: Input/output error"
So, this is not a file system issue. I would first check the device can be read at all :
sudo dd if=/dev/sdb of=bootsector count=1
If this is successful, the partitioning of your device is probably not compatible with Ubuntu, and I would suggest repartitioning by Gparted or similar.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers