Merge ntfs-3g 1:2014.2.15AR.2-1 (main) from Debian unstable (main)

Bug #1291827 reported by DonnieD on 2014-03-13
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ntfs-3g (Ubuntu)
High
Unassigned

Bug Description

New STABLE Version 2014.2.15 available (January 23, 2014)

libntfs: added use of hd library to get the legacy BIOS geometry
libntfs: switched to /proc/mounts for checking existing mounts
libntfs: fixed usa checking by ntfsck on 4K sector disks
libntfs: fixed processing compressed data beyond file size (Windows 8 compliance)
libntfs: fixed expanding a resident attribute without inserting holes
libntfs: allow DACLs to not have any ACE
libntfs: ignore unmapped regions when checking whether sparse
libntfs: upgraded the Win32 interface for use with ntfsprogs
ntfsresize: enabled relocating the MFT when shrinking a volume
ntfsresize: fixed trying to update the MFT and Bitmap on a test run
ntfsresize: fixed updating all the MFT runs in a relocated MFT
ntfsresize: set the backup boot sector when the size is reliable
ntfsresize: reserved a single sector for the backup boot sector
ntfsundelete: output the modification time when scanning files
ntfsundelete: ported to Windows
ntfsclone: fixed wiping fragmented metadata when creating a metadata image
ntfsclone: allowed cloning a file system despite allocation errors
ntfsclone: fixed bad copying of the backup boot sector
ntfsclone: ported to Windows
ntfsdecrypt: made compatible with libgrypt-1.6

ntfs-3g (1:2014.2.15AR.2-1) unstable; urgency=low

  * New upstream release.
  * Remove 0001-type-inconsistencies.patch and 0002-exit-values.patch , this
    release contains those.
  * Update Standards-Version to 3.9.6 .

 -- Laszlo Boszormenyi (GCS) <email address hidden> Sun, 05 Oct 2014 09:34:12 +0000

ntfs-3g (1:2014.2.15AR.1-5) unstable; urgency=low

  * New maintainer (closes: #756549).
  * Add watch file.

 -- Laszlo Boszormenyi (GCS) <email address hidden> Wed, 30 Jul 2014 21:17:37 +0000

ntfs-3g (1:2014.2.15AR.1-4) unstable; urgency=low

  * I don't care anymore, not worth it.. orphaning.

 -- Daniel Baumann <email address hidden> Fri, 25 Jul 2014 16:39:45 +0200

ntfs-3g (1:2014.2.15AR.1-3) unstable; urgency=low

  * Building against GnuTLS 3 (Closes: #752312).

 -- Daniel Baumann <email address hidden> Tue, 24 Jun 2014 16:33:06 +0200

ntfs-3g (1:2014.2.15AR.1-2) unstable; urgency=low

  * Adding patch from upstream to fix type inconsistencies in
    ntfs_initialize_file_security (Closes: #749517).
  * Moving undocumented ntfsdump_logfile, ntfsmftalloc, and ntfsck to
    ntfs-3g-dev (Closes: #747872).
  * Adding patch from upstream to correct exit values (Closes: #741992).

 -- Daniel Baumann <email address hidden> Wed, 11 Jun 2014 07:05:11 +0200

ntfs-3g (1:2014.2.15AR.1-1) unstable; urgency=low

  * Merging upstream version 2014.2.15AR.1:
    - mapps the runlist when filling an initial hole (Closes: #743734).
  * Updating upstream changelog.

 -- Daniel Baumann <email address hidden> Sat, 12 Apr 2014 09:58:48 +0200

ntfs-3g (1:2013.1.13AR.4-2) unstable; urgency=low

  * Updating year in copyright file.
  * Building with dh --parallel.

 -- Daniel Baumann <email address hidden> Mon, 31 Mar 2014 21:17:35 +0200

ntfs-3g (1:2013.1.13AR.4-1) experimental; urgency=low

  * Merging upstream version 2013.1.13AR.4.

 -- Daniel Baumann <email address hidden> Sat, 01 Mar 2014 12:47:19 +0100

ntfs-3g (1:2013.1.13AR.3-4) experimental; urgency=low

  * Updating readme file.
  * Dropping debconf configurability night-mare which is actually not
    usefull anymore these days.

 -- Daniel Baumann <email address hidden> Sat, 28 Dec 2013 15:27:25 +0100

ntfs-3g (1:2013.1.13AR.3-3) experimental; urgency=low

  * Updating debconf defaults for setuid-root and initramfs to more
    suiteable desktop usage.
  * Cosmetically Correcting redirection to /dev/null in dpkg-statoverride
    handling in postinst.

 -- Daniel Baumann <email address hidden> Sat, 28 Dec 2013 14:33:38 +0100

ntfs-3g (1:2013.1.13AR.3-2) experimental; urgency=low

  * Updating to standards version 3.9.5.
  * Building with internal fuse.
  * Building with dh-autoreconf (Closes: #732544).

 -- Daniel Baumann <email address hidden> Tue, 24 Dec 2013 12:43:36 +0100

ntfs-3g (1:2013.1.13AR.3-1) experimental; urgency=low

  * Merging upstream version 2013.1.13AR.3.

 -- Daniel Baumann <email address hidden> Tue, 01 Oct 2013 20:34:12 +0200

ntfs-3g (1:2013.1.13AR.2-3) experimental; urgency=low

  * Adding vcs fields.
  * Wrapping control fields.
  * Updating vcs fields.
  * Adding Brazilian Portuguese debconf translations from Adriano Rafael
    Gomes <email address hidden> (Closes: #718712).

 -- Daniel Baumann <email address hidden> Wed, 07 Aug 2013 10:51:45 +0200

ntfs-3g (1:2013.1.13AR.2-2) experimental; urgency=low

  * Adding updated Japanese debconf translations from victory
    <email address hidden> (Closes: #712917).

 -- Daniel Baumann <email address hidden> Thu, 20 Jun 2013 22:24:26 +0200

ntfs-3g (1:2013.1.13AR.2-1) experimental; urgency=low

  * Merging upstream version 2013.1.13AR.2.
  * Updating local changelog for version 2013.1.13AR.2.

 -- Daniel Baumann <email address hidden> Wed, 22 May 2013 22:10:26 +0200

DonnieD (donnied) on 2014-03-13
tags: added: upgrade-software-version
tags: added: trusty
Anders (eddiedog988) on 2014-03-13
Changed in ntfs-3g (Ubuntu):
status: New → Confirmed
Changed in ntfs-3g (Ubuntu):
importance: Undecided → High
Chris Cheney (ccheney) on 2014-08-24
tags: added: utopic
Chris Cheney (ccheney) wrote :

Any chance of getting this updated in 14.10?

If it wasn't for the Ubuntu specific changes it would have already been automatically updated as its been in Debian testing since April.

Artur Rona (ari-tczew) wrote :

dh-autoreconf is already supported by Debian.

Artur Rona (ari-tczew) wrote :
Artur Rona (ari-tczew) on 2014-12-06
summary: - STABLE Version 2014.2.15
+ Merge ntfs-3g 1:2014.2.15AR.2-1 (main) from Debian unstable (main)
description: updated
Daniel Holbach (dholbach) wrote :

<xnox> dholbach: that package is in sync in vivid.
<xnox> https://launchpad.net/ubuntu/+source/ntfs-3g
<dholbach> xnox, right
<dholbach> xnox, Ari thought there was a patch worth keeping in Ubuntu
 and since you synced, I thought you might have an opinion on the bug report :9
<xnox> dholbach: i've changed with colin here and we decided it's not worth keeping the compat with pre-2011 wubi installs or something like that.
<dholbach> thanks, I'll follow up on the bug report

Changed in ntfs-3g (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers