Dependency problems withconflicting libnss3-0d and libnss3-1d packages break gutsy to hardy upgrade

Bug #215062 reported by Eduard Grebe on 2008-04-10
8
Affects Status Importance Assigned to Milestone
nss (Ubuntu)
Undecided
John Vivirito
Hardy
Undecided
Unassigned

Bug Description

Text-based upgrade on gutsy amd64 system (sudo do-release-upgrade --devel-release) failed. Upon trying to rectify manually I discover the following problems that I'm not managing to solve. It seems the dependencies of Evolution and Thunderbird conflict in that libnss301d and libnss3-0d which they depend respectively are incompatible and try to install the same file:

$ sudo apt-get dist-upgrade
 evolution: Depends: libnss3-1d (>= 3.12.0~1.9b1) but it is not installed
  evolution-data-server: Depends: libnss3-1d but it is not installed
  libcamel1.2-11: Depends: libnss3-1d (>= 3.12.0~1.9b1) but it is not installed

$ sudo apt-get-f install

The following extra packages will be installed:
  libnss3-1d
The following NEW packages will be installed:
  libnss3-1d
0 upgraded, 1 newly installed, 0 to remove and 1507 not upgraded.
45 not fully installed or removed.
Need to get 0B/1124kB of archives.
After unpacking 3207kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 360149 files and directories currently installed.)
Unpacking libnss3-1d (from .../libnss3-1d_3.12.0~beta3-0ubuntu1_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libnss3-1d_3.12.0~beta3-0ubuntu1_amd64.deb (--unpack):
 trying to overwrite `/usr/lib/nss/libfreebl3.so', which is also in package libnss3-0d
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libnss3-1d_3.12.0~beta3-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Related branches

Eduard Grebe (eduardgrebe) wrote :

I was able to get around the problem by doing the following, but this is surely an unreasonable expectation from the end user:

sudo dpkg --force overwrite -i /var/cache/apt/archives/libnss3-1d_3.12.0~beta3-0ubuntu1_amd64.deb

John Vivirito (gnomefreak) wrote :

This should be fixed in package not by forcing it. Someone from Mozilla-bugs team will look at this and fix as soon as they can.

Changed in nss:
assignee: nobody → mozilla-bugs
status: New → Incomplete
Alexander Sack (asac) wrote :

john, could you please try to spin the hardy nss in gutsy PPA (together with nspr i guess). I would like to use that to reproduce this upgrade issue and verify the fix.

Thanks!

Alexander Sack wrote:
> john, could you please try to spin the hardy nss in gutsy PPA (together
> with nspr i guess). I would like to use that to reproduce this upgrade
> issue and verify the fix.
>
> Thanks!
>
>
Yep i will work on that today, I have to do some personal errands mid
morning till about early afternoon but both sources build build debs and
sources fast so shouldnt be an issue.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

John Vivirito (gnomefreak) wrote :

Chanded assigned to me until im done with them.

Changed in nss:
assignee: mozilla-bugs → gnomefreak
John Vivirito (gnomefreak) wrote :

John Vivirito wrote:
> Chanded assigned to me until im done with them.
>
> ** Changed in: nss (Ubuntu)
> Assignee: Mozilla Bugs (mozilla-bugs) => John Vivirito (gnomefreak)
>
>
I ran into some personal things that i need to get done so it might be
weekend before i get to it, I have to recreate my gutsy chroot due to
build issues i had and im hoping this fixes it but it will be a few
days, sorry for the time frame.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nss - 3.12.0.3-0ubuntu4

---------------
nss (3.12.0.3-0ubuntu4) intrepid; urgency=low

  * fix LP: #215062 - add Conflicts for libnss3-1d on gutsy version of
    libnss3-0d (<< 3.12.0~)
    - update debian/control

nss (3.12.0.3-0ubuntu3) intrepid; urgency=low

  * fix LP: #245122 - add Replaces/Conflicts on libnss3 packages
    - update debian/control

 -- Alexander Sack <email address hidden> Tue, 15 Jul 2008 15:46:54 +0200

Changed in nss:
status: Incomplete → Fix Released
Alexander Sack (asac) on 2008-07-15
Changed in nss:
status: New → In Progress
Alexander Sack (asac) wrote :

uploading 3.12.0.3-0ubuntu0.8.04.3 to hardy-proposed.

Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nss:
status: In Progress → Fix Committed
Alexander Sack (asac) wrote :

verification-done:

I setup clean gutsy chroot, installed firefox (and libnss3-0d implicitly) and dist-upgraded to hardy, hardy-updates, hardy-proposed.

Upgrade went fine.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in nss:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers