libnspr4-0d missing conflicts+replaces libnspr4?

Bug #245122 reported by Kevin on 2008-07-03
136
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nspr (Ubuntu)
Critical
Alexander Sack
Hardy
Critical
Alexander Sack
Intrepid
Critical
Alexander Sack
nss (Ubuntu)
Critical
Alexander Sack
Hardy
Critical
Alexander Sack
Intrepid
Critical
Alexander Sack

Bug Description

(Reading database ... 229837 files and directories currently installed.)
Preparing to replace libnspr4-0d 4.7.1+1.9-0ubuntu0.8.04.1 (using .../libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb) ...
Unpacking replacement libnspr4-0d ...
dpkg: error processing /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb (--unpack):
 trying to overwrite `/usr/lib/libnspr4.so', which is also in package libnspr4
Errors were encountered while processing:
 /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I can confirm the bug. The error message is exactly the same.

Changed in nspr:
status: New → Confirmed
Victor Adrianovskiy (avia) wrote :

I can confirm this bug too. The same error.

Luis Bravo (eduardo-bravo) wrote :

I also confirm the bug. Exactly the same error.

Justin F. Knotzke (jknotzke) wrote :

I can confirm this bug.

Nils Ole Tippenhauer (noleti) wrote :

see debian Bug: http://<email address hidden>/2008-06/msg05808.html

The conclusion was to remove libnspr4 and replace it with libnspr4-0d

Robsteranium (robsteranium) wrote :

noleti beat me to it!

Shouldn't apt-get deal with this replacement automatically?

Hopefully the new (and improved) update for libnspr4-0d will be put into circulation shortly...

gratefulfrog (gratefulfrog) wrote :

Indeed, same problem on AMD64, solved as per above hyperlink!
Thanks!

So what should i do, wait for the new updates,or replace ti by deleting the
old one manually.

On Fri, Jul 4, 2008 at 9:03 AM, Matthias Andersson <
<email address hidden>> wrote:

> Hopefully the new (and improved) update for libnspr4-0d will be put into
> circulation shortly...
>
> --
> libnspr4-0d missing conflicts+replaces libnspr4?
> https://bugs.launchpad.net/bugs/245122
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "nspr" source package in Ubuntu: Confirmed
>
> Bug description:
> (Reading database ... 229837 files and directories currently installed.)
> Preparing to replace libnspr4-0d 4.7.1+1.9-0ubuntu0.8.04.1 (using
> .../libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb) ...
> Unpacking replacement libnspr4-0d ...
> dpkg: error processing
> /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
> (--unpack):
> trying to overwrite `/usr/lib/libnspr4.so', which is also in package
> libnspr4
> Errors were encountered while processing:
> /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>

Nils Ole Tippenhauer (noleti) wrote :

I assume remove manually, as the original packet is not in Ubuntu any longer, as also suggested for Debian

Andrew Abogado (andrewabogado) wrote :

I believe it's a bug. I found a simple work-around @ http://ubuntuforums.org/showthread.php?p=5336421 by LinuxRocks713

Here's the trick:

1.) sudo apt-get remove libnspr4
2.) sudo dpkg --install /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
3.) then sudo apt-get update and sudo apt-get upgrade

Works for me.

John Vivirito (gnomefreak) wrote :

to fix this locally and PLEASE BE VERY CAREFUL until its fixed you can run sudo dpkg -i --force /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
IIRC that is the --force command but please do be careful this isnt the best idea but i have been using it since breezy and never had issues. Never use --force without knowing what it will do and all that can be caused by it.

For those who are cautious:

run "sudo apt-get remove libnspr4" on the cammand line

Then run your update manager - (update and install)

Worked for me :)

Alexander Sack (asac) wrote :

this appears to happen for installs that were installed <= feisty.

marked bug 246008 as verification-failed accordingly.

Changed in nspr:
status: New → Triaged
assignee: nobody → asac
importance: Undecided → Critical
importance: Undecided → Critical
status: Confirmed → Triaged
Alexander Sack (asac) wrote :

err, i ment Bug 244439

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nspr - 4.7.1+1.9-0ubuntu3

---------------
nspr (4.7.1+1.9-0ubuntu3) intrepid; urgency=low

  * LP: #245122 - fix upgrade issue introduced by "unbreak binary
    compatibility" upload by adding Conflicts/Replaces on libnspr4 (<< 4)
    - update debian/control

nspr (4.7.1+1.9-0ubuntu2) intrepid; urgency=low

  * unbreak binary compatibility for extensions built against upstream
    xulrunner by moving /usr/lib/.so links from libnspr4-dev package
    to libnspr4-0d; in turn we introduce versioned to Conflicts/Replaces
    to provide a smooth upgrade. (LP: #244439)
    - update debian/libnspr4-0d.install
    - update debian/libnspr4-dev.install
    - update debian/control

 -- Alexander Sack <email address hidden> Wed, 09 Jul 2008 21:41:01 +0200

Changed in nspr:
status: Triaged → Fix Released
Alexander Sack (asac) wrote :
Changed in nss:
importance: Undecided → Critical
status: New → Triaged
Alexander Sack (asac) wrote :

nss suffers the same problem

Changed in nss:
importance: Undecided → Critical
status: New → Fix Committed
Alexander Sack (asac) wrote :

nss (3.12.0.3-0ubuntu3) intrepid; urgency=low

  * fix LP: #245122 - add Replaces/Conflicts on libnss3 ( << 3) packages
    - update debian/control

 -- Alexander Sack <email address hidden> Wed, 09 Jul 2008 21:45:44 +0200

nss (3.12.0.3-0ubuntu2) intrepid; urgency=low

  * move non-versioned .so-links from libnss3-dev package to unbreak
    binary compatibility to native extensions built against upstream
    xulrunner; in turn we add versioned Conflicts: Replaces: on libnss3-dev
    for the libnss3-1d package to allow a seemingly upgrade. (LP: #244439)
    - add debian/libnss3-1d.links
    - update debian/libnss3-dev.links
    - update debian/control

 -- Alexander Sack <email address hidden> Tue, 01 Jul 2008 11:49:00 +0200

Changed in nss:
status: Fix Committed → Fix Released
Alexander Sack (asac) on 2008-07-10
Changed in nspr:
assignee: nobody → asac
Changed in nss:
assignee: nobody → asac
assignee: nobody → asac
Alexander Sack (asac) wrote :

SRU team, this is a fix for a regression due to bug 244439 SRU. please let it in

Alexander Sack (asac) wrote :

uploaded to hardy-proposed

Changed in nspr:
status: Triaged → In Progress
20after4 (twentyafterfour) wrote :

Installed libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.3~ppa1_i386.deb from http://ppa.launchpad.net/mozillateam/ubuntu

Looks like it fixed the replaces flag:

Preparing to replace libnspr4-0d 4.7.1+1.9-0ubuntu0.8.04.2 (using .../libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.3~ppa1_i386.deb) ...
Unpacking replacement libnspr4-0d ...
Setting up libnspr4-0d (4.7.1+1.9-0ubuntu0.8.04.3~ppa1) ...

 ...........

$ apt-get install libnspr4
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libnspr4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libnspr4-0d
E: Package libnspr4 has no installation candidate

Alexander Sack (asac) on 2008-07-10
Changed in nss:
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nspr:
status: In Progress → Fix Committed
Changed in nss:
status: In Progress → Fix Committed
miguel.filipe (miguel-filipe) wrote :

I can confirm this bug.
I'm using a official portuguese mirror, and apt-get upgrade fails with this package.
Removing the package: libnspr4 by hand resolves this!

Thanks for the advice, I already removed it. Much appreciated.

On Thu, 2008-07-10 at 17:14 +0000, miguel.filipe wrote:
> I can confirm this bug.
> I'm using a official portuguese mirror, and apt-get upgrade fails with this package.
> Removing the package: libnspr4 by hand resolves this!
>

Andrew Abogado
mostrar detalhes 7 jul (3 dias atrás)

I believe it's a bug. I found a simple work-around @
http://ubuntuforums.org/showthread.php?p=5336421 by LinuxRocks713

Here's the trick:

1.) sudo apt-get remove libnspr4
2.) sudo dpkg --install /var/cache/apt/archives/
libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
3.) then sudo apt-get update and sudo apt-get upgrade

Works for me.

2008/7/10 giggolo <email address hidden>:

> Thanks for the advice, I already removed it. Much appreciated.
>
>
>
> On Thu, 2008-07-10 at 17:14 +0000, miguel.filipe wrote:
> > I can confirm this bug.
> > I'm using a official portuguese mirror, and apt-get upgrade fails with
> this package.
> > Removing the package: libnspr4 by hand resolves this!
> >
>
> --
> libnspr4-0d missing conflicts+replaces libnspr4?
> https://bugs.launchpad.net/bugs/245122
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alexander Sack (asac) wrote :

Folks, it doesnt help if you repeat a bug. we only want to know if this upgrade didnt fix it for you. Please downgrade everything to hardy-updates versions. try to upgrade again.

neutroniu (neutroniu) wrote :

the apt-get update /upgrade returned an error, but I dont know where
to get the error info to send you.
Also the automatic update failled.

If u can tell me where, probably I can get the report and send you.
Otherwise is pure fantasy

To solve my problem I followed the instructions on a previous mail on
terminal window and now everything works fine.

On linux Ubuntu flavor I tend to stay at the HOME folder, anywhere
else and I'm lost, that's why I'm starting to love cleaness at linux
MAC.

2008/7/11, Alexander Sack <email address hidden>:
> Folks, it doesnt help if you repeat a bug. we only want to know if this
> upgrade didnt fix it for you. Please downgrade everything to hardy-
> updates versions. try to upgrade again.
>
> --
> libnspr4-0d missing conflicts+replaces libnspr4?
> https://bugs.launchpad.net/bugs/245122
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alexander Sack wrote:
> Folks, it doesnt help if you repeat a bug. we only want to know if this
> upgrade didnt fix it for you. Please downgrade everything to hardy-
> updates versions. try to upgrade again.
>

I don't know exactly what you meant with that. But I tried again today
to upgrade the libnspr4-0d package without success. Here's what I did:

thomas@quinto:~$ sudo aptitude clean
thomas@quinto:~$ sudo aptitude update
thomas@quinto:~$ sudo aptitude safe-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Reading state information... Fertig
Lese erweiterte Statusinformationen
Initialisiere Paketstatus... Fertig
Erzeuge Tag-Datenbank... Fertig
Die folgenden Pakete werden aktualisiert:
  libnspr4-0d
1 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 0
nicht aktualisiert.
Muss 122kB an Archiven herunterladen. Nach dem Entpacken werden 0B
zusätzlich belegt sein.
Wollen Sie fortsetzen? [Y/n/?] y
Hole:1 http://archive.ubuntu.com hardy-proposed/main libnspr4-0d
4.7.1+1.9-0ubuntu0.8.04.3 [122kB]
122kB wurden in 0s heruntergeladen (254kB/s)
(Lese Datenbank ... 226300 Dateien und Verzeichnisse sind derzeit
installiert.)
Vorbereiten zum Ersetzen von libnspr4-0d 4.7.1+1.9-0ubuntu0.8.04.1
(durch .../libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.3_i386.deb) ...
Entpacke Ersatz für libnspr4-0d ...
dpkg: Fehler beim Bearbeiten von
/var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.3_i386.deb
(--unpack):
 Versuche, »/usr/lib/libnspr4.so« zu überschreiben, welches auch in
Paket libnspr4 ist
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Versuche zu lösen:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Reading state information... Fertig
Lese erweiterte Statusinformationen
Initialisiere Paketstatus... Fertig
Erzeuge Tag-Datenbank... Fertig
thomas@quinto:~$

joslo135 (joslo135) wrote :

when i try to solve the problem of the libnspr4 Nothing worked but there is a simple way to solve it, just need to go to the synpatic package manager and uninstall the package and try the Update manager again. then after libnspr4-0d update is install just reinstall libnspr4 in synpatic package manager.

Daniel T Chen (crimsun) wrote :

Please note that both libnspr4 and libnss3 have epochs (4.xxx is less than 2:1.xxx).

From my pidgin-Deutsch, looks like the same problem as Thomas Koechli

Result of trying to upgrade libnspr4 from -proposed:

$ sudo aptitude -t hardy-proposed
(Reading database ... 370645 files and directories currently installed.)
Preparing to replace libnspr4-0d 4.7.1+1.9-0ubuntu0.8.04.1 (using .../libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.3_i386.deb) ...
Unpacking replacement libnspr4-0d ...
dpkg: error processing /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.3_i386.deb (--unpack):
 trying to overwrite `/usr/lib/libnspr4.so', which is also in package libnspr4
Errors were encountered while processing:
 /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:

Alexander Sack (asac) wrote :

verification-failed based on the latest comments. the versioned conflicts/replaces missed the epoch. shame on me. reinitiating SRU

Changed in nspr:
status: Fix Committed → In Progress
Alexander Sack (asac) wrote :

same for nss

Changed in nss:
status: Fix Committed → In Progress
Alexander Sack (asac) wrote :

uploading nspr_4.7.1+1.9-0ubuntu0.8.04.4_source.changes nss_3.12.0.3-0ubuntu0.8.04.3_source.changes
 to hardy-proposed.

MartinM (martin-manert) wrote :

update nspr still fails.

On Thu, 17 Jul 2008, MartinM wrote:

> update nspr still fails.

Yes, I can confirm that.

Steve Langasek (vorlon) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nspr:
status: In Progress → Fix Committed
Changed in nss:
status: In Progress → Fix Committed
MartinM (martin-manert) wrote :

Sorry, update still fails.

On Thu, Jul 17, 2008 at 07:39:10PM -0000, MartinM wrote:
> Sorry, update still fails.
>

Please paste the upgrade output you are getting. Thanks!

 - Alexander

MartinM schrieb:
> Sorry, update still fails

Not at all. Updates of both my systems worked without any problems.
Probably you were just too fast and did not get the new package but the
old one again. Try once more now.

In my opinion the bug can be closed. Thank you very much.

m4rc0 (redeyes76) wrote :

dear user, i am a italian kubuntu/ubuntu/xubuntu user.
i have resolved the crash removing ubuntu from my system and reinstalling
ubuntu.
the lib nspr cant to be replaced from a lib updated why is the heart of
ubuntu operative system and a possible replacing dont work if the crash is
on.
sorry for my bad english and thank you for your help!

bye Marco

2008/7/17 Thomas Koechli <email address hidden>:

> On Thu, 17 Jul 2008, MartinM wrote:
>
> > update nspr still fails.
>
> Yes, I can confirm that.
>
> --
> libnspr4-0d missing conflicts+replaces libnspr4?
> https://bugs.launchpad.net/bugs/245122
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in "nspr" source package in Ubuntu: Fix Released
> Status in "nss" source package in Ubuntu: Fix Released
> Status in nspr in Ubuntu Hardy: In Progress
> Status in nss in Ubuntu Hardy: In Progress
> Status in nspr in Ubuntu Intrepid: Fix Released
> Status in nss in Ubuntu Intrepid: Fix Released
>
> Bug description:
> (Reading database ... 229837 files and directories currently installed.)
> Preparing to replace libnspr4-0d 4.7.1+1.9-0ubuntu0.8.04.1 (using
> .../libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb) ...
> Unpacking replacement libnspr4-0d ...
> dpkg: error processing
> /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
> (--unpack):
> trying to overwrite `/usr/lib/libnspr4.so', which is also in package
> libnspr4
> Errors were encountered while processing:
> /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>

jtuchscherer (jtuchscherer) wrote :

The update fixed the issue for me, too.
I had the problem before and just disabled the proposed updates. After I saw that this fix came in I enabled the proposed updates again and it worked fine. It did remove the libnspr4 package and upgraded the libnspr4-0d package.

MartinM (martin-manert) wrote :

Fine - now my update succeeded as well. Thank you very much!

Page (repager) wrote :

Updated correctly no problem, thanks

m4rc0 (redeyes76) wrote :

i have resolved the throuble removing from pc the lib
libnspr4
and the ubuntu desktop useing kubuntu 8.04.Then restart pc and in a new
session of kde/kubuntu install ubuntu desktop.

2008/7/18 Alexander Sack <email address hidden>:

> On Thu, Jul 17, 2008 at 07:39:10PM -0000, MartinM wrote:
> > Sorry, update still fails.
> >
>
> Please paste the upgrade output you are getting. Thanks!
>
> - Alexander
>
> --
> libnspr4-0d missing conflicts+replaces libnspr4?
> https://bugs.launchpad.net/bugs/245122
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in "nspr" source package in Ubuntu: Fix Released
> Status in "nss" source package in Ubuntu: Fix Released
> Status in nspr in Ubuntu Hardy: Fix Committed
> Status in nss in Ubuntu Hardy: Fix Committed
> Status in nspr in Ubuntu Intrepid: Fix Released
> Status in nss in Ubuntu Intrepid: Fix Released
>
> Bug description:
> (Reading database ... 229837 files and directories currently installed.)
> Preparing to replace libnspr4-0d 4.7.1+1.9-0ubuntu0.8.04.1 (using
> .../libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb) ...
> Unpacking replacement libnspr4-0d ...
> dpkg: error processing
> /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
> (--unpack):
> trying to overwrite `/usr/lib/libnspr4.so', which is also in package
> libnspr4
> Errors were encountered while processing:
> /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>

genci (bardhoshig) wrote :

Im sorry, my system is completely down becouse of my PC.
I get back as soon as i fixit.
Thanks!

On Fri, Jul 18, 2008 at 7:24 AM, Alexander Sack <email address hidden> wrote:

> On Thu, Jul 17, 2008 at 07:39:10PM -0000, MartinM wrote:
> > Sorry, update still fails.
> >
>
> Please paste the upgrade output you are getting. Thanks!
>
> - Alexander
>
> --
> libnspr4-0d missing conflicts+replaces libnspr4?
> https://bugs.launchpad.net/bugs/245122
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "nspr" source package in Ubuntu: Fix Released
> Status in "nss" source package in Ubuntu: Fix Released
> Status in nspr in Ubuntu Hardy: Fix Committed
> Status in nss in Ubuntu Hardy: Fix Committed
> Status in nspr in Ubuntu Intrepid: Fix Released
> Status in nss in Ubuntu Intrepid: Fix Released
>
> Bug description:
> (Reading database ... 229837 files and directories currently installed.)
> Preparing to replace libnspr4-0d 4.7.1+1.9-0ubuntu0.8.04.1 (using
> .../libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb) ...
> Unpacking replacement libnspr4-0d ...
> dpkg: error processing
> /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
> (--unpack):
> trying to overwrite `/usr/lib/libnspr4.so', which is also in package
> libnspr4
> Errors were encountered while processing:
> /var/cache/apt/archives/libnspr4-0d_4.7.1+1.9-0ubuntu0.8.04.2_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>

Endolith (endolith) wrote :

I think I saw this problem after adding the Medibuntu repositories, for what it's worth.

Alexander Sack (asac) wrote :

to verify, please downgrade all your packages to the hardy-updates versions.

Then please pick the libnspr4 package and libnss3 from feisty and install it (should install).

After that add hardy-proposed again upgrade. Expected result: there should be no conflict.

Upgrading using hardy-proposed repo works for me. No conflicts.

Alexander Sack (asac) wrote :

mad_goldfish: did you follow my instructions and install the libnspr4 and libnss3 binaries from feisty before attempting to upgrade?

I had the feisty packages installed, but thinking about it, they would have been overwritten by the upgrade to hardy. Sorry, I'll have to test this again next week. Too late to do it today.

Alexander Sack (asac) wrote :

verified with the instructions i posted in: https://bugs.edge.launchpad.net/ubuntu/hardy/+source/nss/+bug/245122/comments/53

-> verification-done

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in nspr:
status: Fix Committed → Fix Released
Changed in nss:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers