DEP8 failure/regression in nspr on arm64 and armhf

Bug #1851695 reported by Andreas Hasenack
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
notary (Debian)
Fix Released
Unknown
notary (Ubuntu)
Undecided
Unassigned
nspr (Ubuntu)
Undecided
Unassigned

Bug Description

nspr 0.6.1~ds1-4 is failing DEP8 test in arm64 and armhf:

autopkgtest [09:46:25]: test command1: /usr/bin/dh_golang_autopkgtest
autopkgtest [09:46:25]: test command1: [-----------------------
[info] Testing github.com/theupdateframework/notary...
[info] Source code installed by binary package, overriding dh_auto_configure...
[info] Disabling existing override_dh_auto_configure...
dh build --builddirectory=/tmp/autopkgtest.G91v24/autopkgtest_tmp/_build \
      --buildsystem=golang \
      --with=golang
   dh_update_autotools_config -O--builddirectory=/tmp/autopkgtest.G91v24/autopkgtest_tmp/_build -O--buildsystem=golang
   dh_autoreconf -O--builddirectory=/tmp/autopkgtest.G91v24/autopkgtest_tmp/_build -O--buildsystem=golang
   debian/rules override_dh_auto_configure
make[1]: Entering directory '/tmp/autopkgtest.G91v24/autopkgtest_tmp'
mkdir -p "_build"
cp -a /usr/share/gocode/src "_build"
make[1]: Leaving directory '/tmp/autopkgtest.G91v24/autopkgtest_tmp'
   debian/rules override_dh_auto_build
make[1]: Entering directory '/tmp/autopkgtest.G91v24/autopkgtest_tmp'
dh_auto_build -- -tags "pkcs11"
 cd _build && go install -gcflags=all=\"-trimpath=/tmp/autopkgtest.G91v24/autopkgtest_tmp/_build/src\" -asmflags=all=\"-trimpath=/tmp/autopkgtest.G91v24/autopkgtest_tmp/_build/src\" -v -p 1 -tags pkcs11 github.com/theupdateframework/notary github.com/theupdateframework/notary/client github.com/theupdateframework/notary/client/changelist github.com/theupdateframework/notary/cmd/escrow github.com/theupdateframework/notary/cmd/notary github.com/theupdateframework/notary/cmd/notary-server github.com/theupdateframework/notary/cmd/notary-signer github.com/theupdateframework/notary/cryptoservice github.com/theupdateframework/notary/passphrase github.com/theupdateframework/notary/proto github.com/theupdateframework/notary/server github.com/theupdateframework/notary/server/errors github.com/theupdateframework/notary/server/handlers github.com/theupdateframework/notary/server/snapshot github.com/theupdateframework/notary/server/storage github.com/theupdateframework/notary/server/timestamp github.com/theupdateframework/notary/signer github.com/theupdateframework/notary/signer/api github.com/theupdateframework/notary/signer/client github.com/theupdateframework/notary/signer/keydbstore github.com/theupdateframework/notary/storage github.com/theupdateframework/notary/storage/rethinkdb github.com/theupdateframework/notary/trustmanager github.com/theupdateframework/notary/trustmanager/remoteks github.com/theupdateframework/notary/trustmanager/yubikey github.com/theupdateframework/notary/trustpinning github.com/theupdateframework/notary/tuf github.com/theupdateframework/notary/tuf/data github.com/theupdateframework/notary/tuf/signed github.com/theupdateframework/notary/tuf/testutils github.com/theupdateframework/notary/tuf/testutils/interfaces github.com/theupdateframework/notary/tuf/testutils/keys github.com/theupdateframework/notary/tuf/utils github.com/theupdateframework/notary/tuf/validation github.com/theupdateframework/notary/utils github.com/theupdateframework/notary/version
src/github.com/docker/distribution/digestset/set.go:9:2: cannot find package "github.com/opencontainers/go-digest" in any of:
 /tmp/autopkgtest.G91v24/autopkgtest_tmp/_build/src/github.com/docker/distribution/vendor/github.com/opencontainers/go-digest (vendor tree)
 /usr/lib/go-1.12/src/github.com/opencontainers/go-digest (from $GOROOT)
 /tmp/autopkgtest.G91v24/autopkgtest_tmp/_build/src/github.com/opencontainers/go-digest (from $GOPATH)
src/github.com/docker/distribution/blobs.go:13:2: cannot find package "github.com/opencontainers/image-spec/specs-go/v1" in any of:
 /tmp/autopkgtest.G91v24/autopkgtest_tmp/_build/src/github.com/docker/distribution/vendor/github.com/opencontainers/image-spec/specs-go/v1 (vendor tree)
 /usr/lib/go-1.12/src/github.com/opencontainers/image-spec/specs-go/v1 (from $GOROOT)
 /tmp/autopkgtest.G91v24/autopkgtest_tmp/_build/src/github.com/opencontainers/image-spec/specs-go/v1 (from $GOPATH)
dh_auto_build: cd _build && go install -gcflags=all=\"-trimpath=/tmp/autopkgtest.G91v24/autopkgtest_tmp/_build/src\" -asmflags=all=\"-trimpath=/tmp/autopkgtest.G91v24/autopkgtest_tmp/_build/src\" -v -p 1 -tags pkcs11 github.com/theupdateframework/notary github.com/theupdateframework/notary/client github.com/theupdateframework/notary/client/changelist github.com/theupdateframework/notary/cmd/escrow github.com/theupdateframework/notary/cmd/notary github.com/theupdateframework/notary/cmd/notary-server github.com/theupdateframework/notary/cmd/notary-signer github.com/theupdateframework/notary/cryptoservice github.com/theupdateframework/notary/passphrase github.com/theupdateframework/notary/proto github.com/theupdateframework/notary/server github.com/theupdateframework/notary/server/errors github.com/theupdateframework/notary/server/handlers github.com/theupdateframework/notary/server/snapshot github.com/theupdateframework/notary/server/storage github.com/theupdateframework/notary/server/timestamp github.com/theupdateframework/notary/signer github.com/theupdateframework/notary/signer/api github.com/theupdateframework/notary/signer/client github.com/theupdateframework/notary/signer/keydbstore github.com/theupdateframework/notary/storage github.com/theupdateframework/notary/storage/rethinkdb github.com/theupdateframework/notary/trustmanager github.com/theupdateframework/notary/trustmanager/remoteks github.com/theupdateframework/notary/trustmanager/yubikey github.com/theupdateframework/notary/trustpinning github.com/theupdateframework/notary/tuf github.com/theupdateframework/notary/tuf/data github.com/theupdateframework/notary/tuf/signed github.com/theupdateframework/notary/tuf/testutils github.com/theupdateframework/notary/tuf/testutils/interfaces github.com/theupdateframework/notary/tuf/testutils/keys github.com/theupdateframework/notary/tuf/utils github.com/theupdateframework/notary/tuf/validation github.com/theupdateframework/notary/utils github.com/theupdateframework/notary/version returned exit code 1
make[1]: Leaving directory '/tmp/autopkgtest.G91v24/autopkgtest_tmp'
make[1]: *** [debian/rules:25: override_dh_auto_build] Error 255
make: *** [debian/rules:12: build] Error 2
autopkgtest [09:46:36]: test command1: -----------------------]

summary: - DEP8 failure/regression in arm64 and armhf
+ DEP8 failure/regression in nspr on arm64 and armhf
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

This was triggered by:
- sync of newer nspr
- merge of newer nss
They all fail the same way.

I did run this with/without the elements from proposed - it just is broken before any or "our" changes.

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

The test history indicates this might be due to some golang changes and indeed the entry point to the test is /usr/bin/dh_golang_autopkgtest.

While autopkgtest says:
  autopkgtest [10:12:21]: test command1: preparing testbed
as usual.
There actually is no debian/test* at all, so this must be something go-special that I haven't encountered yet.

# rerun tests
$ cd /tmp/autopkgtest.v7GzBZ/build.EOf/src
$ mkdir /tmp/autopkgtest.v7GzBZ/autopkgtest_tmp2
$ export AUTOPKGTEST_TMP=/tmp/autopkgtest.v7GzBZ/autopkgtest_tmp2
...
leads to the same breakage as we see in the autopkgtest running on the infrastructure

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

As I expected this is the actual go build that breaks.
The package atm is also FTBFS in focal with the same error.

Buildlog: http://paste.ubuntu.com/p/dfYqvVhVBh/

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

We are currently on golang 1.12.12, upstream has fixes in that regard but while trying to identify I found issue [1] and think this is what we face atm. There isn't a solution yet and my go-foo is too low.

This also affects Debian [2] and I'll file a bug there as well for awareness.
The tests (actually the rebuild in the tests) fail the same way as in Ubuntu.

[1]: https://github.com/theupdateframework/notary/issues/1469
[2]: https://ci.debian.net/packages/n/notary/unstable/amd64/

Changed in nspr (Ubuntu):
status: New → Invalid
Changed in notary (Debian):
status: Unknown → New
Changed in notary (Debian):
status: New → Confirmed
tags: added: server-next
Revision history for this message
Bryce Harrington (bryce) wrote :
Revision history for this message
Andreas Hasenack (ahasenack) wrote :

According to that commit, it's not yet enough.

Revision history for this message
Andreas Hasenack (ahasenack) wrote :

It's a force-badtest across the board:

ubuntu-release:force-badtest notary/0.6.1~ds1-4

revno: 4077
committer: Steve Langasek <email address hidden>
branch nick: hints-ubuntu
timestamp: Wed 2019-11-13 15:35:28 -0800
message:
  badtest notary

Changed in notary (Debian):
status: Confirmed → Fix Released
Revision history for this message
Paride Legovini (paride) wrote :

Fix released in Focal with version 0.6.1~ds2-5.

Changed in notary (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.