Ubuntu

Attempting to upgrade nspluginwrapper via apt-get fails with "error exit status 139" and a Segmentation fault

Reported by jdb2 on 2011-05-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nspluginwrapper (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: nspluginwrapper

Attempting a "sudo apt-get -f" on my system results in the following :

"
jdb2@aleph0:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libjna-java libqzeitgeist0 junit4 libgnome2-vfs-perl esound-clients g++-4.4 libgnomevfs2-extra javahelp2
  firefox-branding libsexy2 libx264-98 libfelix-framework-java libexempi3 libmatroska2 libdbusmenu-gtk1
  libiptcdata0 libgnome2-canvas-perl libwildmidi0 libfelix-main-java openoffice.org-l10n-common
  libswing-layout-java visualvm libsoundtouch1c2 libgnome2-perl libhamcrest-java libequinox-osgi-java libebml2
  libnb-platform12-java libstdc++6-4.4-dev
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up nspluginwrapper (1.2.2-0ubuntu9) ...
plugin dirs:
Auto-update plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
Segmentation fault
dpkg: error processing nspluginwrapper (--configure):
 subprocess installed post-installation script returned error exit status 139
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          dpkg: dependency problems prevent configuration of acroread:
 acroread depends on nspluginwrapper; however:
  Package nspluginwrapper is not configured yet.
dpkg: error processing acroread (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nspluginwrapper-dbgsym:
 nspluginwrapper-dbgsym depends on nspluginwrapper (= 1.2.2-0ubuntu9); however:
  Package nspluginwrapper is not configured yet.
dpkg: error processing nspluginwrapper-dbgsym (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 nspluginwrapper
 acroread
 nspluginwrapper-dbgsym
E: Sub-process /usr/bin/dpkg returned an error code (1)
"

I've traced the problem to a call to the installed nspluginwrapper in the postinst script, specifically "nspluginwrapper -a -v -u" which generates the segfault. Debugging output from GDB and catchsegv are attached.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: nspluginwrapper 1.2.2-0ubuntu9
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Uname: Linux 2.6.38-9-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue May 10 12:56:21 2011
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nspluginwrapper
UpgradeStatus: Upgraded to natty on 2011-05-09 (0 days ago)

jdb2 (jonathanbusby) wrote :

Here is a workaround :

Get the source to nspluginwrapper=1.2.2-0ubuntu9 :

mkdir ~/tmp
cd ~/tmp
apt-get source nspluginwrapper

Untar the source and apply the patches :

tar xvzf nspluginwrapper_1.2.2.orig.tar.gz
zcat nspluginwrapper_1.2.2-0ubuntu9.diff.gz | patch -p1

Compile the source with debugging information -- this seems to "fix" the crash for some reason :

cd nspluginwrapper-1.2.2
export CFLAGS="-g" ; export CXXFLAGS="-g"
./configure --disable-strip
make -j [NUMBER OF PROCESSORS OR CORES YOU HAVE]

Back up your current nspluginwrapper install :

sudo mv /usr/bin/nspluginwrapper /usr/bin/nspluginwrapper.bak

Create a symlink to the newly compiled nspluginwrapper :

sudo ln -s /home/[YOUR USER NAME]/tmp/nspluginwrapper-1.2.2/npconfig /usr/bin/nspluginwrapper

Now run apt-get install -f :

sudo apt-get install -f

You should get output similar to this ( depending on what packages you have attempted to install ) :

jdb2@aleph0:~/tmp/nspluginwrapper-1.2.2$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libjna-java libqzeitgeist0 junit4 libgnome2-vfs-perl esound-clients g++-4.4 libgnomevfs2-extra javahelp2
  firefox-branding libsexy2 libx264-98 libfelix-framework-java libexempi3 libmatroska2 libdbusmenu-gtk1
  libiptcdata0 libgnome2-canvas-perl libwildmidi0 libfelix-main-java openoffice.org-l10n-common
  libswing-layout-java visualvm libsoundtouch1c2 libgnome2-perl libhamcrest-java libequinox-osgi-java
  libebml2 libnb-platform12-java libstdc++6-4.4-dev
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up nspluginwrapper (1.2.2-0ubuntu9) ...
plugin dirs:
Auto-update plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
Auto-update plugins from /usr/lib64/mozilla/plugins
Looking for plugins in /usr/lib64/mozilla/plugins
Auto-update plugins from /usr/lib/firefox/plugins
Looking for plugins in /usr/lib/firefox/plugins
Auto-update plugins from /usr/lib64/firefox/plugins
Looking for plugins in /usr/lib64/firefox/plugins
Auto-update plugins from /root/.mozilla/plugins
Looking for plugins in /root/.mozilla/plugins
Setting up acroread (9.4.2-0natty1) ...
nspluginwrapper: no appropriate viewer found for /opt/Adobe/Reader9/Browser/intellinux/nppdf.so
nspluginwrapper: no appropriate viewer found for /opt/Adobe/Reader9/Browser/intellinux/nppdf.so
Setting up nspluginwrapper-dbgsym (1.2.2-0ubuntu9) ...

Worked like a charm for me.

amichair (amichai2) wrote :

I was hit by this bug as well during the upgrade to Natty - was pretty scary to see the entire upgrade process fail because of this, but fortunately it looks like nothing else was affected and the upgrade otherwise went ok (I hope).

I just wanted to share a simpler workaround I found, which may help find the culprit as well:

before running the upgrade (or "apt-get install -f" if it's too late and it already broke), just move the files under /usr/lib/mozilla/plugins/ to somewhere else (or rename the plugins folder and create an empty one in its place), and after installation/fixing is complete, move them back in place.

FWIW, I played around with this and found that the plugin to blame in my case was skypebuttons.so - moving it alone was enough to prevent the failure. I don't know if this is the same one causing trouble for others too. In fact I have no idea what it is - it seems to be a Kopete plugin (not anything from Skype itself), and I don't even use Kopete...

Anyway, I hope this helps someone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers