subprocess installed post-installation script returned error exit status 139

Bug #773818 reported by Bogdan Bivolaru on 2011-04-30
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nspluginwrapper (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

I just did a dist-upgrade when saw a pop up saying "dist-upgrade is available"

From /var/log/dist-upgrade/main.log :
2011-04-29 23:12:28,622 ERROR got an error from dpkg for pkg: 'nspluginwrapper': 'subprocess installed post-installation script returned error exit status 139'
2011-04-29 23:12:28,622 DEBUG running apport_pkgfailure() nspluginwrapper: subprocess installed post-installation script returned error exit status 139
2011-04-29 23:12:28,658 ERROR got an error from dpkg for pkg: 'nspluginwrapper': 'subprocess installed post-installation script returned error exit status 139'
2011-04-29 23:16:55,036 WARNING no activity on terminal for 240 seconds (Configuring nspluginwrapper)
2011-04-29 23:16:55,245 ERROR got an error from dpkg for pkg: 'flashplugin-installer': 'dependency problems - leaving unconfigured'
2011-04-29 23:16:55,245 DEBUG running apport_pkgfailure() flashplugin-installer: dependency problems - leaving unconfigured
2011-04-29 23:16:55,265 ERROR got an error from dpkg for pkg: 'flashplugin-installer': 'dependency problems - leaving unconfigured'
2011-04-29 23:17:10,365 DEBUG got a conffile-prompt from dpkg for file: '/etc/kde4/kdm/kdmrc'
2011-04-29 23:19:38,227 ERROR Exception during pm.DoInstall()
Traceback (most recent call last):
  File "/tmp/update-manager-bpWh8X/DistUpgradeView.py", line 202, in run
    res = pm.do_install(self.writefd)
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
2011-04-29 23:19:38,276 ERROR SystemError from cache.commit(): installArchives() failed
2011-04-29 23:19:38,276 ERROR found exception: 'E:Sub-process /usr/bin/dpkg returned an error code (1)'
2011-04-29 23:19:38,277 DEBUG can't find apport
2011-04-30 06:32:19,041 DEBUG enabling apt cron job
2011-04-30 06:32:19,054 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
2011-04-30 06:32:23,726 DEBUG enabling apt cron job

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Here is the error
Setting up nspluginwrapper (1.2.2-0ubuntu9) ...
plugin dirs: :/var/lib/flashplugin-installer/
Auto-update plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
Segmentation fault
dpkg: error processing nspluginwrapper (--configure):
 subprocess installed post-installation script returned error exit status 139

moving to nspluginwrapper.

summary: - Update manager package could not be installed while Upgrading
- distribution from 10.10 to 11.04
+ subprocess installed post-installation script returned error exit status
+ 139
affects: update-manager (Ubuntu) → nspluginwrapper (Ubuntu)
Marius Kruger (amanica) wrote :

I saw on http://askubuntu.com/questions/37947/crash-during-installation-of-flashplugin-installer-after-upgrade
that "This was caused by the google-talkplugin package. Uninstalled it and the flashplugin-installer worked perfectly. After that I could re-install google-talkplugin."
(I have not tried it yet)

Marius Kruger (amanica) wrote :

I tried it now: after removing google-talkplugin, flashplugin-installer could finish --configuring again.

Nikolaus Demmel (nikolaus) wrote :

I just had the same issue when updating, though I dont think i have google-talkplugin installed. Any ideas?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers