nspluginwrapper install failed during upgrade to 11.04

Bug #773209 reported by Jeff Hiatt on 2011-04-29
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nspluginwrapper (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

During upgrade to 11.04, I received the following Error dialog: Could not install 'nspluginwrapper'. The upgrade will continue but the 'nspluginwrapper' package mayu not be in a working state. Please consider submitting a bug report about it. "subprocess installed post-installation script returned error exit status 139'

affects: update-manager (Ubuntu) → nspluginwrapper (Ubuntu)

I had this same issue, only when upgrading with Kubuntu. I reported the bug #774772, which can be considered a duplicate: https://bugs.launchpad.net/bugs/774772

Download full text (3.7 KiB)

Valgrind shows this as the result:
$ valgrind /usr/bin/nspluginwrapper -a -v -u
==19997== Memcheck, a memory error detector
==19997== Copyright (C) 2002-2010, and GNU GPL'd, by Julian Seward et al.
==19997== Using Valgrind-3.6.1 and LibVEX; rerun with -h for copyright info
==19997== Command: /usr/bin/nspluginwrapper -a -v -u
==19997==
Auto-update plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
==19997== Invalid free() / delete / delete[]
==19997== at 0x4C282ED: free (vg_replace_malloc.c:366)
==19997== by 0x511F564: _dlerror_run (dlerror.c:160)
==19997== by 0x511F099: dlsym (dlsym.c:71)
==19997== by 0x4017E0: ??? (in /usr/lib/nspluginwrapper/x86_64/linux/npconfig)
==19997== by 0x401901: ??? (in /usr/lib/nspluginwrapper/x86_64/linux/npconfig)
==19997== by 0x401660: ??? (in /usr/lib/nspluginwrapper/x86_64/linux/npconfig)
==19997== by 0x402F11: ??? (in /usr/lib/nspluginwrapper/x86_64/linux/npconfig)
==19997== by 0x403B6E: ??? (in /usr/lib/nspluginwrapper/x86_64/linux/npconfig)
==19997== by 0x5340EFE: (below main) (libc-start.c:226)
==19997== Address 0x1 is not stack'd, malloc'd or (recently) free'd
==19997==
Auto-update plugins from /usr/lib64/mozilla/plugins
Looking for plugins in /usr/lib64/mozilla/plugins
==19997== Invalid read of size 8
==19997== at 0x101062C6: ??? (in /opt/google/talkplugin/libnpgoogletalk64.so)
==19997== by 0x5DEC6FF: ???
==19997== by 0x535BD3C: __cxa_finalize (cxa_finalize.c:56)
==19997== by 0x10101162: ??? (in /opt/google/talkplugin/libnpgoogletalk64.so)
==19997== by 0x1011E7C0: ??? (in /opt/google/talkplugin/libnpgoogletalk64.so)
==19997== by 0x401470B: _dl_close (dl-close.c:748)
==19997== by 0x400E745: _dl_catch_error (dl-error.c:178)
==19997== by 0x511F52B: _dlerror_run (dlerror.c:164)
==19997== by 0x511F00E: dlclose (dlclose.c:48)
==19997== by 0x401888: ??? (in /usr/lib/nspluginwrapper/x86_64/linux/npconfig)
==19997== by 0x401901: ??? (in /usr/lib/nspluginwrapper/x86_64/linux/npconfig)
==19997== by 0x401660: ??? (in /usr/lib/nspluginwrapper/x86_64/linux/npconfig)
==19997== Address 0x8 is not stack'd, malloc'd or (recently) free'd
==19997==
==19997==
==19997== Process terminating with default action of signal 11 (SIGSEGV): dumping core
==19997== Access not within mapped region at address 0x8
==19997== at 0x101062C6: ??? (in /opt/google/talkplugin/libnpgoogletalk64.so)
==19997== by 0x5DEC6FF: ???
==19997== by 0x535BD3C: __cxa_finalize (cxa_finalize.c:56)
==19997== by 0x10101162: ??? (in /opt/google/talkplugin/libnpgoogletalk64.so)
==19997== by 0x1011E7C0: ??? (in /opt/google/talkplugin/libnpgoogletalk64.so)
==19997== by 0x401470B: _dl_close (dl-close.c:748)
==19997== by 0x400E745: _dl_catch_error (dl-error.c:178)
==19997== by 0x511F52B: _dlerror_run (dlerror.c:164)
==19997== by 0x511F00E: dlclose (dlclose.c:48)
==19997== by 0x401888: ??? (in /usr/lib/nspluginwrapper/x86_64/linux/npconfig)
==19997== by 0x401901: ??? (in /usr/lib/nspluginwrapper/x86_64/linux/npconfig)
==19997== by 0x401660: ??? (in /usr/lib/nspluginwrapper/x86_64/linux/npconfig)

gdb shows:
#0 __libc_free (mem=0x...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers