MASTER package nspluginwrapper 1.2.2-0ubuntu4 failed to install/upgrade: wrapper update crashes when gcu-plugin is installed

Bug #357965 reported by Leonard Michlmayr on 2009-04-08
118
This bug affects 24 people
Affects Status Importance Assigned to Milestone
nspluginwrapper (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: nspluginwrapper

Output:
Richte nspluginwrapper ein (1.2.2-0ubuntu4) ...
plugin dirs:
Auto-update plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
Update plugin /usr/lib/mozilla/plugins/flashplugin-alternative.so
Update plugin /usr/lib/mozilla/plugins/npwrapper.libflashplayer.so
Auto-update plugins from /usr/lib64/mozilla/plugins
Looking for plugins in /usr/lib64/mozilla/plugins
Update plugin /usr/lib64/mozilla/plugins/flashplugin-alternative.so
Update plugin /usr/lib64/mozilla/plugins/npwrapper.libflashplayer.so
Auto-update plugins from /usr/lib/firefox/plugins
Looking for plugins in /usr/lib/firefox/plugins
Update plugin /usr/lib/firefox/plugins/flashplugin-alternative.so
Update plugin /usr/lib/firefox/plugins/npwrapper.libflashplayer.so
Segmentation fault (core dumped)
dpkg: Fehler beim Bearbeiten von nspluginwrapper (--configure):
 Unterprozess post-installation script gab den Fehlerwert 139 zurück

ProblemType: Package
Architecture: amd64
DistroRelease: Ubuntu 9.04
ErrorMessage: Unterprozess post-installation script gab den Fehlerwert 139 zurück
NonfreeKernelModules: nvidia
Package: nspluginwrapper 1.2.2-0ubuntu4
SourcePackage: nspluginwrapper
Title: package nspluginwrapper 1.2.2-0ubuntu4 failed to install/upgrade: Unterprozess post-installation script gab den Fehlerwert 139 zurück
Uname: Linux 2.6.28-11-generic x86_64

Alexander Sack (asac) wrote :

can you reproduce this crash by running sudo nspluginwrapper -u -v -a ?

Changed in nspluginwrapper (Ubuntu):
status: New → Incomplete

Yes.
Segmentation fault.

Are there any -dbg packages that I can install to help debugging?
I will attach ltrace and strace output.

Ok, I fixed this problem by removing the package gcu-plugin 0.8.6-1ubuntu5.

Maybe nspluginwrapper should conflict with gcu-plugin (<= 0.8.6-1ubuntu5).

The crash happens in libselinux during dlclose() of libmozgcu.so:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fe7e3b396f0 (LWP 14432)]
0x00007fe7d811d83d in fini_context_translations () at setrans_client.c:211
211 setrans_client.c: No such file or directory.
 in setrans_client.c
(gdb) bt full
#0 0x00007fe7d811d83d in fini_context_translations () at setrans_client.c:211
No locals.
#1 0x00007fe7d81102ff in __do_global_dtors_aux () from /lib/libselinux.so.1
No locals.
#2 0x0000000000000000 in ?? ()

and seems to be a duplicate of #237156. I can confirm that dlclose() works with the patched libselinux1 package.

Alexander Sack (asac) on 2009-04-30
Changed in nspluginwrapper (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
summary: package nspluginwrapper 1.2.2-0ubuntu4 failed to install/upgrade:
- Unterprozess post-installation script gab den Fehlerwert 139 zurück
+ wrapper update crashes when gcu-plugin is installed
summary: - package nspluginwrapper 1.2.2-0ubuntu4 failed to install/upgrade:
+ MASTER package nspluginwrapper 1.2.2-0ubuntu4 failed to install/upgrade:
wrapper update crashes when gcu-plugin is installed
tec (tecumtah) wrote :

I seem to have the same bug on my system on Ubuntu 10.10 amd64. Unfortunately I cannot remove gcu-plugin as it is not installed. I am not really sure about the implications as acroread and flash are happily working. Only thing is that the error messages are a bit annoying each time I use apt or aptitude or alike programs. I'll be happy to provide more information if you could tell me what you need. Thanks.

sudo apt-get remove gcu-plugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package gcu-plugin is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up nspluginwrapper (1.2.2-0ubuntu7) ...
plugin dirs:
Auto-update plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
Segmentation fault
dpkg: error processing nspluginwrapper (--configure):
 subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of acroread:
 acroread depends on nspluginwrapper; however:
  Package nspluginwrapper is not configured yet.
dpkg: error processing acroread (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 nspluginwrapper
 acroread
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ollea (ollea) wrote :

I solved the problem by uninstalling GoogleTalk.

tec (tecumtah) wrote :

I can confirm that "sudo apt-get remove google-talkplugin" solved the problem on my box. However, reinstalling google-talkplugin later did not make the problem appear again.

Justin Lawrence (jl-irj) wrote :

"sudo apt-get remove google-talkplugin" fixed it for me as well

Same here, removing google-talkplugin fixed the problem.

Guillaume Millet (guimillet) wrote :

Same here, removing google-talkplugin fixed the problem.

Vladimir Rutsky (rutsky) wrote :

Same here, removing google-talkplugin fixed the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers