nspluginwrapper 1.1.0 does not support wmode correctly with Flash 10 RC2

Bug #272286 reported by Conn O Griofa on 2008-09-19
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nspluginwrapper (Fedora)
Fix Released
Medium
nspluginwrapper (Ubuntu)
Wishlist
Unassigned
Nominated for Karmic by zyodei
Nominated for Lucid by zyodei

Bug Description

Binary package hint: nspluginwrapper

Hello,

I have been testing the i386 build of nspluginwrapper_1.1.0-0ubuntu2 using the latest release candidate (10.0.12.10) of the flash plugin, and it does not support wmode correctly. If you open multiple pages with flash content in Firefox, the npviewer.bin process will segfault.

Without nspluginwrapper, flash 10rc2 (10.0.12.10) is 100% stable on my system.

My configuration: Intrepid i386 install with latest updates, with custom flashplugin-nonfree package (debdiff awaiting review from bug #257403). Using PulseAudio ALSA plugins (asoundconf set-pulseaudio is set) and libflashsupport is *not* installed.

Expected results: flash 10 rc2 works correctly with and without nspluginwrapper installed.
Actual results: flash 10rc2 crashes with nspluginwrapper (see above), does not crash without nspluginwrapper.

Workaround: edit src/npw-viewer.c and change "ALLOW_WINDOWLESS_PLUGINS 1" to ""ALLOW_WINDOWLESS_PLUGINS 0" - patch attached.

Description of problem:
Recently I was testing the latest labs.adobe.com flash plugin 10.0.0.569. I was pointed by abobe folks that to have better experience I should be using firefox trunk, and so I did. It turns out that there are some problems with the wrapper when wmode is coupled with flash video - the embedded video is not displayed. Using the i686 build of firefox solves the problem. The following message is displayed in the console with x86_64 build and the wrapper:

*** NSPlugin Viewer *** ERROR: could not reconstruct XVisual from visualID

Version-Release number of selected component (if applicable):
flash-plugin-10.0.0.569-release.i386
nspluginwrapper-1.1.0-5.fc9.x86_64
nspluginwrapper-1.1.0-5.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. Install the packages listed above
2. Get a firefox nightly build (I was using 20080814)
3. Go to e.g. http://politbiuro.pl/politbiuro/1,85402,5580837,Prezydent__Nie_boje_sie__Pracownik_BOR_u__To_glupota.html

Actual results:
White spaces are displayed where two video clips should be embedded

Expected results:
Videos are shown properly

It's going to be fixed in the upcoming firefox update (3.0.2).

Download full text (11.4 KiB)

That's with 3.0.2 build 6. Error still present. Looks like nspluginwrapper issue to me since without the wrapper videos display fine. (Sorry it's ASSIGNED, I can't switch it back to NEW).

*** NSPlugin Viewer *** ERROR: could not reconstruct XVisual from visualID
*** NSPlugin Viewer *** ERROR: could not reconstruct XVisual from visualID
*** NSPlugin Viewer *** ERROR: NPN_InvalidateRect() invoke: Message type invalid
*** NSPlugin Wrapper *** ERROR: NPP_WriteReady() invoke: Message type invalid
*** NSPlugin Wrapper *** ERROR: NPP_Write() invoke: Message type invalid
*** NSPlugin Wrapper *** ERROR: NPP_DestroyStream() invoke: Message type invalid

(firefox-bin:5506): GLib-CRITICAL **: g_hash_table_remove_internal: assertion `hash_table != NULL' failed
*** NSPlugin Wrapper *** ERROR: NPP_URLNotify() invoke: Połączenie zerwane przez drugą stronę
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_HandleEvent() invoke: Connection closed
*** NSPlugin Wra...

Looks like now I can. Please note that now I am testing with flash 10.0.12.10. I also tried 20080916 trunk firefox build and the problem is still present, but only these two errors are displayed:
*** NSPlugin Viewer *** ERROR: could not reconstruct XVisual from visualID
*** NSPlugin Viewer *** ERROR: could not reconstruct XVisual from visualID

This error message means that the flash-plugin is recently dead.

The firefox/nspluginwrapper combination support windowless flash plugin, but the windowless flash can crash as well as the windowed one and when this happens (very often) you'll see this message.

It has nothing to do with the windowless mode, it's just a flash crash.

Then why it does crash with nspluginwrapper disabled and works fine without it? Do you want me to carry out some additional tests?

Flash crashes with nspluginwrapper because the NPAPI emulation provided by nspluginwrapper is not 100% accurate. Unfortunately we can't fix it reliably because there are some limitations given by the RPC interface architecture and closed-source flash code...

Well, I guess no WMODE for me then until Adobe releases a 64-bit plugin. CLOSED CANTFIX?

Conn O Griofa (psyke83) wrote :

Alexander,

Please note that this patch will not apply to the series due to interference from other patches. It applies correctly if it is placed earlier (e.g. between "003_update_help_info.diff" and "004_fix_threading.diff" in the series file).

Changed in nspluginwrapper:
status: Unknown → Confirmed
ktp420 (ktp420) wrote :

you can disable windowless mode in the plugin itself by adding following to /etc/adobe/mms.cfg
   WindowlessDisable=true

Conn O Griofa (psyke83) wrote :

ktp420,

We don't want to do that, because it will disable windowless mode for 32 bit users as well. Disabling support only in nspluginwrapper is a better workaround.

ktp420 (ktp420) wrote :

I agree...just wanted to provide another workaround until it is fixed.

Daniel T Chen (crimsun) wrote :

I don't believe we need this change now that FF 3.0.2 is in the repos.

Changed in nspluginwrapper:
importance: Undecided → Wishlist
status: New → Incomplete
Conn O Griofa (psyke83) wrote :

Daniel,

Unfortunately no. I am using the latest version (1.9.0.2+build6+nobinonly-0ubuntu2) and it still exhibits the crashing.

Bug #239182 already deals with the original windowless mode bug in Firefox that was discovered (and fixed) in 3.0.2, and it impacted all users (with and without nspluginwrapper).

This bug is dealing with an incompatibility between nspluginwrapper 1.1.0 and the newest Flash 10 rc2 (10.0.12.10). This incompatibility seems to have been introduced somewhere between beta 2 and rc2 of the plugin.

Changed in nspluginwrapper:
status: Incomplete → Confirmed
ktp420 (ktp420) wrote :

There might be some good news...Gwenole has been working on trying to provide better support for wmode. He might have a fix for the issue...

https://www.redhat.com/archives/nspluginwrapper-devel-list/2008-October/msg00004.html

Daniel T Chen (crimsun) on 2008-10-08
Changed in nspluginwrapper:
status: Confirmed → In Progress
Dave Gilbert (ubuntu-treblig) wrote :

I still have some problems with Flash with nspluginwrapper 1.1.0-0ubuntu2 and flash 10.0.12.10ubuntu1; as it always has Flash occasionally dies in Firefox and needs a restart of Firefox;
but an odd one I have on Intrepid is that one particular flash game I've played for ages on Hardy very rarely starts:

Desktop tower defense: http://www.handdrawngames.com/DesktopTD/Game.asp

However, that runs pretty reliably on the same system using Konqueror (still 64bit).
It is however painfully slow - and I don't know if that's Konqueror or some other change in Intrepid.

Dave

This seems to have been fixed with the latest update. Way to go folks!

Changed in nspluginwrapper:
status: Confirmed → Fix Released
Conn O Griofa (psyke83) on 2008-10-16
Changed in nspluginwrapper:
status: In Progress → Fix Released
zyodei (buddhaflow) wrote :

I just wanted to say, I think this bug should be upgraded...I am running Mint 8 x64 (AMD64, Karmic) and this bug renders firefox totally inoperable.

Conn's link above only seems to address Intrepid and Jaunty.

I was not able to "locate" either /etc/adobe/mms.cfg

or

nspluginwrapper-1.1.0/src/npw-viewer.c (I assume the second would require recompiling, which I don't know how to do)

For a new user, this can be an absolute dealbreaker for Linux, and should really be upgraded to a higher priority fix. Firefox is the core application of the OS for most users, and people expect Flash to just "work", not crash the browser without any message or explanation over and over again.

Changed in nspluginwrapper (Fedora):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.