Ubuntu

npviewer.bin crashed with SIGSEGV in g_type_check_instance_cast()

Reported by peter b on 2008-04-06
30
Affects Status Importance Assigned to Milestone
flashplugin-nonfree (Ubuntu)
Undecided
Unassigned
nspluginwrapper (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: nspluginwrapper

Heron 804 beta amd64 ww/latest updates : nspluginwrapper crash with flashplugin_nonfree 9.0.115

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Sun Apr 6 10:25:05 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
Package: nspluginwrapper 0.9.91.5-2ubuntu1
PackageArchitecture: amd64
ProcCmdline: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin --plugin /usr/lib/flashplugin-nonfree/libflashplayer.so --connection /org/wrapper/NSPlugins/libflashplayer.so/7718-8
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: nspluginwrapper
StacktraceTop:
 g_type_check_instance_cast ()
 ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
 ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
 ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
 ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
Title: npviewer.bin crashed with SIGSEGV in g_type_check_instance_cast()
Uname: Linux 2.6.24-15-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video

peter b (b1pete) wrote :
liquidator87 (liquidator87) wrote :

I confirm this... it happens quite often...

Changed in nspluginwrapper:
status: New → Confirmed
Ignacio Larrain (ilarrain) wrote :

I confirm this.

The problem was present before, but after upgrade to FF 3.0 b5 (before I was using FF 3.0 b4), the bug is quite recurrent. All flash animations disappear and flash does not come back until FF restart.

The bug often appears while closing a tab with a flash animation on it.

John Dong (jdong) wrote :

Indeed this seems strongly correlated with Firefox 3.0beta5 -- this didn't happen for me often in beta4 but in beta5 it's literally every flash tab closed triggers this.

I have that issue every time i start firefox, since i have several tabs using flash to be remembered by firefox. It started with Firefox 3 beta 5 after the April 07 update in hardy. Anyway, npviewer.bin is using too many resources and looks quite unstable with firefox 3 @ AMD64. My processor is rarely quiet.

Good luck with this, Felipe.

StacktraceTop:?? ()
?? ()
?? ()
?? ()
?? ()

What Felipe says it's throughly true...

Scott Wegner (swegner) wrote :

I'm having this same problem, and it seems to be spurred by the Firefox 3b5 update. When I startup Firefox, I'll visit about 3-5 flash pages before flash simply stops working.

Using Hardy Beta w/ AMD64 and restricted flash + nvidia driver.

John Dong (jdong) wrote :

I'm going to mark this as release-critical to triage and fix.... Losing 64-bit Flash support is a serious regression from Firefox 3.0 beta 4.

Changed in nspluginwrapper:
importance: Undecided → High
milestone: none → ubuntu-8.04
John Dong (jdong) wrote :

I rebuilt nspluginwrapper against the latest Hardy and I've not had a Flash crash since (been testing for 12hrs or so intensively)

Can anyone else verify those results with the attached pbuilder built deb?

John Vivirito (gnomefreak) wrote :

John flash was just updated maybe we should see if it fixed itself before fixing nspluginwrapper incase its not needed?

John Dong (jdong) wrote :

John,

I already tried that earlier and got three identical segfaults with 0.9.124

mabovo (mabovo) wrote :

Using Hardy 8.04 amd64 and FF3b5 on MacBook2,1 and got this bug too.

I am testing John Dong deb to see if solve and will report progress soon.

mabovo (mabovo) wrote :

Openned four tabs in Youtube one tab in testing sun jvm, other with home banking and another one from different site using flash I haven't noticed any crashes on FF3b5

mabovo (mabovo) wrote :

In another test I relogin with FF3b5 openned in all windows trying to force it crash. X comes back and started FF3b5 without "apports".

mabovo (mabovo) wrote :

Unfortunately mozilla-mplayer provoked X to crash and relogin after trying to play a video from BBC on http://www.bbc.co.uk/languages/french/talk/video/nb_rm_greetings1_video.shtml that requires mplayerplugin-3.51 to play ram files.

It was working nice before installed nspluginwrapper .

John Dong (jdong) wrote :

MOTU-release , based on my testing over the past 24 hours I have strong reason to believe that a no-src-change rebuild gets rid of this crash.

Please do this.

peter b (b1pete) wrote :

john, I gave it a try, shortly after you posted it I installed your .deb

so far so good; I'll see how it goes further. if problems encountered I'll let you know here.

thank you.
peter b

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nspluginwrapper - 0.9.91.5-2ubuntu2

---------------
nspluginwrapper (0.9.91.5-2ubuntu2) hardy; urgency=low

  * No source change rebuild to resolve crashing against xulrunner 1.9b5
   - MOTU Release approved (LP: #212855)

 -- John Dong <email address hidden> Thu, 10 Apr 2008 14:01:35 -0400

Changed in nspluginwrapper:
status: Confirmed → Fix Released
  • unnamed Edit (1.6 KiB, text/html; charset=ISO-8859-1)

Well, It's solved. No more problems with flash and nspluginwrapper since
last updates(yesterday I think).

Congratulations!

Greetings, Felipe.

On Fri, Apr 11, 2008 at 1:35 PM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package nspluginwrapper - 0.9.91.5-2ubuntu2
>
> ---------------
> nspluginwrapper (0.9.91.5-2ubuntu2) hardy; urgency=low
>
> * No source change rebuild to resolve crashing against xulrunner 1.9b5
> - MOTU Release approved (LP: #212855)
>
> -- John Dong <email address hidden> Thu, 10 Apr 2008 14:01:35 -0400
>
> ** Changed in: nspluginwrapper (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> npviewer.bin crashed with SIGSEGV in g_type_check_instance_cast()
> https://bugs.launchpad.net/bugs/212855
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
ATTE:
Hernán Felipe De la Puente Christen
Móvil: 093199807
ICQ : 58547127
MSN : <email address hidden>
Web : http://www.udec.cl/%7Ehdelapuente

Changed in flashplugin-nonfree:
status: New → Invalid

Not that I would know if this is a crash or not, but at least I'm still seeing tons on unreaped npviewer.bins with the latest nspluginwrapper. Who's the parent here that's supposed to reap these? Firefox itself?

jmk 5129 5097 13 Jul28 ? 11:31:35 [npviewer.bin] <defunct>

byte71 (slurpsl) wrote :

I confirm, there are already problem with npviewer.bin ,it's always crash with flash animation d
dpkg -l | grep nspluginwrapper
ii nspluginwrapper 0.9.91.5-2ubuntu2
Linux 2.6.24-24-generic #1 SMP Tue Aug 18 16:22:17 UTC 2009 x86_64 GNU/Linux
the error is
 kernel: [ 6831.043795] npviewer.bin[14900]: segfault at f1a58eb4 rip f6ca64c3 rsp ee7613a0 error 4
thanks

Nero (nero66666) on 2010-01-04
Changed in nspluginwrapper (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers