npviewer.bin crashed with SIGSEGV in pthread_mutex_lock()

Bug #206432 reported by Arkansis on 2008-03-25
26
Affects Status Importance Assigned to Milestone
nspluginwrapper (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: nspluginwrapper

Description: Ubuntu hardy (development branch)
Release: 8.04

was running a flash web site using firefox 3 beta 4.
Nothing happened other than apport warning me about the error.

This Npviewer error sometime causes flash not to work in some situations

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Tue Mar 25 09:27:57 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin
NonfreeKernelModules: nvidia
Package: nspluginwrapper 0.9.91.5-2ubuntu1
PackageArchitecture: amd64
ProcCmdline: /usr/lib/nspluginwrapper/i386/linux/npviewer.bin --plugin /usr/lib/flashplugin-nonfree/libflashplayer.so --connection /org/wrapper/NSPlugins/libflashplayer.so/6353-5
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: nspluginwrapper
StacktraceTop:
 pthread_mutex_lock () from /lib32/libpthread.so.0
 ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
 ?? ()
 ?? () from /usr/lib/flashplugin-nonfree/libflashplayer.so
 ?? ()
Title: npviewer.bin crashed with SIGSEGV in pthread_mutex_lock()
Uname: Linux 2.6.24-12-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video

Arkansis (arkansis1) wrote :

StacktraceTop:pthread_mutex_lock () from /lib32/libpthread.so.0
?? ()
?? ()
?? ()
?? ()

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in nspluginwrapper:
importance: Undecided → Medium
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in nspluginwrapper:
status: Incomplete → Invalid
Robin Sheat (eythian) wrote :

I'm seeing the same issue with FF 3 RC1 (hardy-proposed). Getting a backtrace isn't possible as there is no -dbg or -dbgsyms version of the package available.

Changed in nspluginwrapper:
status: Invalid → New
Thomas Zander (thomas-e-zander) wrote :

Same here with FF3 RC1. Slightly more verbose stacktrace attached.
Pedro, is there anything more I can do to provide useful info?

Bert Van de Poel (bhack) wrote :

It still happens on hardy 64 with firefox 3.0.1 but opera doesn't seem to have the same problem (or at least not that often)

Jean.c.h (slug71) wrote :

Just booted the pc for the first time this morning, started the update manager and up popped this crash.

Using Intrepid AMD64.

Hew (hew) wrote :

I'm still getting this crash, even though I'm on Intrepid without libflashsupport. According to bug 192888, this should be fixed. Is this really a dupe, or has bug 192888 been marked incorrectly?

flashplugin-nonfree/intrepid uptodate 10.0.1.218+10.0.0.525ubuntu1
ia32-libs/intrepid uptodate 2.2ubuntu13
libflashsupport not installed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers