npconfig crashed with SIGSEGV in g_str_equal()

Bug #1105417 reported by Christopher Townsend on 2013-01-25
474
This bug affects 91 people
Affects Status Importance Assigned to Milestone
nspluginwrapper (Ubuntu)
Medium
Unassigned

Bug Description

I was trying to install the icaclient (Citirx Receiver) package and got this crash.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: nspluginwrapper 1.4.4-0ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-1.5-generic 3.8.0-rc4
Uname: Linux 3.8.0-1-generic x86_64
ApportVersion: 2.8-0ubuntu2
Architecture: amd64
Date: Fri Jan 25 15:24:37 2013
ExecutablePath: /usr/lib/nspluginwrapper/x86_64/linux/npconfig
InstallationDate: Installed on 2012-11-13 (72 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
ProcCmdline: nspluginwrapper -a -v -u
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f8ce6906958 <__strcmp_sse42+168>: pcmpeqb (%rdi),%xmm1
 PC (0x7f8ce6906958) ok
 source "(%rdi)" (0x7f8ce08602f0) in non-readable VMA region: 0x7f8ce075c000-0x7f8ce095c000 ---p /usr/lib/x86_64-linux-gnu/libroken.so.18.1.0
 destination "%xmm1" ok
SegvReason: reading VMA /usr/lib/x86_64-linux-gnu/libroken.so.18.1.0
Signal: 11
SourcePackage: nspluginwrapper
StacktraceTop:
 g_str_equal () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_hash_table_lookup () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_quark_from_static_string () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 call_init (l=l@entry=0xa33860, argc=argc@entry=4, argv=argv@entry=0x7fff69126878, env=env@entry=0x7fff691268a0) at dl-init.c:84
Title: npconfig crashed with SIGSEGV in g_str_equal()
UpgradeStatus: Upgraded to raring on 2013-01-04 (20 days ago)
UserGroups:

Christopher Townsend (townsend) wrote :
information type: Private → Public

StacktraceTop:
 g_str_equal (v1=<optimized out>, v2=<optimized out>) at /build/buildd/glib2.0-2.35.4/./glib/ghash.c:1668
 g_hash_table_lookup_node (hash_return=<synthetic pointer>, key=0x7f8ce4fa02fa, hash_table=0xa3c400) at /build/buildd/glib2.0-2.35.4/./glib/ghash.c:386
 g_hash_table_lookup (hash_table=0xa3c400, key=key@entry=0x7f8ce4fa02fa) at /build/buildd/glib2.0-2.35.4/./glib/ghash.c:1038
 quark_from_string (duplicate=0, string=0x7f8ce4fa02fa "-g-type-private--GTypeFlags") at /build/buildd/glib2.0-2.35.4/./glib/gquark.c:173
 g_quark_from_static_string (string=string@entry=0x7f8ce4fa02fa "-g-type-private--GTypeFlags") at /build/buildd/glib2.0-2.35.4/./glib/gquark.c:239

Changed in nspluginwrapper (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nspluginwrapper (Ubuntu):
status: New → Confirmed
Craig Denman (cdenman) wrote :

Confirmed same bug in kernel Ubuntu Raring 3.8.0-11 after installation of nspluginwrapper -- problem with npconfig? Flashplugin-installer is also installed.

8200 (8200) wrote :

This also happened to me with Ubuntu 13.04 AMD64 with all latest updates.

david6 (andrew-dowden) wrote :

Confirming previous post. Issue with Ubunut 13.04 64-bit, latest updates.

No specific cause / install / update yet identified.

leo_mancini (leo-mancini) wrote :

I'm using Ubuntu 13.10 and I have also attempted to install Citrix Receiver without any luck.

tags: added: saucy
tags: added: bugpattern-needed
Jonas Öhrn (jonas-ohrn) wrote :

I had same problem and it was resolved by removing some plugins I had, leaving only flashplugin-alternative.so left in /usr/lib/mozilla/plugins/

sudo apt-get --purge remove totem-mozilla rhythmbox-mozilla

tags: added: trusty
Alex Mayorga (alex-mayorga) wrote :

FWIW same thing happened to me on trusty in the next boot after following https://help.ubuntu.com/community/CitrixICAClientHowTo#Citrix_Receiver_13.0_on_Ubuntu_13.10_64-bit

188236 (christian-bernstein) wrote :

Crashed while installing Adobe Reader (and dependencies).

Anthony (cloestro) wrote :

Starting the crashing command in gdb we can see that the crash occurs while the shared object /usr/lib/mozilla/plugins/libtotem-narrowspace-plugin.so is loaded.

Unintstalling "totem-mozilla" solve the problem.

Bryan Quigley (bryanquigley) wrote :

The totem browser plugins are being removed anyway upstream [1]. I wonder if we can just remove them as well, or at least switch the default so they aren't installed.
[1] http://www.hadess.net/2014/04/good-bye-totem-browser-plugin.html

Changed in nspluginwrapper (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers