autopkgtests are still flaky

Bug #1775097 reported by Mathieu Trudel-Lapierre on 2018-06-04
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nplan (Ubuntu)
Low
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]
autopkgtests gating the netplan releases in the Ubuntu archive.

[Test case]
Validate that the tests are passing; specifically test_eth_* and test_bond_resend_igmp.

[Regression potential]
Given that this is limited to the test suite, there is only very limited chance of regression from this SRU. Specifically, this is meant to fix the test mentioned in test cases. New test failures should be investigated as potentially caused by this SRU.

---

Autopkgtests for netplan.io / nplan are still flaky, and tend to fail to run succesfully due to bad configuration rather than actually failing tests.

Fix this.

Brian Murray (brian-murray) wrote :

Are they only flaky for Xenial? I ask as that's the only release I see an upload for.

description: updated
Changed in nplan (Ubuntu):
importance: Undecided → Low

Hello Mathieu, or anyone else affected,

Accepted nplan into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nplan/0.32~16.04.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nplan (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial

Verification-done on xenial: nplan/0.32~16.04.6:

http://autopkgtest.ubuntu.com/packages/nplan lists the autopkgtest results on xenial. The tests that were flaky are now passing at first run (so no longer flaky), and are reproducible on the command-line.

arm64, s390x are permanent failures for an entirely different reason: test bed failures, due to missing wireless tools/drivers (s390x doesn't have cfg80211, armhf doesn't have iw installed, armhf waiting for tests to complete).

I feel this qualifies as validation passing.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nplan - 0.32~16.04.6

---------------
nplan (0.32~16.04.6) xenial; urgency=medium

  [ Mathieu Trudel-Lapierre ]
  * tests/integration.py: Fix autopkgtests involving bonds/bridges to do proper
    cleanup every time, so later tests don't unnecessarily wait for an
    interface not configured to be up. (LP: #1775097)

  [ Daniel Axtens ]
  * Generate udev rules files to rename devices (LP: #1770082)
    Due to a systemd issue[1], using link files to rename interfaces
    doesn't work as expected. Link files will not rename an interface
    if it was already renamed, and interfaces are renamed in initrd, so
    set-name will often not work as expected when rebooting. However,
    rules files will cause a renaming, even if the interface has been
    renamed in initrd.

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 03 Jul 2018 12:55:11 -0400

Changed in nplan (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nplan has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers