cannot route IPv6 addresses

Bug #1735944 reported by Robin Hall on 2017-12-02
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nplan (Ubuntu)
Undecided
Daniel Axtens

Bug Description

I have install Ubuntu 17.10 64 bit server and set a static IP address as well as an IPv6 address. I have also tried using DHCP6 as well. I can ping locally any address on the same VLAN. I cannot ping outside of the local addresses. This is a new install on a Dell R710 running ESXi. I have other servers that have no problem routing, this is the only server using netplan. I have tried adding a static route, setting gateway6: and neither works.

netplan config:

network:
  version: 2
  renderer: networkd
  ethernets:
    ens160:
      dhcp4: no
      dhcp6: no
      addresses: [192.168.20.20/24, "2000:2000:BEEF:FEEB::10/64"]
      gateway4: 192.168.20.1
      gateway6: 2000:2000:BEEF:FEEB::1
      nameservers:
         addresses: [192.168.100.3,192.168.20.10]

ip -6 route:

maineac@MARIADB-01:/etc/netplan$ ip -6 route
2000:2000:BEEF:FEEB::/64 dev ens160 proto kernel metric 256 pref medium
2000:2000:BEEF:FEEB::/64 dev ens160 proto ra metric 1024 pref medium
fe80::/64 dev ens160 proto kernel metric 256 pref medium
default proto static metric 1024
        nexthop via 2000:2000:BEEF:FEEB::1 dev ens160 weight 1
        nexthop via fe80::1:1 dev ens160 weight 1
        nexthop via fe80::1 dev ens160 weight 1

kernel routing table:

maineac@MARIADB-01:/etc/netplan$ route -6
Kernel IPv6 routing table
Destination Next Hop Flag Met Ref Use If
localhost/128 [::] U 256 1 0 lo
2000:2000:BEEF:FEEB::/64 [::] U 256 3 13 ens160
2000:2000:BEEF:FEEB::/64 [::] U 1024 1 0 ens160
fe80::/64 [::] U 256 2 6 ens160
[::]/0 2000:2000:BEEF:FEEB::1 UG 1024 3 6 ens160
[::]/0 fe80::1:1 UG 1024 2 4 ens160
[::]/0 fe80::1 UG 1024 3 12 ens160
[::]/0 [::] !n -1 1 51 lo
localhost/128 [::] Un 0 4 3 lo
MARIADB-01/128 [::] Un 0 2 0 lo
MARIADB-01/128 [::] Un 0 4 2 lo
MARIADB-01/128 [::] Un 0 2 0 lo
MARIADB-01/128 [::] Un 0 5 40 lo
ff00::/8 [::] U 256 5 129 ens160
[::]/0 [::] !n -1 1 53 lo

Description: Ubuntu 17.10
Release: 17.10

maineac@MARIADB-01:~$ apt-cache policy nplan
nplan:
  Installed: 0.30
  Candidate: 0.30
  Version table:
 *** 0.30 500
        500 http://us.archive.ubuntu.com/ubuntu artful/main amd64 Packages
        100 /var/lib/dpkg/status

I expect to route beyond the gateway on IPv6

I cannot get beyond local addresses.

Robin Hall (rob33-me) wrote :

I would really like to know what needs to be done to fix this. I get the same on every install and updates are quite tedious waiting for it to time out on IPv6 addresses.

I think this is "just" a syntax issue. Try quotes around the IPv6 address in gateway6. :/

Changed in nplan (Ubuntu):
status: New → Incomplete

The IPv6 should be in quotes when entering with gateway.
Hope this should work

Changed in nplan (Ubuntu):
assignee: nobody → MOHAMMED FAHAD MUSHAHID (89mfahad)
status: Incomplete → In Progress
Robin Hall (rob33-me) wrote :

Putting the gateway in quotes does not help. Still the same way.

Daniel Axtens (daxtens) wrote :

Hmm, that's really odd. I'm sorry you haven't had a solution yet.

I have a set of test containers to test ipv6 networking. My netplan config for a static IPv6 address is https://github.com/daxtens/ipv6-config-demos/blob/master/static-networkd/60-ipv6.yaml and it looks a lot like yours. It can definitely get past the next hop.

If I enter that container and dump the same info as you have:

root@static-networkd:~# ip -6 route
fd8f:1d7d:b141::/64 dev eth0 proto kernel metric 256 pref medium
fe80::/64 dev eth0 proto kernel metric 256 pref medium
default via fd8f:1d7d:b141::1 dev eth0 proto static metric 1024 pref medium

Interestingly here I'm missing all the nexthop stuff you have...

root@static-networkd:~# route -6
Kernel IPv6 routing table
Destination Next Hop Flag Met Ref Use If
fd8f:1d7d:b141::/64 [::] U 256 2 5 eth0
fe80::/64 [::] U 256 1 0 eth0
[::]/0 _gateway UG 1024 2 18 eth0
ip6-localhost/128 [::] Un 0 3 4 lo
static-networkd/128 [::] Un 0 3 20 eth0
static-networkd/128 [::] Un 0 3 8 eth0
ip6-mcastprefix/8 [::] U 256 2 76 eth0
[::]/0 [::] !n -1 1 1 lo

And again here I don't have a bunch of routes you do.

I wonder how you're ending up with the nexthop stuff. Do you have any virtual networking stuff on your host? VMs? openvswitch? Anything else that would mess with routes?

Regards,
Daniel

Changed in nplan (Ubuntu):
assignee: MOHAMMED FAHAD MUSHAHID (89mfahad) → Daniel Axtens (daxtens)
status: In Progress → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers