FTBFS nova when in /usr/src

Bug #890272 reported by Loic Dachary on 2011-11-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nova (Ubuntu)
Low
Unassigned

Bug Description

On a virgin Ubuntu oneiric

a) cd /usr/src
b) apt-get build-dep nova
c) apt-get source nova
d) cd nova-*
e) dpkg-buildpackage

What is expected: a well formed debian package

What happens instead:

IOError: [Errno 2] No such file or directory: '../../lib/pymodules/python2.7/docutils/writers/html4css1/html4css1.css'
Unable to open source file for reading ('../../lib/pymodules/python2.7/docutils/writers/html4css1/html4css1.css'). Exiting.
make[1]: *** [override_dh_auto_build] Error 1
make[1]: Leaving directory `/usr/src/nova-2011.3'
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Note: the same commands in the directory /root instead of /usr/src succeed

Loic Dachary (dachary) wrote :
description: updated
Thierry Carrez (ttx) wrote :

Not a bug in nova, affects Ubuntu packaging.
(Note that running all that as root sounds very wrong to me)

affects: nova → nova (Ubuntu)
Dave Walker (davewalker) on 2011-11-20
Changed in nova (Ubuntu):
importance: Undecided → Low
Chuck Short (zulcss) on 2012-09-11
Changed in nova (Ubuntu):
status: New → Triaged
Chuck Short (zulcss) wrote :

I dont think this is no longer a problem. Please re-open if it is.

Changed in nova (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers