nova-compute-xen depends on xen-linux-system which does not exist

Bug #873243 reported by Robie Basak on 2011-10-13
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nova (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned

Bug Description

nova-compute-xen depends on xen-linux-system which does not exist. The dependency system cannot account for the requirement that the system must be booted into dom0, so this will need to be arranged by the sysadmin manually. Packages xen-hypervisor-4.1-amd64 or xen-hypervisor-4.1-i386 can help with this.

Robie Basak (racb) on 2011-10-13
affects: nova → nova (Ubuntu)
Robie Basak (racb) wrote :

SRU Justification:
1. Impact: installing nova-compute-xen fails with "Depends: xen-linux-system but it is not installable"
2. How bug was addressed: dependency on xen-linux-system was dropped
3. Patch: attached
4. Test case: add universe and "apt-get install nova-compute-xen"
5. Regression potential: I can't how might cause a regression.

Users will need to install xen-hypervisor-4.1-amd64 or xen-hypervisor-4.1-i386 manually, but we can't use a normal package dependency since we currently can't account for the way the system was booted in a dependency.

Hello Robie, or anyone else affected,

Accepted nova into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nova (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Clint Byrum (clint-fewbar) wrote :

Marking precise task as Triaged, a pocket copy from oneiric-updates should close it once it is verified.

Changed in nova (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in nova (Ubuntu Oneiric):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2011.3-0ubuntu7

---------------
nova (2011.3-0ubuntu7) precise; urgency=low

  [Scott Moser]
  * Removed db_pool complexities from nova.db.sqlalchemy.session (LP: #838581)

  [Chuck Short]
  * debian/patches/fix-iscsi-target-path.patch: Fix ISCSI target path patch.
    (LP: #871278)
  * debian/control: Either install xen-hypervisor-4.1-amd64 or
    xen-hypervisor-4.1-i386 for nova-compute-xen. (LP: #873243)
 -- Dave Walker (Daviey) <email address hidden> Sun, 16 Oct 2011 23:00:52 +0100

Changed in nova (Ubuntu Precise):
status: Triaged → Fix Released
Dave Walker (davewalker) on 2011-10-16
Changed in nova (Ubuntu Precise):
milestone: none → precise-alpha-1
Changed in nova (Ubuntu Oneiric):
milestone: none → oneiric-updates
Jamie Strandboge (jdstrand) wrote :

oneiric-proposed has been superseded by the 2011.3-0ubuntu6.2 security update.

Changed in nova (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Rogério Vinhal Nunes (rogervn) wrote :

I just tried to use the oneiric-proposed version and it seems to continue with the broken dependency.

Robie Basak (racb) wrote :

Confirmed broken - thanks Rogério. It looks like this has regressed due to a future SRU.

Changed in nova (Ubuntu Oneiric):
status: Fix Released → Triaged
tags: added: verification-failed
removed: verification-needed
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in nova (Ubuntu Oneiric):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments