Cannot attach volumes to instances if tgt is used

Bug #871278 reported by Eric Dodemont on 2011-10-09
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Chuck Short
nova (Ubuntu)
High
Chuck Short
Oneiric
Undecided
Unassigned
Precise
High
Chuck Short

Bug Description

I cannot attach a volume to an instance if both are on different hosts.

This is a problem which is specific to tgt which is used on Oneiric. I file that bug in Nova (Ubuntu) and not in Nova (Openstack), even though it is not an Ubuntu packaging problem.

Example:

SW: OpenStack 2011.3 (Diablo) -- Package: 2011.3-0ubuntu6
OS: Ubuntu 11.10 (Oneiric -- Beta2)

node1 (192.168.1.201): vol-00000004
node2 (192.168.1.202): i-00000004

root@node1:~# euca-attach-volume -i i-00000004 -d /dev/vdc vol-00000004

Error seen in nova-compute.log:

Error: iSCSI device not found at /dev/disk/by-path/ip-192.168.1.201:3260-iscsi-iqn.2010-10.org.openstack:volume-00000004-lun-0

Explanation:

nova-compute is waiting for a device to be configured as:

/dev/disk/by-path/ip-192.168.1.201:3260-iscsi-iqn.2010-10.org.openstack:volume-00000004-lun-0

but the device is configured as:

/dev/disk/by-path/ip-192.168.1.201:3260-iscsi-iqn.2010-10.org.openstack:volume-00000004-lun-1

nova-compute waits for xxx-lun-0, but xxx-lun-1 is configured:

root@node2:/dev/disk/by-path# ls -l
lrwxrwxrwx 1 root root 9 2011-10-08 22:02 ip-192.168.1.201:3260-iscsi-iqn.2010-10.org.openstack:volume-00000004-lun-1 -> ../../sdd

I guess this is a difference between the iet and tgt softwares used to configure iSCSI targets.

On Oneiric, tgt is used by default, and iet cannot be used because the kernel module is no more available.

In nova.conf:

--iscsi_helper=tgtadm

If I adapt the code from lun-0 to lun-1, everything works well:

diff /usr/share/pyshared/nova/volume/driver.py-patched /usr/share/pyshared/nova/volume/driver.py-unpatched
536c536
< mount_device = ("/dev/disk/by-path/ip-%s-iscsi-%s-lun-1" %
---
> mount_device = ("/dev/disk/by-path/ip-%s-iscsi-%s-lun-0" %

Complete nova-compute.log:

root@node2:~# tail -50 /var/log/nova/nova-compute.log
2011-10-08 22:02:31,179 DEBUG nova.rpc [-] received {u'_context_roles': [u'projectmanager'], u'_context_request_id': u'8911d1d6-66eb-48eb-ab9a-f7a387d858fa', u'_context_read_deleted': False, u'args': {u'instance_id': 4, u'mountpoint': u'/dev/vdc', u'volume_id': 4}, u'_context_auth_token': None, u'_context_strategy': u'noauth', u'_context_is_admin': True, u'_context_project_id': u'project-one', u'_context_timestamp': u'2011-10-08T20:02:31.145628', u'_context_user_id': u'admin', u'method': u'attach_volume', u'_context_remote_address': u'192.168.1.201'} from (pid=1585) __call__ /usr/lib/python2.7/dist-packages/nova/rpc/impl_kombu.py:600
2011-10-08 22:02:31,180 DEBUG nova.rpc [-] unpacked context: {'user_id': u'admin', 'roles': [u'projectmanager'], 'timestamp': u'2011-10-08T20:02:31.145628', 'auth_token': None, 'msg_id': None, 'remote_address': u'192.168.1.201', 'strategy': u'noauth', 'is_admin': True, 'request_id': u'8911d1d6-66eb-48eb-ab9a-f7a387d858fa', 'project_id': u'project-one', 'read_deleted': False} from (pid=1585) _unpack_context /usr/lib/python2.7/dist-packages/nova/rpc/impl_kombu.py:646
2011-10-08 22:02:31,181 INFO nova.compute.manager [8911d1d6-66eb-48eb-ab9a-f7a387d858fa admin project-one] check_instance_lock: decorating: |<function attach_volume at 0x2946230>|
2011-10-08 22:02:31,181 INFO nova.compute.manager [8911d1d6-66eb-48eb-ab9a-f7a387d858fa admin project-one] check_instance_lock: arguments: |<nova.compute.manager.ComputeManager object at 0x21e5790>| |<nova.rpc.impl_kombu.RpcContext object at 0x43fdf10>| |4|
2011-10-08 22:02:31,181 DEBUG nova.compute.manager [8911d1d6-66eb-48eb-ab9a-f7a387d858fa admin project-one] instance 4: getting locked state from (pid=1585) get_lock /usr/lib/python2.7/dist-packages/nova/compute/manager.py:1165
2011-10-08 22:02:31,333 INFO nova.compute.manager [8911d1d6-66eb-48eb-ab9a-f7a387d858fa admin project-one] check_instance_lock: locked: |False|
2011-10-08 22:02:31,334 INFO nova.compute.manager [8911d1d6-66eb-48eb-ab9a-f7a387d858fa admin project-one] check_instance_lock: admin: |True|
2011-10-08 22:02:31,334 INFO nova.compute.manager [8911d1d6-66eb-48eb-ab9a-f7a387d858fa admin project-one] check_instance_lock: executing: |<function attach_volume at 0x2946230>|
2011-10-08 22:02:31,410 AUDIT nova.compute.manager [8911d1d6-66eb-48eb-ab9a-f7a387d858fa admin project-one] instance 4: attaching volume 4 to /dev/vdc
2011-10-08 22:02:31,447 WARNING nova.volume.driver [-] ISCSI provider_location not stored, using discovery
2011-10-08 22:02:31,447 DEBUG nova.utils [-] Running cmd (subprocess): sudo iscsiadm -m discovery -t sendtargets -p node1 from (pid=1585) execute /usr/lib/python2.7/dist-packages/nova/utils.py:168
2011-10-08 22:02:31,489 DEBUG nova.volume.driver [-] ISCSI Discovery: Found 192.168.1.201:3260,1 iqn.2010-10.org.openstack:volume-00000004 from (pid=1585) _get_iscsi_properties /usr/lib/python2.7/dist-packages/nova/volume/driver.py:479
2011-10-08 22:02:31,490 DEBUG nova.utils [-] Running cmd (subprocess): sudo iscsiadm -m node -T iqn.2010-10.org.openstack:volume-00000004 -p 192.168.1.201:3260 --login from (pid=1585) execute /usr/lib/python2.7/dist-packages/nova/utils.py:168
2011-10-08 22:02:32,015 DEBUG nova.volume.driver [-] iscsiadm ('--login',): stdout=Logging in to [iface: default, target: iqn.2010-10.org.openstack:volume-00000004, portal: 192.168.1.201,3260]
Login to [iface: default, target: iqn.2010-10.org.openstack:volume-00000004, portal: 192.168.1.201,3260]: successful
 stderr= from (pid=1585) _run_iscsiadm /usr/lib/python2.7/dist-packages/nova/volume/driver.py:506
2011-10-08 22:02:32,015 DEBUG nova.utils [-] Running cmd (subprocess): sudo iscsiadm -m node -T iqn.2010-10.org.openstack:volume-00000004 -p 192.168.1.201:3260 --op update -n node.startup -v automatic from (pid=1585) execute /usr/lib/python2.7/dist-packages/nova/utils.py:168
2011-10-08 22:02:32,033 DEBUG nova.volume.driver [-] iscsiadm ('--op', 'update', '-n', 'node.startup', '-v', 'automatic'): stdout= stderr= from (pid=1585) _run_iscsiadm /usr/lib/python2.7/dist-packages/nova/volume/driver.py:506
2011-10-08 22:02:32,033 WARNING nova.volume.driver [-] ISCSI volume not yet found at: /dev/disk/by-path/ip-192.168.1.201:3260-iscsi-iqn.2010-10.org.openstack:volume-00000004-lun-0. Will rescan & retry. Try number: 0
2011-10-08 22:02:32,034 DEBUG nova.utils [-] Running cmd (subprocess): sudo iscsiadm -m node -T iqn.2010-10.org.openstack:volume-00000004 -p 192.168.1.201:3260 --rescan from (pid=1585) execute /usr/lib/python2.7/dist-packages/nova/utils.py:168
2011-10-08 22:02:32,052 DEBUG nova.volume.driver [-] iscsiadm ('--rescan',): stdout=Rescanning session [sid: 3, target: iqn.2010-10.org.openstack:volume-00000004, portal: 192.168.1.201,3260]
 stderr= from (pid=1585) _run_iscsiadm /usr/lib/python2.7/dist-packages/nova/volume/driver.py:506
2011-10-08 22:02:33,054 WARNING nova.volume.driver [-] ISCSI volume not yet found at: /dev/disk/by-path/ip-192.168.1.201:3260-iscsi-iqn.2010-10.org.openstack:volume-00000004-lun-0. Will rescan & retry. Try number: 1
2011-10-08 22:02:33,054 DEBUG nova.utils [-] Running cmd (subprocess): sudo iscsiadm -m node -T iqn.2010-10.org.openstack:volume-00000004 -p 192.168.1.201:3260 --rescan from (pid=1585) execute /usr/lib/python2.7/dist-packages/nova/utils.py:168
2011-10-08 22:02:33,073 DEBUG nova.volume.driver [-] iscsiadm ('--rescan',): stdout=Rescanning session [sid: 3, target: iqn.2010-10.org.openstack:volume-00000004, portal: 192.168.1.201,3260]
 stderr= from (pid=1585) _run_iscsiadm /usr/lib/python2.7/dist-packages/nova/volume/driver.py:506
2011-10-08 22:02:37,077 WARNING nova.volume.driver [-] ISCSI volume not yet found at: /dev/disk/by-path/ip-192.168.1.201:3260-iscsi-iqn.2010-10.org.openstack:volume-00000004-lun-0. Will rescan & retry. Try number: 2
2011-10-08 22:02:37,077 DEBUG nova.utils [-] Running cmd (subprocess): sudo iscsiadm -m node -T iqn.2010-10.org.openstack:volume-00000004 -p 192.168.1.201:3260 --rescan from (pid=1585) execute /usr/lib/python2.7/dist-packages/nova/utils.py:168
2011-10-08 22:02:37,095 DEBUG nova.volume.driver [-] iscsiadm ('--rescan',): stdout=Rescanning session [sid: 3, target: iqn.2010-10.org.openstack:volume-00000004, portal: 192.168.1.201,3260]
 stderr= from (pid=1585) _run_iscsiadm /usr/lib/python2.7/dist-packages/nova/volume/driver.py:506
2011-10-08 22:02:46,100 ERROR nova.rpc [-] Exception during message handling
(nova.rpc): TRACE: Traceback (most recent call last):
(nova.rpc): TRACE: File "/usr/lib/python2.7/dist-packages/nova/rpc/impl_kombu.py", line 620, in _process_data
(nova.rpc): TRACE: rval = node_func(context=ctxt, **node_args)
(nova.rpc): TRACE: File "/usr/lib/python2.7/dist-packages/nova/compute/manager.py", line 117, in decorated_function
(nova.rpc): TRACE: function(self, context, instance_id, *args, **kwargs)
(nova.rpc): TRACE: File "/usr/lib/python2.7/dist-packages/nova/compute/manager.py", line 1242, in attach_volume
(nova.rpc): TRACE: volume_id)
(nova.rpc): TRACE: File "/usr/lib/python2.7/dist-packages/nova/volume/manager.py", line 245, in setup_compute_volume
(nova.rpc): TRACE: path = self.driver.discover_volume(context, volume_ref)
(nova.rpc): TRACE: File "/usr/lib/python2.7/dist-packages/nova/volume/driver.py", line 546, in discover_volume
(nova.rpc): TRACE: (mount_device))
(nova.rpc): TRACE: Error: iSCSI device not found at /dev/disk/by-path/ip-192.168.1.201:3260-iscsi-iqn.2010-10.org.openstack:volume-00000004-lun-0
(nova.rpc): TRACE:
2011-10-08 22:03:52,889 INFO nova.compute.manager [-] Updating host status
2011-10-08 22:05:55,440 INFO nova.compute.manager [-] Updating host status

root@node2:/dev/disk/by-path# ls -l
total 0
lrwxrwxrwx 1 root root 9 2011-10-08 22:02 ip-192.168.1.201:3260-iscsi-iqn.2010-10.org.openstack:volume-00000004-lun-1 -> ../../sdd
lrwxrwxrwx 1 root root 9 2011-10-08 20:35 pci-0000:00:1f.2-scsi-0:0:0:0 -> ../../sda
lrwxrwxrwx 1 root root 10 2011-10-08 20:35 pci-0000:00:1f.2-scsi-0:0:0:0-part1 -> ../../sda1
lrwxrwxrwx 1 root root 10 2011-10-08 20:35 pci-0000:00:1f.2-scsi-0:0:0:0-part2 -> ../../sda2
lrwxrwxrwx 1 root root 10 2011-10-08 20:35 pci-0000:00:1f.2-scsi-0:0:0:0-part5 -> ../../sda5
lrwxrwxrwx 1 root root 9 2011-10-08 20:35 pci-0000:00:1f.2-scsi-0:0:1:0 -> ../../sdb
lrwxrwxrwx 1 root root 10 2011-10-08 21:38 pci-0000:00:1f.2-scsi-0:0:1:0-part1 -> ../../sdb1
lrwxrwxrwx 1 root root 9 2011-10-08 20:35 pci-0000:00:1f.2-scsi-1:0:0:0 -> ../../sdc
lrwxrwxrwx 1 root root 10 2011-10-08 20:35 pci-0000:00:1f.2-scsi-1:0:0:0-part1 -> ../../sdc1
lrwxrwxrwx 1 root root 9 2011-10-08 20:35 pci-0000:00:1f.2-scsi-1:0:1:0 -> ../../sr0

root@node1:~# tgtadm --lld iscsi --op show --mode target
Target 1: iqn.2010-10.org.openstack:volume-00000004
    System information:
        Driver: iscsi
        State: ready
    I_T nexus information:
        I_T nexus: 1
            Initiator: iqn.1993-08.org.debian:01:63503b146b7
            Connection: 0
                IP Address: 192.168.1.202 <========= initiator (i-00000004) on node2 is connected to target (vol-00000004) on node1
    LUN information:
        LUN: 0
            Type: controller
            SCSI ID: IET 00010000
            SCSI SN: beaf10
            Size: 0 MB, Block size: 1
            Online: Yes
            Removable media: No
            Readonly: No
            Backing store type: null
            Backing store path: None
            Backing store flags:
        LUN: 1 <==================================== LUN = 1 (and not 0)
            Type: disk
            SCSI ID: IET 00010001
            SCSI SN: beaf11
            Size: 1074 MB, Block size: 512
            Online: Yes
            Removable media: No
            Readonly: No
            Backing store type: rdwr
            Backing store path: /dev/nova-volumes/volume-00000004
            Backing store flags:
    Account information:
    ACL information:
        ALL

Eric Dodemont (dodeeric) on 2011-10-09
description: updated
description: updated
Dave Walker (davewalker) wrote :

Thank you for the wonderfully detailed bug report.

I am intrigued why they differ by 1.. "/

This might need some smarter logic for us to be able to push a conditional mount_device value upstream, to support both formats.

Changed in nova (Ubuntu):
milestone: none → oneiric-updates
assignee: nobody → Chuck Short (zulcss)
importance: Undecided → High
status: New → Triaged
tags: added: server-o-rs
Eric Dodemont (dodeeric) on 2011-10-09
description: updated

Hello Eric, or anyone else affected,

Accepted nova into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nova (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Dave Walker (davewalker) on 2011-10-16
Changed in nova (Ubuntu Oneiric):
milestone: none → oneiric-updates
Changed in nova (Ubuntu Precise):
milestone: oneiric-updates → precise-alpha-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2011.3-0ubuntu7

---------------
nova (2011.3-0ubuntu7) precise; urgency=low

  [Scott Moser]
  * Removed db_pool complexities from nova.db.sqlalchemy.session (LP: #838581)

  [Chuck Short]
  * debian/patches/fix-iscsi-target-path.patch: Fix ISCSI target path patch.
    (LP: #871278)
  * debian/control: Either install xen-hypervisor-4.1-amd64 or
    xen-hypervisor-4.1-i386 for nova-compute-xen. (LP: #873243)
 -- Dave Walker (Daviey) <email address hidden> Sun, 16 Oct 2011 23:00:52 +0100

Changed in nova (Ubuntu Precise):
status: Triaged → Fix Released
Eric Dodemont (dodeeric) wrote :
Download full text (42.5 KiB)

I do not see any difference between package 2011.3-0ubuntu6 and 2011.3-0ubuntu6.1 (oneiric-proposed). For me, it looks like the problem is still there: nova-compute is still looking for lun-0 when it should look for lun-1. lun-0 is reserved by tgt for the controler.

Bellow the three cases I have tested:

A) instance on node2 and volume on node1: NOK
B) instance and volume on node2: OK (but iSCSI not used in such case)
C) instance on node1 and volume on node2: NOK

Case A) and C) give the same error.

---

node1: 172.17.68.16 (nova-api, nova-objectstore, nova-scheduler, nova-network, mysql, rabbitmq, glance, nova-compute, nova-volume)
node2: 172.17.68.100 (nova-compute, nova-volume)

root@node1:~# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"

root@node2:~# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"

I have upgraded all the packages from oneiric-proposed (not only nova, but also open-iscsi, etc.):

node1:

24 packages upgraded:

[UPGRADE] initramfs-tools 0.99ubuntu7 -> 0.99ubuntu8
[UPGRADE] initramfs-tools-bin 0.99ubuntu7 -> 0.99ubuntu8
[UPGRADE] libgssapi-krb5-2 1.9.1+dfsg-1ubuntu1 -> 1.9.1+dfsg-1ubuntu2
[UPGRADE] libk5crypto3 1.9.1+dfsg-1ubuntu1 -> 1.9.1+dfsg-1ubuntu2
[UPGRADE] libkrb5-3 1.9.1+dfsg-1ubuntu1 -> 1.9.1+dfsg-1ubuntu2
[UPGRADE] libkrb5support0 1.9.1+dfsg-1ubuntu1 -> 1.9.1+dfsg-1ubuntu2
[UPGRADE] libpam-modules 1.1.3-2ubuntu1 -> 1.1.3-2ubuntu2
[UPGRADE] libpam-modules-bin 1.1.3-2ubuntu1 -> 1.1.3-2ubuntu2
[UPGRADE] libpam-runtime 1.1.3-2ubuntu1 -> 1.1.3-2ubuntu2
[UPGRADE] libpam0g 1.1.3-2ubuntu1 -> 1.1.3-2ubuntu2
[UPGRADE] libxenstore3.0 4.1.1-2ubuntu4 -> 4.1.1-2ubuntu4.1
[UPGRADE] nova-api 2011.3-0ubuntu6 -> 2011.3-0ubuntu6.1
[UPGRADE] nova-common 2011.3-0ubuntu6 -> 2011.3-0ubuntu6.1
[UPGRADE] nova-compute 2011.3-0ubuntu6 -> 2011.3-0ubuntu6.1
[UPGRADE] nova-compute-kvm 2011.3-0ubuntu6 -> 2011.3-0ubuntu6.1
[UPGRADE] nova-doc 2011.3-0ubuntu6 -> 2011.3-0ubuntu6.1
[UPGRADE] nova-network 2011.3-0ubuntu6 -> 2011.3-0ubuntu6.1
[UPGRADE] nova-objectstore 2011.3-0ubuntu6 -> 2011.3-0ubuntu6.1
[UPGRADE] nova-scheduler 2011.3-0ubuntu6 -> 2011.3-0ubuntu6.1
[UPGRADE] nova-volume 2011.3-0ubuntu6 -> 2011.3-0ubuntu6.1
[UPGRADE] open-iscsi 2.0.871-0ubuntu8 -> 2.0.871-0ubuntu9
[UPGRADE] open-iscsi-utils 2.0.871-0ubuntu8 -> 2.0.871-0ubuntu9
[UPGRADE] python-nova 2011.3-0ubuntu6 -> 2011.3-0ubuntu6.1
[UPGRADE] update-manager-core 1:0.152.25 -> 1:0.152.25.2

node2:

20 packages upgraded:

[UPGRADE] initramfs-tools 0.99ubuntu7 -> 0.99ubuntu8
[UPGRADE] initramfs-tools-bin 0.99ubuntu7 -> 0.99ubuntu8
[UPGRADE] libgssapi-krb5-2 1.9.1+dfsg-1ubuntu1 -> 1.9.1+dfsg-1ubuntu2
[UPGRADE] libk5crypto3 1.9.1+dfsg-1ubuntu1 -> 1.9.1+dfsg-1ubuntu2
[UPGRADE] libkrb5-3 1.9.1+dfsg-1ubuntu1 -> 1.9.1+dfsg-1ubuntu2
[UPGRADE] libkrb5support0 1.9.1+dfsg-1ubuntu1 -> 1.9.1+dfsg-1ubuntu2
[UPGRADE] libpam-modules 1.1.3-2ubuntu1 -> 1.1.3-2ubuntu2
[UPGRADE] libpam-modules-bin 1.1.3-2ubuntu1 -> 1.1.3-2ubuntu2
[UPGRADE] libpam-runtime 1.1.3-2ubuntu1 -> 1.1.3-2ubuntu...

Martin Pitt (pitti) on 2011-10-18
tags: added: verification-failed
removed: verification-needed
livemoon (mwjpiero) wrote :

I have the same problem, when I attach a volume, it also show:
"Error: iSCSI device not found at /dev/disk/by-path/ip-10.200.200.4:3260-iscsi-iqn.2010-10.org.openstack:volume-00000001-lun-0"

my version is
2012.1-dev (2012.1-LOCALBRANCH:LOCALREVISION)

livemoon (mwjpiero) on 2011-10-25
Changed in nova (Ubuntu Oneiric):
status: Fix Committed → Incomplete
livemoon (mwjpiero) wrote :

I have modified three fils:

/usr/local/lib/python2.7/dist-packages/nova/virt/libvirt/volume.py
nova/volume/driver.py
nova/virt/libvirt/volume.py

change lun0->lun1

- host_device = ("/dev/disk/by-path/ip-%s-iscsi-%s-lun-0"
+ host_device = ("/dev/disk/by-path/ip-%s-iscsi-%s-lun-1"

it works well. but are the developer ready to fix this bugs

Jamie Strandboge (jdstrand) wrote :

oneiric-proposed has been superseded by the 2011.3-0ubuntu6.2 security update.

Chuck Short (zulcss) on 2011-10-26
Changed in nova (Ubuntu Precise):
status: Fix Released → In Progress
Nathan Koterba (nkoterba) wrote :

Just ran into this issue myself.

Openstack is looking for lun-0, but the device shows up on my Oneiric install as lun-1.

Have subscribed to bug report...hopefully looking for an update here.

Mark McLoughlin (markmc) wrote :
Dave Walker (davewalker) on 2011-12-01
Changed in nova (Ubuntu):
milestone: precise-alpha-1 → precise-alpha-2
Thierry Carrez (ttx) on 2011-12-02
Changed in nova:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Chuck Short (zulcss)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/2296
Committed: http://github.com/openstack/nova/commit/15cc877cc2af71135b896974f17cb4a63291a08c
Submitter: Jenkins
Branch: master

 status fixcommitted
 done

commit 15cc877cc2af71135b896974f17cb4a63291a08c
Author: Chuck Short <email address hidden>
Date: Tue Dec 13 13:45:43 2011 -0500

    Fix tgtadm off by one error. Fixes bug #871278

    Change-Id: Ia359045465ada9753b86d1a08cc947966b3ac899
    Signed-off-by: Chuck Short <email address hidden>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2012.1~e2-0ubuntu1

---------------
nova (2012.1~e2-0ubuntu1) precise; urgency=low

  * New usptream release. Fixes the following bugs:
    (LP: #871278, #848643, #859679, #83199)
  * debian/nova-console.install: Fix empty package.
  * debian/patches, debian/pydist-overrides: Cleaner way
    of disabling unwanted python-dependencies.
  * debian/control:
    - Suggest python-keystone. (LP: #901881)
    - Update build dependencies.
  * debian/nova.conf: Use virtio networking by default.
    (LP: #904480)
  * debian/fix-traversal-via-image-register.patch: Dropped
    fixed upstream.
 -- Chuck Short <email address hidden> Fri, 16 Dec 2011 13:03:55 -0500

Changed in nova (Ubuntu Precise):
status: In Progress → Fix Released
Mark McLoughlin (markmc) wrote :

Fix was merged into master

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-01-25
Changed in nova:
milestone: none → essex-3
status: Fix Committed → Fix Released
Tom Ellis (tellis) wrote :

This is still occurring in oneiric with diablo, could someone spin a new pkg that isn't superseded by the 2011.3-0ubuntu6.2 security update?

Thanks!

Tom Ellis (tellis) wrote :

I had to modify the original patch a little to to get it to work (set it to 1 instead of 0 for tgt):
http://paste.ubuntu.com/876094/

For essex, I see driver.py has changed anyway and now has that fix in the iscsi.py helper script.

Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-3 → 2012.1
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in nova (Ubuntu Oneiric):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers