nova-compute is missing dependency on qemu-kvm

Bug #833530 reported by Scott Moser on 2011-08-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nova (Ubuntu)
High
Unassigned

Bug Description

after installing nova-compute-lxc and attempting to run an instance i got:

2011-08-25 05:35:53,595 DEBUG nova.utils [-] Running cmd (subprocess): qemu-img create -f qcow2 -o cluster_size=2M,backing_file=/var/lib/nova/instances/_base/da4b9237bacccdf19c0760cab7aec4a8359010b0 /var/lib/nova/instances/instance-00000003/disk from (pid=805) execute /usr/lib/pymodules/python2.7/nova/utils.py:164
...
(nova.exception): TRACE: File "/usr/lib/python2.7/subprocess.py", line 1239, in _execute_child
(nova.exception): TRACE: raise child_exception
(nova.exception): TRACE: OSError: [Errno 2] No such file or directory

The missing executable was 'qemu-img'

nova-compute in lxc mode uses qemu-img and qemu-nbd from qemu-kvm package.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nova-compute-lxc 2011.3~d4~20110812.1417-0ubuntu1
ProcVersionSignature: User Name 3.0.0-9.14-virtual 3.0.3
Uname: Linux 3.0.0-9-virtual x86_64
Architecture: amd64
Date: Thu Aug 25 05:38:17 2011
NovaConf: Error: [Errno 13] Permission denied: '/etc/nova/nova.conf'
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nova
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Scott Moser (smoser) wrote :
summary: - nova-compute-lxc is missing depnedency on qemu-kvm
+ nova-compute-lxc is missing dependency on qemu-kvm
Scott Moser (smoser) wrote :

I realized this also not listed as a depends of nova-compute, and I think the dependency is probably there.

It would seem the best solution would be for the ubuntu qemu-kvm source package to create a qemu-utils package like debian's.
http://packages.debian.org/sid/qemu-utils

summary: - nova-compute-lxc is missing dependency on qemu-kvm
+ nova-compute is missing dependency on qemu-kvm
Scott Moser (smoser) wrote :

I opened bug 833799 as a feature request for qemu-kvm package to build a qemu-utils package.

Thierry Carrez (ttx) on 2011-08-26
Changed in nova (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2011.3~rc~20110901.1523-0ubuntu1

---------------
nova (2011.3~rc~20110901.1523-0ubuntu1) oneiric; urgency=low

  [ Chuck Short ]
  * Really remove python-ipy.
  * New upstream release.
  * Use "--use_deprecated_auth" by default because we dont support
    kestone yet. (LP: #838768)

  [ James E. Blair ]
  * Add python-unittest2 as a build dep.

  [ Dave Walker (Daviey) ]
  * debian/control: Added python-kombu as a build and run depends.
    - LP: #798876

  [ Scott Moser ]
  * add dependency on qemu-kvm to nova-compute (LP: #833530)
 -- Chuck Short <email address hidden> Fri, 02 Sep 2011 13:21:22 -0400

Changed in nova (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers