[SRU] November Stable Point Updates

Bug #1906271 reported by Chris MacNaughton on 2020-11-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Status tracked in Victoria
Stein
Undecided
Chris MacNaughton
Train
Undecided
Chris MacNaughton
Ussuri
Undecided
Chris MacNaughton
Victoria
Undecided
Chris MacNaughton
nova (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Chris MacNaughton
Groovy
Undecided
Chris MacNaughton

Bug Description

[Impact]
This release sports mostly bug-fixes and we would like to make sure all of our users have access to these improvements. The update contains the following package updates to Nova:

Groovy Victoria: 22.0.1
Focal Ussuri: 21.1.1
Train: 20.4.1
Stein: 19.3.2

[Test Case]
The following SRU process was followed:
https://wiki.ubuntu.com/OpenStackUpdates

In order to avoid regression of existing consumers, the OpenStack team will run their continuous integration test against the packages that are in -proposed. A successful run of all available tests will be required before the proposed packages can be let into -updates.

The OpenStack team will be in charge of attaching the output summary of the executed tests. The OpenStack team members will not mark ‘verification-done’ until this has happened.

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned tests are attached to this bug.

[Discussion]

Changed in nova (Ubuntu):
status: New → Fix Released
Changed in nova (Ubuntu Groovy):
assignee: nobody → Chris MacNaughton (chris.macnaughton)
Changed in nova (Ubuntu Focal):
assignee: nobody → Chris MacNaughton (chris.macnaughton)
description: updated
Brian Murray (brian-murray) wrote :

I don't see nova 22.0.1 in hirsute yet, so setting this to Incomplete until that exists.

Changed in nova (Ubuntu Groovy):
status: New → Incomplete

A new upload has been made to Nova in Hirsute that corresponds with the upstream releases first milestone. As a result, I'm re-marking Groovy New

Changed in nova (Ubuntu Groovy):
status: Incomplete → New

Hello Chris, or anyone else affected,

Accepted nova into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:22.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in nova (Ubuntu Groovy):
status: New → Fix Committed
tags: added: verification-needed verification-needed-groovy
tags: added: sts
Download full text (10.8 KiB)

Verification was performed on Groovy:

======
Totals
======
Ran: 97 tests in 1373.9563 sec.
 - Passed: 89
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 1098.0484 sec.

Full output of tempest run:

{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_get_flavor [0.339680s] ... ok
{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_list_flavors [0.106037s] ... ok
{0} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_create [3.909244s] ... ok
{0} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_list [4.614518s] ... ok
{0} tempest.api.compute.security_groups.test_security_groups.SecurityGroupsTestJSON.test_security_groups_create_list_delete [9.030929s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_list_servers [0.173761s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_verify_server_details [0.000801s] ... ok
{0} tempest.api.compute.servers.test_attach_interfaces.AttachInterfacesUnderV243Test.test_add_remove_fixed_ip [104.053006s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_list_servers [0.322322s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_verify_server_details [0.001537s] ... ok
{1} tempest.api.compute.servers.test_server_actions.ServerActionsTestJSON.test_reboot_server_hard [121.116171s] ... ok
{1} tempest.api.compute.test_versions.TestVersions.test_get_version_details [0.839068s] ... ok
{1} tempest.api.compute.test_versions.TestVersions.test_list_api_versions [0.017325s] ... ok
{1} setUpClass (tempest.api.identity.admin.v2.test_services.ServicesTestJSON) ... SKIPPED: Identity api v2 is not enabled
{1} setUpClass (tempest.api.identity.admin.v2.test_users.UsersTestJSON) ... SKIPPED: Identity api v2 is not enabled
{1} tempest.api.identity.admin.v3.test_domains.DomainsTestJSON.test_create_update_delete_domain [1.009589s] ... ok
{1} tempest.api.identity.admin.v3.test_policies.PoliciesTestJSON.test_create_update_delete_policy [0.901911s] ... ok
{1} tempest.api.identity.admin.v3.test_regions.RegionsTestJSON.test_create_region_with_specific_id [0.184164s] ... ok
{1} tempest.api.identity.admin.v3.test_roles.RolesV3TestJSON.test_role_create_update_show_list [0.480441s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestManualDisk.test_list_servers [0.166518s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestManualDisk.test_verify_server_details [0.001296s] ... ok
{1} tempest.api.identity.admin.v3.test_services.ServicesTestJSON.test_create_update_get_service [0.938737s] ... ok
{1} tempest.api.image.v2.test_versions.VersionsTest.test_list_versions [0.016004s] ... ok
{1} tempest.api.network.test_networks.BulkNetworkOpsTest.test_bulk_create_delete_network [29.064320s] ... ok
{1} tempest.api.network.test_networks.BulkNetworkOpsTest.test_bulk_create_delete_port [23.161710s] ... ok
{0} tempest.api.compute.servers.test_server_addresses.ServerAddressesT...

description: updated
tags: added: verification-done-groovy
removed: verification-needed-groovy
Corey Bryant (corey.bryant) wrote :

Hello Chris, or anyone else affected,

Accepted nova into victoria-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:victoria-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-victoria-needed to verification-victoria-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-victoria-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-victoria-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2:22.0.1-0ubuntu1

---------------
nova (2:22.0.1-0ubuntu1) groovy; urgency=medium

  [ Corey Bryant ]
  * d/gbp.conf: Create stable/victoria branch.

  [ Chris MacNaughton ]
  * New stable point release for OpenStack Victoria (LP: #1906271).

 -- Chris MacNaughton <email address hidden> Tue, 01 Dec 2020 08:29:19 +0000

Changed in nova (Ubuntu Groovy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nova has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Download full text (10.9 KiB)

Validation was performed on Focal with the Victoria cloud archive enabled:

======
Totals
======
Ran: 97 tests in 2193.3125 sec.
 - Passed: 89
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 1633.8652 sec.

==============
Worker Balance
==============
 - Worker 0 (49 tests) => 0:36:13.778196
 - Worker 1 (48 tests) => 0:30:47.621274

Full output of tempest run:

{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_get_flavor [0.245810s] ... ok
{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_list_flavors [0.093508s] ... ok
{0} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_create [4.282885s] ... ok
{0} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_list [5.023939s] ... ok
{0} tempest.api.compute.security_groups.test_security_groups.SecurityGroupsTestJSON.test_security_groups_create_list_delete [20.203357s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_list_servers [0.193767s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_verify_server_details [0.001397s] ... ok
{0} tempest.api.compute.servers.test_attach_interfaces.AttachInterfacesUnderV243Test.test_add_remove_fixed_ip [126.114864s] ... ok
{1} tempest.api.compute.servers.test_server_actions.ServerActionsTestJSON.test_reboot_server_hard [32.546130s] ... ok
{1} tempest.api.compute.test_versions.TestVersions.test_get_version_details [0.694648s] ... ok
{1} tempest.api.compute.test_versions.TestVersions.test_list_api_versions [0.014072s] ... ok
{1} setUpClass (tempest.api.identity.admin.v2.test_services.ServicesTestJSON) ... SKIPPED: Identity api v2 is not enabled
{1} setUpClass (tempest.api.identity.admin.v2.test_users.UsersTestJSON) ... SKIPPED: Identity api v2 is not enabled
{1} tempest.api.identity.admin.v3.test_domains.DomainsTestJSON.test_create_update_delete_domain [0.623259s] ... ok
{1} tempest.api.identity.admin.v3.test_policies.PoliciesTestJSON.test_create_update_delete_policy [0.637078s] ... ok
{1} tempest.api.identity.admin.v3.test_regions.RegionsTestJSON.test_create_region_with_specific_id [0.131706s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_list_servers [0.208165s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_verify_server_details [0.001362s] ... ok
{1} tempest.api.identity.admin.v3.test_roles.RolesV3TestJSON.test_role_create_update_show_list [0.393541s] ... ok
{1} tempest.api.identity.admin.v3.test_services.ServicesTestJSON.test_create_update_get_service [0.706775s] ... ok
{1} tempest.api.image.v2.test_versions.VersionsTest.test_list_versions [0.029611s] ... ok
{1} tempest.api.network.test_networks.BulkNetworkOpsTest.test_bulk_create_delete_network [43.393031s] ... ok
{1} tempest.api.network.test_networks.BulkNetworkOpsTest.test_bulk_create_delete_port [35.739888s] ... ok
{1} tempest.api.network.test_networks.BulkNetworkOpsTest.test_bulk_create_delete_subnet [45.609722s] ... ok
{0} tempest.api.compute.se...

tags: added: verification-victoria-done
removed: verification-victoria-needed
Łukasz Zemczak (sil2100) wrote :

Since this is a new upstream release following a single tracking bug, please be sure to double-check that the previous SRU bugfix is in effect: https://bugs.launchpad.net/nova/+bug/1893263

Changed in nova (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed-focal

Hello Chris, or anyone else affected,

Accepted nova into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:21.1.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Hello Chris, or anyone else affected,

Accepted nova into ussuri-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:ussuri-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-ussuri-needed to verification-ussuri-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-ussuri-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-ussuri-needed

Hello Chris, or anyone else affected,

Accepted nova into train-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:train-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-train-needed to verification-train-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-train-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-train-needed

Hello Chris, or anyone else affected,

Accepted nova into stein-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:stein-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-stein-needed to verification-stein-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-stein-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-stein-needed

Verification was performed on Focal:

======
Totals
======
Ran: 97 tests in 1747.4193 sec.
 - Passed: 89
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 1401.5078 sec.

tags: added: verification-done-focal
removed: verification-needed-focal

Verification was performed on Focal with the Ussuri cloud archive:

======
Totals
======
Ran: 97 tests in 1280.3080 sec.
 - Passed: 89
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 964.8993 sec.

The above comment is regarding the Victoria cloud archive, as Ussuri ships on Focal.

Verification was performed on Bionic with the Ussuri cloud archive:

======
Totals
======
Ran: 97 tests in 799.2596 sec.
 - Passed: 89
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 665.3789 sec.

tags: added: verification-ussuri-done
removed: verification-ussuri-needed

Verification was performed on Bionic with the Train cloud archive:

======
Totals
======
Ran: 97 tests in 715.7132 sec.
 - Passed: 89
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 568.4569 sec.

tags: added: verification-train-done
removed: verification-train-needed

Verification was performed on Bionic with the Stein cloud archive:

======
Totals
======
Ran: 97 tests in 828.3108 sec.
 - Passed: 89
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 684.0840 sec.

tags: added: verification-done verification-stein-done
removed: verification-needed verification-stein-needed

The verification of the Stable Release Update for nova has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

This bug was fixed in the package nova - 2:22.0.1-0ubuntu1~cloud0
---------------

 nova (2:22.0.1-0ubuntu1~cloud0) focal-victoria; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 nova (2:22.0.1-0ubuntu1) groovy; urgency=medium
 .
   [ Corey Bryant ]
   * d/gbp.conf: Create stable/victoria branch.
 .
   [ Chris MacNaughton ]
   * New stable point release for OpenStack Victoria (LP: #1906271).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2:21.1.1-0ubuntu2

---------------
nova (2:21.1.1-0ubuntu2) focal; urgency=medium

  * d/p/lp1892361.patch: Update pci stat pools based on PCI device changes (LP: #1892361).

 -- Chris MacNaughton <email address hidden> Mon, 18 Jan 2021 15:25:16 +0000

Changed in nova (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nova has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

This bug was fixed in the package nova - 2:20.4.1-0ubuntu1~cloud0
---------------

 nova (2:20.4.1-0ubuntu1~cloud0) bionic-train; urgency=medium
 .
   * New stable point release for OpenStack Train (LP: #1906271).
   * d/p/lp1893263.patch: Removed. Change landed upstream in this point release.

The verification of the Stable Release Update for nova has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

This bug was fixed in the package nova - 2:19.3.2-0ubuntu1~cloud0
---------------

 nova (2:19.3.2-0ubuntu1~cloud0) bionic-stein; urgency=medium
 .
   * New stable point release for OpenStack Stein (LP: #1906271).
   * d/p/lp1893263.patch: Removed. Patch has landed upstream and is included
     in this point release.

The verification of the Stable Release Update for nova has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

This bug was fixed in the package nova - 2:21.1.1-0ubuntu2~cloud0
---------------

 nova (2:21.1.1-0ubuntu2~cloud0) bionic-ussuri; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 nova (2:21.1.1-0ubuntu2) focal; urgency=medium
 .
   * d/p/lp1892361.patch: Update pci stat pools based on PCI device changes (LP: #1892361).
 .
 nova (2:21.1.1-0ubuntu1) focal; urgency=medium
 .
  * New stable point release for OpenStack Ussuri (LP: #1906271).
  * d/p/lp1893263.patch: Removed as this fix landed in this point release.

Changed in nova (Ubuntu):
assignee: nobody → Chris MacNaughton (chris.macnaughton)
assignee: Chris MacNaughton (chris.macnaughton) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers