drop db sync commands from OpenStack packages

Bug #1713059 reported by Felipe Reyes on 2017-08-25
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Status tracked in Pike
Mitaka
High
Unassigned
Newton
High
Unassigned
Ocata
High
Unassigned
Pike
High
Unassigned
aodh (Ubuntu)
Status tracked in Artful
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Medium
Unassigned
ceilometer (Ubuntu)
Status tracked in Artful
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Medium
Unassigned
cinder (Ubuntu)
Status tracked in Artful
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Medium
Unassigned
glance (Ubuntu)
Status tracked in Artful
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Medium
Unassigned
ironic (Ubuntu)
Status tracked in Artful
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Medium
Unassigned
keystone (Ubuntu)
Status tracked in Artful
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Medium
Unassigned
manila (Ubuntu)
Status tracked in Artful
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Medium
Unassigned
nova (Ubuntu)
Status tracked in Artful
Xenial
High
Felipe Reyes
Zesty
High
Felipe Reyes
Artful
High
Unassigned
openstack-trove (Ubuntu)
Status tracked in Artful
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Medium
Unassigned
panko (Ubuntu)
Status tracked in Artful
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Medium
Unassigned

Bug Description

[Impact]

nova-compute service does not need access to the database, systems where nova.conf is configured without a database connection the nova-common package will fail to get configured

[Test Case]

Using this deployer bundle -> http://paste.ubuntu.com/25426891/
juju-deployer -c bundle.yaml -d -v -s 10 xenial-mitaka
# once everything is installed
git clone https://github.com/openstack-charmers/openstack-charms-tools.git
cd openstack-charms-tools/
./os-upgrade.py -o cloud:xenial-newton

Expected result:

nova-compute units upgrade their packages to newton without errors

Actual result:

nova-common fails to configure itself in the nova-compute units

[Regression Potential]

This change was tested in a staging environment and no regressions were detected, but any possible regression will express itself as a failure running "nova-manage db sync".

[Other Info]
The original reason this bug was opened is that nova db sync is executed when the 'connection' is not defined. Let's fix that and at the same time drop all db syncs from OpenStack packages in Pike.

More on the nova issue:

When the 'connection' configuration key is NOT defined in /etc/nova/nova.conf the nova-common.postinst script still tries to run 'nova-manage db sync'

root@juju-b24bc9-mno-18:~# grep connection /etc/nova/nova.conf
root@juju-b24bc9-mno-18:~# dpkg-reconfigure nova-common
Option "logdir" from group "DEFAULT" is deprecated. Use option "log-dir" from group "DEFAULT".
Option "verbose" from group "DEFAULT" is deprecated for removal. Its value may be silently ignored in the future.
ERROR: could not access cell mapping database - has api db been created?
An error has occurred:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/nova/cmd/manage.py", line 1602, in main
    ret = fn(*fn_args, **fn_kwargs)
  File "/usr/lib/python2.7/dist-packages/nova/cmd/manage.py", line 645, in sync
    return migration.db_sync(version)
  File "/usr/lib/python2.7/dist-packages/nova/db/migration.py", line 26, in db_sync
    return IMPL.db_sync(version=version, database=database, context=context)
  File "/usr/lib/python2.7/dist-packages/nova/db/sqlalchemy/migration.py", line 57, in db_sync
    repository, version)
  File "/usr/lib/python2.7/dist-packages/migrate/versioning/api.py", line 186, in upgrade
    return _migrate(url, repository, version, upgrade=True, err=err, **opts)
  File "<decorator-gen-15>", line 2, in _migrate
  File "/usr/lib/python2.7/dist-packages/migrate/versioning/util/__init__.py", line 160, in with_engine
    return f(*a, **kw)
  File "/usr/lib/python2.7/dist-packages/migrate/versioning/api.py", line 366, in _migrate
    schema.runchange(ver, change, changeset.step)
  File "/usr/lib/python2.7/dist-packages/migrate/versioning/schema.py", line 93, in runchange
    change.run(self.engine, step)
  File "/usr/lib/python2.7/dist-packages/migrate/versioning/script/py.py", line 148, in run
    script_func(engine)
  File "/usr/lib/python2.7/dist-packages/nova/db/sqlalchemy/migrate_repo/versions/345_require_online_migration_completion.py", line 44, in upgrade
    raise exception.ValidationError(detail=msg)
ValidationError: Migration cannot continue until all these have been migrated to the api database. Please run `nova-manage db online_migrations' on Newton code before continuing.There are still 5 unmigrated flavors.

Running the postinst script manually with -x

root@juju-b24bc9-mno-18:~# bash -ex /var/lib/dpkg/info/nova-common.postinst configure
+ '[' configure = configure ']'
+ getent group nova
+ getent passwd nova
+ '[' -z '' ']'
+ chown -R nova:nova /var/lib/nova/
+ chown -R nova:nova /etc/nova
+ chown -R nova:adm /var/log/nova
+ '[' -z '' ']'
+ chown -R nova:nova /var/lib/nova/
+ chmod 0640 /etc/nova/nova.conf
+ chmod 0640 /etc/nova/api-paste.ini
+ chmod 0750 /etc/nova
+ chmod 0750 /var/log/nova
+ chown root:root /etc/nova/rootwrap.conf
+ chown root:root /etc/nova/rootwrap.d
+ chmod 0755 /etc/nova/rootwrap.d
+ grep -qE '^(sql_)?connection( )?=.*' /etc/nova/nova.conf
+ su -s /bin/sh -c 'nova-manage db sync' nova
Option "logdir" from group "DEFAULT" is deprecated. Use option "log-dir" from group "DEFAULT".
Option "verbose" from group "DEFAULT" is deprecated for removal. Its value may be silently ignored in the future.
ERROR: could not access cell mapping database - has api db been created?
An error has occurred:
Traceback (most recent call last):
...
ValidationError: Migration cannot continue until all these have been migrated to the api database. Please run `nova-manage db online_migrations' on Newton code before continuing.There are still 5 unmigrated flavors.

The condition to run the sync operation should be that the connection config key is defined in nova.conf

# diff -u /var/lib/dpkg/info/nova-common.postinst ./nova-common.postinst
--- /var/lib/dpkg/info/nova-common.postinst 2017-06-19 08:12:49.000000000 +0000
+++ ./nova-common.postinst 2017-08-25 13:08:48.852744427 +0000
@@ -47,8 +47,8 @@
     chown root:root /etc/nova/rootwrap.d
     chmod 0755 /etc/nova/rootwrap.d

- if ! grep -qE "^(sql_)?connection( )?=.*" /etc/nova/nova.conf || \
- grep -qE "^(sql_)?connection.*sqlite.*" /etc/nova/nova.conf
+ if grep -qE "^(sql_)?connection( )?=.*" /etc/nova/nova.conf || \
+ grep -qE "^(sql_)?connection.*sqlite.*" /etc/nova/nova.conf
     then
       su -s /bin/sh -c 'nova-manage db sync' nova
     fi

Felipe Reyes (freyes) wrote :

Here I'm attaching a debdiff for artful, if this is OK, I will work on the SRUs.

Note: This package is not synced from debian -> https://github.com/openstack/deb-nova/blob/debian/ocata/debian/nova-common.postinst.in#L105

The attachment "lp1713059_artful.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Corey Bryant (corey.bryant) wrote :

Hi Felipe

Historically we've configured OpenStack services to use sqlite at install time, and it makes sense to run the db sync commands in that case. However, I'm not sure why we also run the db sync commands if connection isn't defined (! grep -qE "^(sql_)?connection( )?=.*" /etc/nova/nova.conf).

We do this in a number of packages so I want to figure out why we do that. We do the same in cinder, panko, aodh, nova, manila, to name a few.

What we don't want to do is to run the db sync commands for non-sqlite db's. If not using sqlite we leave it up to the user or config mgmt tooling.

Corey

On Mon, Aug 28, 2017 at 06:25:17PM -0000, Corey Bryant wrote:
> Hi Felipe
>
> Historically we've configured OpenStack services to use sqlite at
> install time, and it makes sense to run the db sync commands in that
> case. However, I'm not sure why we also run the db sync commands if
> connection isn't defined (! grep -qE "^(sql_)?connection( )?=.*"
> /etc/nova/nova.conf).
>
> We do this in a number of packages so I want to figure out why we do
> that. We do the same in cinder, panko, aodh, nova, manila, to name a
> few.
>
> What we don't want to do is to run the db sync commands for non-sqlite
> db's. If not using sqlite we leave it up to the user or config mgmt
> tooling.

gotcha, then that's what that negation is meant for, the regexp needs to be tweaked a little bit to match only when "connection is config is set, but it's value contains sqlite"

That may be what was meant to do. Let me sync with James when he gets back to get the historical context.

Download full text (3.2 KiB)

On Mon, Aug 28, 2017 at 03:44:42PM -0300, Felipe Reyes wrote:
> On Mon, Aug 28, 2017 at 06:25:17PM -0000, Corey Bryant wrote:
> > Hi Felipe
> >
> > Historically we've configured OpenStack services to use sqlite at
> > install time, and it makes sense to run the db sync commands in that
> > case. However, I'm not sure why we also run the db sync commands if
> > connection isn't defined (! grep -qE "^(sql_)?connection( )?=.*"
> > /etc/nova/nova.conf).
> >
> > We do this in a number of packages so I want to figure out why we do
> > that. We do the same in cinder, panko, aodh, nova, manila, to name a
> > few.
> >
> > What we don't want to do is to run the db sync commands for non-sqlite
> > db's. If not using sqlite we leave it up to the user or config mgmt
> > tooling.
>
> gotcha, then that's what that negation is meant for, the regexp needs to be tweaked a little bit to match only when "connection is config is set, but it's value contains sqlite"

Dropping the first grep:

--- /var/lib/dpkg/info/nova-common.postinst 2017-06-19 08:12:49.000000000 +0000
+++ ./nova-common.postinst 2017-08-28 18:51:01.367912483 +0000
@@ -47,8 +47,7 @@
     chown root:root /etc/nova/rootwrap.d
     chmod 0755 /etc/nova/rootwrap.d

- if ! grep -qE "^(sql_)?connection( )?=.*" /etc/nova/nova.conf || \
- grep -qE "^(sql_)?connection.*sqlite.*" /etc/nova/nova.conf
+ if grep -qE "^(sql_)?connection.*sqlite.*" /etc/nova/nova.conf
     then
       su -s /bin/sh -c 'nova-manage db sync' nova
     fi

Connection NOT defined:

root@juju-675da2-mno-17:~# bash -ex ./nova-common.postinst
+ '[' '' = configure ']'
root@juju-675da2-mno-17:~# bash -ex ./nova-common.postinst configure
+ '[' configure = configure ']'
+ getent group nova
+ getent passwd nova
+ '[' -z '' ']'
+ chown -R nova:nova /var/lib/nova/
+ chown -R nova:nova /etc/nova
+ chown -R nova:adm /var/log/nova
+ '[' -z '' ']'
+ chown -R nova:nova /var/lib/nova/
+ chmod 0640 /etc/nova/nova.conf
+ chmod 0640 /etc/nova/api-paste.ini
+ chmod 0750 /etc/nova
+ chmod 0750 /var/log/nova
+ chown root:root /etc/nova/rootwrap.conf
+ chown root:root /etc/nova/rootwrap.d
+ chmod 0755 /etc/nova/rootwrap.d
+ grep -qE '^(sql_)?connection.*sqlite.*' /etc/nova/nova.conf
+ '[' -e /var/lib/nova/nova.sqlite ']'
+ chown nova:nova /var/lib/nova/nova.sqlite
+ chmod 0640 /var/lib/nova/nova.sqlite
root@juju-675da2-mno-17:~# grep connection /etc/nova/nova.conf

Connection defined:

root@juju-675da2-mno-17:~# bash -ex ./nova-common.postinst configure
+ '[' configure = configure ']'
+ getent group nova
+ getent passwd nova
+ '[' -z '' ']'
+ chown -R nova:nova /var/lib/nova/
+ chown -R nova:nova /etc/nova
+ chown -R nova:adm /var/log/nova
+ '[' -z '' ']'
+ chown -R nova:nova /var/lib/nova/
+ chmod 0640 /etc/nova/nova.conf
+ chmod 0640 /etc/nova/api-paste.ini
+ chmod 0750 /etc/nova
+ chmod 0750 /var/log/nova
+ chown root:root /etc/nova/rootwrap.conf
+ chown root:root /etc/nova/rootwrap.d
+ chmod 0755 /etc/nova/rootwrap.d
+ grep -qE '^(sql_)?connection.*sqlite.*' /etc/nova/nova.conf
+ '[' -e /var/lib/nova/nova.sqlite ']'
+ chown nova:nova /var/lib/nova/nova.sqlite
+ chmod 0640 /var/lib/nova/nova.sqlite
root@juju-675da2-mno-17...

Read more...

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nova (Ubuntu):
status: New → Confirmed
Corey Bryant (corey.bryant) wrote :

I discussed with James and we'd like to completely drop the db migrations from the packages in Pike.

I don't think we need to backport fixes for all packages, however since nova is hitting this in Ocata we should backport for that package.

summary: - nova db sync is executed when the 'connection' is not defined
+ drop db sync commands from OpenStack packages
description: updated
description: updated
Changed in ironic (Ubuntu Zesty):
status: New → Invalid
Changed in ironic (Ubuntu Xenial):
status: New → Invalid
Changed in ironic (Ubuntu Artful):
status: New → Triaged
importance: Undecided → Medium
Changed in nova (Ubuntu Artful):
importance: Undecided → High
Changed in nova (Ubuntu Zesty):
status: New → Triaged
Changed in nova (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Critical
importance: Critical → High
Changed in nova (Ubuntu Zesty):
importance: Undecided → High
Changed in ceilometer (Ubuntu Artful):
importance: Undecided → Medium
status: New → Triaged
Changed in ceilometer (Ubuntu Zesty):
status: New → Invalid
Changed in ceilometer (Ubuntu Xenial):
status: New → Invalid
Changed in cinder (Ubuntu Xenial):
status: New → Invalid
Changed in cinder (Ubuntu Zesty):
status: New → Invalid
Changed in cinder (Ubuntu Artful):
importance: Undecided → Medium
status: New → Triaged
Changed in panko (Ubuntu Xenial):
status: New → Invalid
Changed in panko (Ubuntu Zesty):
status: New → Invalid
Changed in panko (Ubuntu Artful):
importance: Undecided → Medium
status: New → Triaged
Changed in openstack-trove (Ubuntu Xenial):
status: New → Invalid
Changed in openstack-trove (Ubuntu Zesty):
status: New → Invalid
Changed in openstack-trove (Ubuntu Artful):
importance: Undecided → Medium
status: New → Triaged
Changed in glance (Ubuntu Xenial):
status: New → Invalid
Changed in glance (Ubuntu Zesty):
status: New → Invalid
Changed in glance (Ubuntu Artful):
importance: Undecided → Medium
status: New → Triaged
Changed in aodh (Ubuntu Xenial):
status: New → Invalid
Changed in aodh (Ubuntu Zesty):
status: New → Invalid
Changed in aodh (Ubuntu Artful):
importance: Undecided → Medium
status: New → Triaged
Changed in manila (Ubuntu Xenial):
status: New → Invalid
Changed in manila (Ubuntu Zesty):
status: New → Invalid
Changed in manila (Ubuntu Artful):
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ironic - 1:9.1.0-0ubuntu2

---------------
ironic (1:9.1.0-0ubuntu2) artful; urgency=medium

  * d/ironic-common.postinst: Drop db sync (LP: #1713059).

 -- Corey Bryant <email address hidden> Tue, 29 Aug 2017 10:33:57 -0400

Changed in ironic (Ubuntu Artful):
status: Triaged → Fix Released
Changed in keystone (Ubuntu Xenial):
status: New → Invalid
Changed in keystone (Ubuntu Zesty):
status: New → Invalid
Changed in keystone (Ubuntu Artful):
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aodh - 5.0.0-0ubuntu2

---------------
aodh (5.0.0-0ubuntu2) artful; urgency=medium

  * d/aodh-common.postinst: Drop db sync (LP: #1713059).

 -- Corey Bryant <email address hidden> Tue, 29 Aug 2017 10:57:40 -0400

Changed in aodh (Ubuntu Artful):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceilometer - 1:9.0.0-0ubuntu4

---------------
ceilometer (1:9.0.0-0ubuntu4) artful; urgency=medium

  * d/ceilometer-common.postinst: Drop ceilometer-upgrade (LP: #1713059).

 -- Corey Bryant <email address hidden> Tue, 29 Aug 2017 10:41:26 -0400

Changed in ceilometer (Ubuntu Artful):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package panko - 3.0.0-0ubuntu2

---------------
panko (3.0.0-0ubuntu2) artful; urgency=medium

  * d/panko-common.postinst: Drop db sync (LP: #1713059).

 -- Corey Bryant <email address hidden> Tue, 29 Aug 2017 10:48:01 -0400

Changed in panko (Ubuntu Artful):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glance - 2:15.0.0~rc2-0ubuntu2

---------------
glance (2:15.0.0~rc2-0ubuntu2) artful; urgency=medium

  * d/glance-api.postinst, d/glance-registry.postinst: Drop db sync
    commands (LP: #1713059).

 -- Corey Bryant <email address hidden> Tue, 29 Aug 2017 10:54:14 -0400

Changed in glance (Ubuntu Artful):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openstack-trove - 1:8.0.0~rc1-0ubuntu2

---------------
openstack-trove (1:8.0.0~rc1-0ubuntu2) artful; urgency=medium

  * d/trove-common.postinst: Drop db sync (LP: #1713059).

 -- Corey Bryant <email address hidden> Tue, 29 Aug 2017 10:50:58 -0400

Changed in openstack-trove (Ubuntu Artful):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package manila - 1:5.0.0~rc1-0ubuntu2

---------------
manila (1:5.0.0~rc1-0ubuntu2) artful; urgency=medium

  * d/manila-common.postinst: Drop db sync (LP: #1713059).

 -- Corey Bryant <email address hidden> Tue, 29 Aug 2017 11:18:30 -0400

Changed in manila (Ubuntu Artful):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package keystone - 2:12.0.0~rc2-0ubuntu2

---------------
keystone (2:12.0.0~rc2-0ubuntu2) artful; urgency=medium

  * d/keystone.postinst: Drop db sync (LP: #1713059).

 -- Corey Bryant <email address hidden> Tue, 29 Aug 2017 11:21:44 -0400

Changed in keystone (Ubuntu Artful):
status: Triaged → Fix Released
Felipe Reyes (freyes) on 2017-08-29
Changed in nova (Ubuntu Zesty):
assignee: nobody → Felipe Reyes (freyes)
Changed in nova (Ubuntu Xenial):
assignee: nobody → Felipe Reyes (freyes)
Felipe Reyes (freyes) wrote :
Felipe Reyes (freyes) wrote :
Felipe Reyes (freyes) wrote :
Felipe Reyes (freyes) on 2017-08-29
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2:16.0.0~rc2-0ubuntu3

---------------
nova (2:16.0.0~rc2-0ubuntu3) artful; urgency=medium

  * d/tests/nova-daemons: Run db sync prior to testing services are running.

 -- Corey Bryant <email address hidden> Tue, 29 Aug 2017 16:36:46 -0400

Changed in nova (Ubuntu Artful):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinder - 2:11.0.0~rc2-0ubuntu3

---------------
cinder (2:11.0.0~rc2-0ubuntu3) artful; urgency=medium

  * d/cinder.conf, d/tests/cinder-daemons, d/tests/cinder-volume: Update
    default config with enabled_backends and database connection, and run
    db sync commands in autopkgtests prior to testing services are running.

 -- Corey Bryant <email address hidden> Tue, 29 Aug 2017 17:14:11 -0400

Changed in cinder (Ubuntu Artful):
status: Triaged → Fix Released

The verification of the Stable Release Update for aodh has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package aodh - 5.0.0-0ubuntu2~cloud0
---------------

 aodh (5.0.0-0ubuntu2~cloud0) xenial-pike; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 aodh (5.0.0-0ubuntu2) artful; urgency=medium
 .
   * d/aodh-common.postinst: Drop db sync (LP: #1713059).

James Page (james-page) wrote :

The verification of the Stable Release Update for ceilometer has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package ceilometer - 1:9.0.0-0ubuntu4~cloud0
---------------

 ceilometer (1:9.0.0-0ubuntu4~cloud0) xenial-pike; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 ceilometer (1:9.0.0-0ubuntu4) artful; urgency=medium
 .
   * d/ceilometer-common.postinst: Drop ceilometer-upgrade (LP: #1713059).

James Page (james-page) wrote :

The verification of the Stable Release Update for ironic has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package ironic - 1:9.1.0-0ubuntu2~cloud0
---------------

 ironic (1:9.1.0-0ubuntu2~cloud0) xenial-pike; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 ironic (1:9.1.0-0ubuntu2) artful; urgency=medium
 .
   * d/ironic-common.postinst: Drop db sync (LP: #1713059).

James Page (james-page) wrote :

The verification of the Stable Release Update for panko has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package panko - 3.0.0-0ubuntu2~cloud0
---------------

 panko (3.0.0-0ubuntu2~cloud0) xenial-pike; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 panko (3.0.0-0ubuntu2) artful; urgency=medium
 .
   * d/panko-common.postinst: Drop db sync (LP: #1713059).

Corey Bryant (corey.bryant) wrote :

Thanks for the patches Felipe. I've uploaded the package to zesty, xenial-newton-staging, and xenial. It is awaiting SRU review for zesty and xenial, and awaiting promotion to xenial-newton-proposed:

https://launchpad.net/ubuntu/zesty/+queue?queue_state=1&queue_text=
https://launchpad.net/ubuntu/xenial/+queue?queue_state=1&queue_text=
http://reqorts.qa.ubuntu.com/reports/ubuntu-server/cloud-archive/newton_versions.html

Hello Felipe, or anyone else affected,

Accepted nova into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:13.1.4-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nova (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Felipe, or anyone else affected,

Accepted nova into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:15.0.6-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nova (Ubuntu Zesty):
status: Triaged → Fix Committed
tags: added: verification-needed-zesty
Ryan Beisner (1chb1n) wrote :

Hello Felipe, or anyone else affected,

Accepted nova into mitaka-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:mitaka-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-mitaka-needed to verification-mitaka-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-mitaka-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-mitaka-needed
Ryan Beisner (1chb1n) wrote :

Hello Felipe, or anyone else affected,

Accepted nova into newton-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:newton-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-newton-needed to verification-newton-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-newton-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-newton-needed
Ryan Beisner (1chb1n) wrote :

Hello Felipe, or anyone else affected,

Accepted nova into ocata-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:ocata-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-ocata-needed to verification-ocata-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-ocata-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-ocata-needed
Felipe Reyes (freyes) wrote :

Tested zesty-ocata, this bug is fixed and no regressions were found, evidence -> http://pastebin.ubuntu.com/25627502/

tags: added: verification-done-zesty
removed: verification-needed-zesty
Felipe Reyes (freyes) wrote :

tested xenial-ocata, bug fixed and no regressions found, evidence: http://pastebin.ubuntu.com/25628568/

tested xenial-newton, bug fixed and no regressions found, evidence: http://pastebin.ubuntu.com/25628597/

tags: added: verification-newton-done verification-ocata-done
removed: verification-newton-needed verification-ocata-needed
Felipe Reyes (freyes) wrote :

tested trusty-mitaka, the db sync is not run with the new version of the package, evidence: http://pastebin.ubuntu.com/25629280/
tested xenial-mitaka, no more db sync, evidence http://pastebin.ubuntu.com/25629321/

tags: added: verification-done verification-done-xenial verification-mitaka-done
removed: verification-mitaka-needed verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2:15.0.6-0ubuntu1.1

---------------
nova (2:15.0.6-0ubuntu1.1) zesty; urgency=medium

  * d/nova-common.postinst: Don't sync database if connection is not defined
    in /etc/nova/nova.conf (LP: #1713059).

 -- Felipe Reyes <email address hidden> Tue, 29 Aug 2017 15:40:07 -0300

Changed in nova (Ubuntu Zesty):
status: Fix Committed → Fix Released
Felipe Reyes (freyes) wrote :

default nova.conf are different between xenial and ocata, the main difference is that nova.conf from ocata defines a sql connection[0] and in mitaka is not defined[1]

nova.conf from xenial(mitaka) -> http://paste.ubuntu.com/25634494/
nova.conf from zesty(ocata) -> http://paste.ubuntu.com/25634492/

So I wonder what's the path to fix this:

1) change debian/tests/nova-daemons to add a sqlite database in nova.conf, run db sync and then restart the daemon(s)
2) change the nova.conf that is installed by the debian package to set a sqlite database by default
3) Reject this change from mitaka

Thoughts?

[0] # grep 'connection=sqlite' /etc/nova/nova.conf
connection=sqlite:////var/lib/nova/nova.sqlite
[1] # grep "connection" /etc/nova/nova.conf
root@just-teal:~#

tags: added: verification-failed verification-failed-xenial verification-mitaka-failed
removed: verification-done verification-done-xenial verification-mitaka-done
Felipe Reyes (freyes) wrote :

nova.conf from newton -> http://paste.ubuntu.com/25634939/ , it does define a sqlite connection

Corey Bryant (corey.bryant) wrote :

Felipe, I've uploaded nova 2:13.1.4-0ubuntu4.1 to the xenial review queue with sqlite connection strings added to the default nova.conf. That should fix this up. Thanks for digging into this.

Brian Murray (brian-murray) wrote :

Hello Felipe, or anyone else affected,

Accepted nova into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:13.1.4-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-xenial
removed: verification-failed verification-failed-xenial
Felipe Reyes (freyes) wrote :

Eric,

About the failure in autopkgtest for s390x, I executed the test suite manually and it passed without problems (with and without proposed enabled)

$ adt-run -B nova --- lxd adt/ubuntu/zesty/s390x
adt-run [12:05:23]: version 3.20.4ubuntu1
adt-run [12:05:23]: host XXXX; command line: /usr/bin/adt-run -B nova --- lxd adt/ubuntu/zesty/s390x
adt-run [12:05:32]: testbed dpkg architecture: s390x
adt-run [12:05:33]: testbed running kernel: Linux 4.4.0-96-generic #119-Ubuntu SMP Tue Sep 12 14:59:56 UTC 2017
adt-run [12:05:34]: @@@@@@@@@@@@@@@@@@@@ apt-source nova
[...]
adt-run [12:07:39]: test python-nova: - - - - - - - - - - results - - - - - - - - - -
python-nova PASS
adt-run [12:07:39]: @@@@@@@@@@@@@@@@@@@@ summary
nova-compute-daemons PASS
nova-daemons PASS
nova-api PASS
python-nova PASS

$ adt-run --apt-pocket proposed -B nova --- lxd adt/ubuntu/zesty/s390x
adt-run [12:23:53]: version 3.20.4ubuntu1
adt-run [12:23:53]: host freyeslpar; command line: /usr/bin/adt-run --apt-pocket proposed -B nova --- lxd adt/ubuntu/zesty/s390x
adt-run [12:24:05]: @@@@@@@@@@@@@@@@@@@@ test bed setup
Get:1 http://ports.ubuntu.com/ubuntu-ports zesty-proposed InRelease [240 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports zesty-proposed/universe Sources [11.9 kB]
Get:3 http://ports.ubuntu.com/ubuntu-ports zesty-proposed/main Sources [17.7 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports zesty-proposed/main s390x Packages [28.1 kB]
Get:5 http://ports.ubuntu.com/ubuntu-ports zesty-proposed/universe s390x Packages [22.3 kB]
Fetched 320 kB in 1s (300 kB/s)
Reading package lists...
adt-run [12:24:07]: testbed dpkg architecture: s390x
adt-run [12:24:08]: testbed running kernel: Linux 4.4.0-96-generic #119-Ubuntu SMP Tue Sep 12 14:59:56 UTC 2017
adt-run [12:24:08]: @@@@@@@@@@@@@@@@@@@@ apt-source nova
[...]
adt-run [12:26:15]: test python-nova: - - - - - - - - - - results - - - - - - - - - -
python-nova PASS
adt-run [12:26:15]: @@@@@@@@@@@@@@@@@@@@ summary
nova-compute-daemons PASS
nova-daemons PASS
nova-api PASS
python-nova PASS

Best,

On Fri, Oct 06, 2017 at 04:28:46PM -0000, Corey Bryant wrote:
> Felipe, the tests for xenial look ok here: http://people.canonical.com
> /~ubuntu-archive/proposed-migration/xenial/update_excuses.html

We were checking a failure in zesty running nova autopkgtest triggered by a new vlan package pushed into -proposed

http://autopkgtest.ubuntu.com/packages/n/nova/zesty/s390x
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-zesty/zesty/s390x/n/nova/20170921_203340_e5492@/log.gz

Corey Bryant (corey.bryant) wrote :

I see. Let me know if you need anything. It looks like there aren't any update-excuses zesty failures atm for nova so maybe this has been resolved.

Corey Bryant (corey.bryant) wrote :

I meant to say involving nova.

Felipe Reyes (freyes) wrote :

xenial (mitaka) is working fine, no regressions detected -> http://pastebin.ubuntu.com/25768480/

tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2:13.1.4-0ubuntu4.1

---------------
nova (2:13.1.4-0ubuntu4.1) xenial; urgency=medium

  * d/nova.conf: Add connection strings to default config for sqlite. This
    enables daemons to start by default and fixes failing autopkgtests.
  * d/tests/nova-daemons: Update test to be resilient to timing failures.

nova (2:13.1.4-0ubuntu4) xenial; urgency=medium

  * d/nova-common.postinst: Don't sync database if connection is not defined
    in /etc/nova/nova.conf (LP: #1713059).

 -- Corey Bryant <email address hidden> Tue, 03 Oct 2017 14:24:48 -0400

Changed in nova (Ubuntu Xenial):
status: Fix Committed → Fix Released
Felipe Reyes (freyes) wrote :

Hi Corey, it's pending to sync nova (2:13.1.4-0ubuntu4.1) from xenial to the trusty-mitaka cloud archive to be able to verify the SRU

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers