[SRU] liberty point releases

Bug #1594867 reported by David Della Vecchia on 2016-06-21
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
neutron-fwaas (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
neutron-lbaas (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
neutron-vpnaas (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
nova (Ubuntu)
Undecided
Unassigned
Wily
Undecided
Unassigned
python-glance-store (Ubuntu)
Wily
Undecided
Unassigned

Bug Description

New point releases for misc openstack components for the liberty release:

nova 12.0.4
neutron 7.1.1
neutron-lbaas 7.1.1
neutron-fwaas 7.1.1
neutron-vpnaas 7.1.1

Changed in glance (Ubuntu):
status: New → Invalid
Changed in neutron (Ubuntu):
status: New → Invalid
Changed in nova (Ubuntu):
status: New → Invalid
Changed in python-glance-store (Ubuntu):
status: New → Invalid
no longer affects: glance (Ubuntu)
description: updated
Changed in neutron-lbaas (Ubuntu):
status: New → Invalid
Changed in python-glance-store (Ubuntu Wily):
status: New → Invalid
description: updated
Corey Bryant (corey.bryant) wrote :

nova, neutron, neutron-fwaas, neutron-lbaas, and neutron-vpnaas have been uploaded to the wily review queue and are awaiting SRU team review. I dropped python-glance-store from this bug so that the uploaded packages aren't blocked by it, and it can be done in a separate SRU bug.

no longer affects: python-glance-store (Ubuntu)
description: updated

Hello David, or anyone else affected,

Accepted nova into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:12.0.4-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nova (Ubuntu Wily):
status: New → Fix Committed
tags: added: verification-needed
Chris J Arges (arges) wrote :

Hello David, or anyone else affected,

Accepted neutron into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron/2:7.1.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in neutron (Ubuntu Wily):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello David, or anyone else affected,

Accepted neutron-lbaas into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron-lbaas/2:7.1.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in neutron-lbaas (Ubuntu Wily):
status: New → Fix Committed
Changed in neutron-fwaas (Ubuntu):
status: New → Invalid
Changed in neutron-fwaas (Ubuntu Wily):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello David, or anyone else affected,

Accepted neutron-fwaas into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron-fwaas/1:7.1.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in neutron-vpnaas (Ubuntu):
status: New → Invalid
Changed in neutron-vpnaas (Ubuntu Wily):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello David, or anyone else affected,

Accepted neutron-vpnaas into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron-vpnaas/2:7.1.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of nova from wily-proposed was performed and bug 1602311 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1602311 (not this bug). Thanks!

tags: added: verification-failed
James Page (james-page) wrote :

Dropping verification-failed tag - the linked bug is most likely due to pip installed copies of a number of packages in the nova dependency chain.

tags: removed: verification-failed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2:12.0.4-0ubuntu1

---------------
nova (2:12.0.4-0ubuntu1) wily; urgency=medium

  [ James Page ]
  * New upstream version.
  * d/p/network-data-json-in-configdrive.patch: Dropped, included upstream.
  * d/p/*: Refresh.

  [ David Della Vecchia ]
  * New upstream stable point release for OpenStack Liberty (LP: #1594867).
  * d/p/ignore-proxies.patch: Rebased.

 -- David Della Vecchia <email address hidden> Tue, 21 Jun 2016 12:08:46 -0400

Changed in nova (Ubuntu Wily):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nova has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron-fwaas - 1:7.1.1-0ubuntu1

---------------
neutron-fwaas (1:7.1.1-0ubuntu1) wily; urgency=medium

  * New upstream stable point release for OpenStack Liberty (LP: #1594867).

 -- David Della Vecchia <email address hidden> Tue, 21 Jun 2016 15:03:56 -0400

Changed in neutron-fwaas (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:7.1.1-0ubuntu1

---------------
neutron (2:7.1.1-0ubuntu1) wily; urgency=medium

  [ James Page ]
  * New upstream version.
  * d/p/*: Refresh.

  [ Corey Bryant ]
  * d/p/fix-test-treat-devices-added-updated-no-local-interface.patch:
    Mock ip_lib for failing test.
  * d/rules: Use ostestr to run tests.
  * d/control, d/neutron-plugin-midonet.install, d/t/midonet-plugin:
    Drop MidonetInterfaceDriver as it has moved out of tree.

  [ David Della Vecchia ]
  * New upstream stable point release for OpenStack Liberty (LP: #1594867).
  * d/p/fix-neutron-configuration.patch: Rebased.
  * d/p/drop-ryu-dep.patch: Rebased.

 -- David Della Vecchia <email address hidden> Tue, 21 Jun 2016 12:14:50 -0400

Changed in neutron (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron-lbaas - 2:7.1.1-0ubuntu1

---------------
neutron-lbaas (2:7.1.1-0ubuntu1) wily; urgency=medium

  * New upstream stable point release for OpenStack Liberty (LP: #1594867).
  * d/p/skip-failing-tests.patch: Rebased.

 -- David Della Vecchia <email address hidden> Tue, 21 Jun 2016 12:22:41 -0400

Changed in neutron-lbaas (Ubuntu Wily):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron-vpnaas - 2:7.1.1-0ubuntu1

---------------
neutron-vpnaas (2:7.1.1-0ubuntu1) wily; urgency=medium

  * New upstream stable point release for OpenStack Liberty (LP: #1594867).

 -- David Della Vecchia <email address hidden> Tue, 21 Jun 2016 15:00:59 -0400

Changed in neutron-vpnaas (Ubuntu Wily):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers