nova-vncproxy has unmet dependencies

Bug #1064440 reported by steve A on 2012-10-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nova (Ubuntu)
Undecided
Unassigned

Bug Description

I am creating a multi server installation of openstack following this documentation:
http://docs.openstack.org/trunk/openstack-compute/install/apt/content/ch_installing-openstack-overview.html
I have added the required repos to install this on 12.04LTS
http://docs.openstack.org/trunk/openstack-compute/install/apt/content/assumptions.html

the nova-vncproxy package fails to install

steps to reproduce -
root@iswubu33:/etc# apt-get install nova-vncproxy
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nova-vncproxy : Depends: nova-common (= 2012.2~f3-0ubuntu1~cloud0) but 2012.2-0ubuntu3~cloud0 is to be installed
E: Unable to correct problems, you have held broken packages.

workaround identified - none

James Page (james-page) wrote :

Hi Steve

Thanks for the bug report; nova-vncproxy has been dropped from the nova packaging - please use nova-novncproxy instead.

The nova-vncproxy should have been removed from the cloud-archive - will take a look.

Changed in nova (Ubuntu):
status: New → Invalid
steve A (dafridgie) wrote :

Cheers James, thanks for the guidance,
I'd been using novncproxy in essex and did wonder why it seemed to be back in folsom.
thanks for the clarification -
I can confirm nova-novncproxy installs without issues

thanks again

Steve a

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers