[SRU] Release tagged version 17.0.1 for stable/queens repositories

Bug #1789427 reported by Alex Kavanagh on 2018-08-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
Queens
Undecided
Alex Kavanagh
nova-lxd (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Alex Kavanagh

Bug Description

[Impact]
This is a new point release of nova-lxd for stable/queens. This has fixes to work with LXD 3.0 which removed some zfs storage keys from the default config. This has been fixed in master, and backported to stable/queens:

https://review.openstack.org/#/c/584900/

[Test Case]

In order to verify that this functions, the tests/gate-basic-bionic-queens integration test covers the functionality of nova-lxd in bionic with queens. Passing this test verifies the software.

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned tests are attached to this bug.

[Discussion]

description: updated
Changed in nova-lxd (Ubuntu):
status: New → Invalid
Changed in nova-lxd (Ubuntu Bionic):
status: New → Triaged
no longer affects: nova-lxd
Changed in cloud-archive:
status: New → Invalid
summary: - Release tagged version 17.0.1 for stable/queens repositories
+ [SRU] Release tagged version 17.0.1 for stable/queens repositories
Corey Bryant (corey.bryant) wrote :

I've uploaded nova-lxd 17.0.1 to the bionic unapproved queue where it is awaiting review by the sru team:

https://launchpad.net/ubuntu/bionic/+queue?queue_state=1&queue_text=

description: updated

Hello Alex, or anyone else affected,

Accepted nova-lxd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova-lxd/17.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nova-lxd (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Corey Bryant (corey.bryant) wrote :

Hello Alex, or anyone else affected,

Accepted nova-lxd into queens-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:queens-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-queens-needed to verification-queens-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-queens-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-queens-needed
Changed in nova-lxd (Ubuntu Bionic):
assignee: nobody → Alex Kavanagh (ajkavanagh)
Alex Kavanagh (ajkavanagh) wrote :

Verified on bionic with queens proposed using https://github.com/openstack-charmers/openstack-bundles/tree/master/development/openstack-lxd-bionic-queens bundle (for MaaS)

Verified that a server instance can be booted and that no errors occur.

tags: added: verification-done verification-done-bionic verification-done-needed
removed: verification-needed verification-needed-bionic verification-queens-needed
Łukasz Zemczak (sil2100) wrote :

Thank you for the verification Alex! What's not completely clear from yout test comment is what exact packages and version have been tested during validation? You mentioned queens proposed - does that imply testing of the binaries that are currently in bionic-proposed?

Alex Kavanagh (ajkavanagh) wrote :

Hi Łukasz

Sorry, I should have been more specific. The openstack-lxd-bionic-queens bundle tests the distro installed version of OpenStack on bionic, which is the OpenStack queens release. I then used the queens-proposed archive to verify that the 17.0.1 release of nova-lxd was being installed and ran through the integration tests for this.

This confirms that the 17.0.1 release of nova-lxd with queens (which is the openstack release for bionic) works with the rest of the bionic package software.

> You mentioned queens proposed - does that imply testing of the binaries that are currently in bionic-proposed?

Yes, I believe so.

Thanks
Alex.

Chris Halse Rogers (raof) wrote :

Unless I misunderstand the archive setups, this sounds like you did *not* test the packages from bionic-proposed?

Queens-proposed is - as far as I'm aware - a separate archive that needs to be enabled with `add-apt-repository cloud-archive:queens-proposed`, and so you would not be pulling the binaries from bionic-proposed?

Alex Kavanagh (ajkavanagh) wrote :

Okay, for the avoidance of doubt, I will re-do my tests and post the actual package versions here.

Alex Kavanagh (ajkavanagh) wrote :

So this is what I tested and verified works with python-nova-lxd 17.0.1:

Package: python-nova-lxd
Version: 17.0.1-0ubuntu1
Priority: extra
Section: python
Source: nova-lxd
Origin: Ubuntu
Maintainer: Chuck Short <email address hidden>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 308 kB
Depends: python-os-brick (>= 2.1.1), python-os-vif (>= 1.7.0), python-oslo.concurrency (>= 3.25.0), python-oslo.config (>= 1:5.1.0), python-oslo.i18n (>= 3.15.3), python-oslo.log (>= 3.36.0), python-oslo.utils (>= 3.33.0), python-pylxd (>= 2.1.1), python-pbr, python:any (<< 2.8), python:any (>= 2.7.5-5~)
Homepage: http://github.com/openstack/nova-lxd
Supported: 5y
Download-Size: 43.1 kB
APT-Manual-Installed: no
APT-Sources: http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages
Description: OpenStack Compute Python libraries - LXD driver
 OpenStack is a reliable cloud infrastructure. Its mission is to produce
 the ubiquitous cloud computing platform that will meet the needs of public
 and private cloud providers regardless of size, by being simple to implement
 and massively scalable.
 .
 OpenStack Compute, codenamed Nova, is a cloud computing fabric controller. In
 addition to its "native" API (the OpenStack API), it also supports the Amazon
 EC2 API.
 .
 Nova is intended to be modular and easy to extend and adapt. It supports many
 different hypervisors (KVM and Xen to name a few), different database backends
 (SQLite, MySQL, and PostgreSQL, for instance), different types of user
 databases (LDAP or SQL), etc.

The verification of the Stable Release Update for nova-lxd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova-lxd - 17.0.1-0ubuntu1

---------------
nova-lxd (17.0.1-0ubuntu1) bionic; urgency=medium

  * d/gbp.conf: Create stable/queens branch.
  * New upstream stable point release for OpenStack Queens (LP: #1789427).

 -- Corey Bryant <email address hidden> Tue, 28 Aug 2018 10:15:13 -0400

Changed in nova-lxd (Ubuntu Bionic):
status: Fix Committed → Fix Released
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for nova-lxd has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package nova-lxd - 17.0.1-0ubuntu1~cloud0
---------------

 nova-lxd (17.0.1-0ubuntu1~cloud0) xenial-queens; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 nova-lxd (17.0.1-0ubuntu1) bionic; urgency=medium
 .
   * d/gbp.conf: Create stable/queens branch.
   * New upstream stable point release for OpenStack Queens (LP: #1789427).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers