Background colour bright blue

Bug #929425 reported by Gerry Boland on 2012-02-09
252
This bug affects 71 people
Affects Status Importance Assigned to Milestone
notify-osd (Ubuntu)
Medium
Mirco Müller

Bug Description

Since update today on Precise, all notifications are a bright blue.

I'm running Unity 2d (with Unity installed also) with Metacity. Compositing on or off, same result.

Relevant settings:

gsettings get com.canonical.Unity average-bg-color
'#FFFFFFFFFFFFFFFF' <- manually set

and is still bright blue.

Related branches

Gerry Boland (gerboland) on 2012-02-09
Changed in notify-osd:
assignee: nobody → Mirco Müller (macslow)
Mirco Müller (macslow) wrote :

I've got reports from people also getting this with regular unity/compiz.

Changed in notify-osd:
status: New → Confirmed
importance: Undecided → Medium
Mirco Müller (macslow) wrote :

It only has to be three "quadruples" not four (like in #RRRRGGGGBBBB). So...

gsettings get com.canonical.Unity average-bg-color "#FFFFFFFFFFFF"

... would give you a white. It will of course always be slightly darkened by notify-osd automatically. But I've also an possible fix proposed.

wacked_up (arianvg) wrote :

I experience this bug on Unity 3D 5.4 as well.

Jose Manuel Perdomo (joz3) wrote :

The same bug in the gnome classic desktop

Omer Akram (om26er) on 2012-02-21
Changed in notify-osd:
status: Confirmed → In Progress
Changed in notify-osd (Ubuntu):
status: New → In Progress
Sebastien Bacher (seb128) wrote :

bug #934425 has a comment stating that it happens for background which are less than 1300px vertical, not sure if that's the same issue than 2d is having though

summary: - Background colour bright blue on Unity2D
+ Background colour bright blue
Christian B (masterblah777-d) wrote :

I'm experiencing this in Unity 3d after upgrading from ubuntu 11.10 to Ubuntu 12.04.

alexy@dsl.pipex.com (alexg) wrote :

Fixed for me by changing the wallpaper. Tested with notify-send 'yo'

Michael Weimann (m982) wrote :

Since updating to 12.04 yesterday my notifications are blue too. If I change to the default ubuntu wallpaper the notifications are as usual. When using this one delivered with 11.10 http://www.flickr.com/photos/vellender/6031920006/ the notifications are blue.

Michael Hope (michaelh1) wrote :

It's normally fine but now, after lunch, it's blue.

They don't just turn bright blue, either. Depending on the wallpaper set, my laptop now has aqua-colored notifications (purple-and-orange pangolin wallpaper), and they are bright red on my desktop (blue-and-green wallpaper). Someone I know on Google+ has vivid green notifications with his wallpaper (see https://plus.google.com/u/0/100530892038948253747/posts/N7o4wUVHnbT ).

I can confirm that changing the wallpaper to #10's, the bubbles become vivid green and not blue.

si14 (a2alt) wrote :

It affects me too with this wallpaper: http://ge.tt/6e9Lt7F/v/0?c

Kieran Hogg (xerosis) wrote :

Mine has just started doing this with no changes to background. Unity 3d.

Simeon (simeon5) wrote :

Happens to me too sometimes when I disconnect from my WLAN so its probably not background-related.

Simeon (simeon5) wrote :

This happened to me before but only ~ once a month. Since todays update it happens pretty much every time. Maybe its a regression caused by a recent fix?

Greg Michalec (greg-primate) wrote :

It looks like this was fixed (at least for me) with the update to notify-osd 0.9.34-0ubuntu1 .

It is fixed, but should be little bit darker, not that pale

Simeon (simeon5) wrote :

seems to be fixed here too.

Michael (amemain) wrote :

Just had it happen to me and I am fully updated.

@Michael: Did you try a reboot? It's also fixed for me.

Mirco Müller (macslow) wrote :

As of notify-osd 0.9.34 this issue is fixed.

Changed in notify-osd:
status: In Progress → Fix Released
Changed in notify-osd (Ubuntu):
status: In Progress → Fix Released
Shahar Or (mightyiam) wrote :

Yey! Thanks, everyone!

James Gifford (jamesgifford) wrote :

I don't think this is fixed - I'm on notify-osd 0.9.34-0ubuntu2, and it's still a chameleon.

See these two screenshots for comparison.

http://i.imgur.com/qJQBH.png

http://i.imgur.com/eXtnP.png

Evan Huus (eapache) wrote :

@James: It's supposed to change depending on the wallpaper. This bug was about it picking a wildly inaccurate colour (ie one that wasn't anywhere close to what was in the wallpaper).

Changed in notify-osd (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
no longer affects: notify-osd
Changed in notify-osd (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments