Notify-osd accessibility broken due to recent GTK3 changes.

Bug #856071 reported by Luke Yelavich on 2011-09-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
notify-osd (Ubuntu)
High
Canonical Desktop Experience Team

Bug Description

 affects ubuntu/notify-osd

 affects notify-osd
 tag a11y

Since recent work in GTK3 to merge the gail module into GTK proper, notify-osd accessibility is broken. When a notification pops up, the orca screen reader should read the notification, for example when changing volume, Orca should speak "Volume" and the percentage. However now Orca says "Notification notify-osd".

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in notify-osd (Ubuntu):
status: New → Confirmed
Changed in notify-osd (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Undecided → High
summary: - Notify-osd accessibility broken due to recent GT3 changes.
+ Notify-osd accessibility broken due to recent GTK3 changes.
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notify-osd - 0.9.33-0ubuntu1

---------------
notify-osd (0.9.33-0ubuntu1) precise; urgency=low

  * New upstream release:
    - change background colour to use the same median colour used in
      the unity dash (lp: #810325)
    - should migrate the user gconf keys values to gsettings (lp: #827897)
    - accessibility broken due to recent GTK3 changes (lp: #856071)
    - keeps on writing to .cache/notify-osd.log and waking up my drive
      (lp: #904835)
    - wakes up for every key/focus event after showing the first bubble
      (lp: #915389)
 -- Sebastien Bacher <email address hidden> Wed, 08 Feb 2012 21:08:41 +0100

Changed in notify-osd (Ubuntu):
status: Confirmed → Fix Released

I got an update to notify-osd in precise, and now Orca reads no
notifications at all. It doesn't even say notification. Is there
something I'm missing?

On 02/08/2012 01:15 PM, Launchpad Bug Tracker wrote:
> This bug was fixed in the package notify-osd - 0.9.33-0ubuntu1
>
> ---------------
> notify-osd (0.9.33-0ubuntu1) precise; urgency=low
>
> * New upstream release:
> - change background colour to use the same median colour used in
> the unity dash (lp: #810325)
> - should migrate the user gconf keys values to gsettings (lp: #827897)
> - accessibility broken due to recent GTK3 changes (lp: #856071)
> - keeps on writing to .cache/notify-osd.log and waking up my drive
> (lp: #904835)
> - wakes up for every key/focus event after showing the first bubble
> (lp: #915389)
> -- Sebastien Bacher<email address hidden> Wed, 08 Feb 2012 21:08:41 +0100
>
> ** Changed in: notify-osd (Ubuntu)
> Status: Confirmed => Fix Released
>

Adolfo Jayme (fitojb) on 2013-06-27
no longer affects: notify-osd (Ubuntu Oneiric)
no longer affects: notify-osd
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers