Rhythmbox Notification Bubble shows wrong cover art

Bug #451086 reported by Joachim Sauer on 2009-10-14
176
This bug affects 39 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
Rhythmbox
Fix Released
Medium
notify-osd (Ubuntu)
Low
Mirco Müller
Karmic
Low
Unassigned
rhythmbox (Ubuntu)
Low
Unassigned
Karmic
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: rhythmbox

When switching between songs while the main window is invisible notification bubble pop up to show me what the current song is.

Unfortunately the notification bubble sometimes shows the wrong cover art. It seems to me that the main (only?) problem is when switching from a song with cover art to another song that has no cover art. In that case all the information from the new song is displayed, but the cover art of the old song is still displayed (which is obviously no longer applicable).

ProblemType: Bug
Architecture: amd64
Date: Wed Oct 14 10:35:51 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/rhythmbox
NonfreeKernelModules: nvidia
Package: rhythmbox 0.12.5-0ubuntu3
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=de_AT.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-13.45-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.31-13-generic x86_64

Joachim Sauer (saua) wrote :
affects: rhythmbox (Ubuntu) → notify-osd (Ubuntu)
Mirco Müller (macslow) wrote :

In that case rhythmbox should update the bubble correctly. Examples for doing this can be found in notify-osd trunk (lp:notify-osd) in ./notify-osd/examples/update-notifications.py. There's also an ANSI C example, but that's not up to date at the moment. This is solely an issue of rhythmbox and none of notify-osd, therefore I'm reassigning this to rhythmbox.

Changed in notify-osd (Ubuntu):
status: New → Invalid
Mirco Müller (macslow) wrote :

Ups, already reported to rhythmbox. Marking it as invalid on notify-osd then.

Mirco Müller (macslow) wrote :

Here's how rhythmbox should go about this case when second song lacks cover-art (pseudo-code):

// create a new bubble for first song
image_file = get_cover_art_image (song_one);
if (image_file)
 n = notification_new ("Song one", "Artist one, Album one", image_file);
else
 n = notification_new ("Song one", "Artist one, Album one", " "); // note the space between the last double-quote pair

notification_show (n);

// update current bubble
image_file = get_cover_art_image (song_two);
if (image_file)
 notification_update (n, "Song two", "Artist two, Album two", image_file);
else
 notification_update (n, "Song two", "Artist two, Album two", " "); // note the space between the last double-quote pair

notification_show (n);

According to you example-case the first song will have a cover-image, thus the if-branch will be executed (resulting in an icon-summary-body layout case). For the second song the else-branch will be executed, because it lacks a cover-image. Then the filename will be a simple single space (and result in a summary-body layout case). This is needed for notify-osd to be able to determine the bubble-layout and distinguish update- from append-cases.

Joachim Sauer (saua) wrote :

I tried to implement that change myself and indeed this simply change (see attached patch) solved the problem for me. Now songs without cover art are displayed correctly (i.e. with no cover art).

Joachim Sauer (saua) wrote :

It seems this issue is not the only one. I just now seen an issue where the cover art of the previous song was still displayed for a song that *had* a cover art (i.e. the new cover art didn't correctly replace the old cover art)

David Barth (dbarth) wrote :

Need to consider whether notify-osd really needs icon == " " to disambiguate layouts.

Changed in notify-osd:
milestone: none → ubuntu-9.10
Pedro Villavicencio (pedro) wrote :

this looks like bug 446822

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
Joachim Sauer (saua) wrote :

Regarding #8: that second issue I mention in comment #6 might be bug 446822. The one I mentioned initially is definitely a separate one.

I wasn't sure if there was a common source of those bugs, so I thought I'd mention them both here.

Mirco Müller (macslow) on 2009-10-15
Changed in notify-osd:
status: New → Invalid
Pedro Villavicencio (pedro) wrote :

you might want to send this upstream to bugzilla.gnome.org since you're getting the issue there then, thanks.

Joachim Sauer (saua) wrote :

reported bug upstream

Changed in rhythmbox:
importance: Undecided → Unknown
status: New → Unknown
Sebastien Bacher (seb128) wrote :

the bug is not really a rhythmbox one but rather a notify-osd one since the sementic has been changed there

Changed in notify-osd (Ubuntu):
status: Invalid → New
Changed in notify-osd:
status: Invalid → New
David Barth (dbarth) on 2009-10-16
Changed in notify-osd:
importance: Undecided → Medium
status: New → Triaged
Changed in notify-osd (Ubuntu):
importance: Undecided → Low
status: New → Triaged
David Barth (dbarth) on 2009-10-16
Changed in notify-osd:
assignee: nobody → Mirco Müller (macslow)
Changed in notify-osd (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
David Barth (dbarth) on 2009-10-16
Changed in notify-osd:
assignee: Mirco Müller (macslow) → David Barth (dbarth)
Changed in notify-osd (Ubuntu):
assignee: Mirco Müller (macslow) → David Barth (dbarth)
Changed in rhythmbox (Ubuntu):
status: New → Triaged
martin (braaart) wrote :

More or less the problem I'm having. Seems to be associated with events after a song without a CD cover. But also seems to be a bit random. Sometimes wrong cover, sometimes no cover. Sometimes the false cover then carries over to subsequent songs.. Song/Title/Artist text seems to be unaffected.

Rajoy (siberia-accanto) wrote :

This bug disturbs me in Ubuntu 9.10, updated to the latest packages 2 hrs ago.

When a song has no album art, Rhythmbox shows the previous song's art in the notifying bubble.

Mirco Müller (macslow) on 2009-10-24
Changed in notify-osd:
status: Triaged → Invalid
assignee: David Barth (dbarth) → Mirco Müller (macslow)
Changed in notify-osd (Ubuntu):
status: Triaged → Invalid
Changed in rhythmbox (Ubuntu):
status: Triaged → In Progress
milestone: none → ubuntu-9.10
Mirco Müller (macslow) wrote :

The cause for this bug is, that rhythmbox (rb) does not correctly reset the hints on a notification.

So if a song does not have a cover-art defined for it, rb just passes a default icon via the "icon parameter". But if a previous song had a cover-art defined, it was sent from rb via DBus to the notification-daemon (notify-osd in this case) using the "image_data" hint. If this "image_data" hint is not explicitly cleared from rb before sending out that default icon as "icon parameter", the pixbuf attached to that "image_data" hint overrules the "icon parameter", resulting in the notification showing the wrong/old cover-art.

I've written a patch against rb 0.12.5 to fix this. It is attached to this comment. Furthermore I uploaded rhythmbox_0.12.5-0ubuntu5 to my PPA here (https://edge.launchpad.net/~macslow/+archive/ppa/+packages). Someone from the distro-team can grab needed bits from there and upload it to main.

I also added a remark in the upstream bug-report (https://bugzilla.gnome.org/show_bug.cgi?id=598613) and attached my patch there too.

Changed in rhythmbox (Ubuntu):
status: In Progress → Fix Committed
Changed in rhythmbox (Ubuntu):
milestone: ubuntu-9.10 → karmic-updates
Changed in rhythmbox (Ubuntu Karmic):
importance: Undecided → Low
status: New → Triaged
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.6-0ubuntu1

---------------
rhythmbox (0.12.6-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - Context pane plugin
    - Power management plugin reworked to use new D-Bus API
    - MTP plugin reworked to do everything asynchronously
    - Volume slider levels match what PulseAudio displays
    - Playback pipeline filter interfaces actually work properly now
    - Much improved visualization performance when crossfading is enabled
    Bugs fixed:
    499048 - Filter insertion and removal on non-xfade backend is not robust.
    499051 - xfade backend doesn't play nice with LADSPA filters
    499052 - Filter removal on xfade backend is not robust.
    534981 - Add multi threading to MTP Support (lp: #235726)
    564772 - MTP plugin crash when I plug-in my Creative Zen 32Gb
    564800 - GnomeGoals: Remove deprecated GTK+ symbols
    589845 - im-status: use mission control dbus interface (lp: #424499)
    590474 - Podcast entry disappears from display during download (lp: #451176)
    594901 - Rhythmbox fails to display cover image from id3 tag (lp: #426329)
    595966 - leaked string in rb_stock_icons_init
    596573 - [PATCH] Do not use gnome-power-manager for inhibits,
             instead use gnome-session
    597706 - rhythmbox crashed with SIGSEGV in g_object_get() (lp: #445047)
    597708 - rhythmbox crashed with SIGSEGV in rb_source_get_config_widget()
             (lp: #444526)
    597708 - DAAP plugin doesn't link to libsoup
    598135 - Should init error before call libhal_device_get_property_string
    598302 - Use GDK spawn functions to handle multi-screen
    598613 - Rhythmbox shows cover art of previous track in Notification Bubble
             if current track has no cover art (lp: #451086)
    598955 - Use Cubic volume when StreaVolume interface is available
    600058 - Feed is not parsed when title tag is empty (lp: #468323)
    600513 - Generates invalid Brasero project
    600549 - Crash when transferring a track over MTP with a slash in
             the track title
    600624 - track information is not displayed correctly sometimes
             when playing internet radios (lp: #467308)
    600995 - Elapsed time indicator is wrong when seeking (lp: #474145)
    601352 - Crash while editing automatic playlist
    601460 - Rhythmbox gets laggy when copying music to iPod
    601528 - Play button doesn't work after finishing a playlist (lp: #474155)
    602615 - rhythmbox fails to build if python bindings are built and ld's
             --no-add-needed is used
    New and updated translations
  * debian/patches/05_brasero_burn_xml.patch:
    - the change is in the new version
  * debian/patches/90_autoconf.patch:
    - new version update
  * debian/patches/91_git_change_fix_inhibit_use.patch
    - the change is in the new version
 -- Sebastien Bacher <email address hidden> Mon, 23 Nov 2009 11:45:02 +0100

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released
Saivann Carignan (oxmosys) wrote :

This has been fixed upstream. I imported the upstream patch from git commit a0914313afb7a374954fa7079fbc90af0b6c402a and prepared a clean debdiff ready for a SRU. I did not update bug description has the milestone was already set to karmic-update. I built and tested my debdiff and the upstream patch fixes the bug in my case.

Sebastien Bacher (seb128) wrote :

Thank you for your work, I've sponsored the sru now

Changed in notify-osd (Ubuntu Karmic):
importance: Undecided → Low
status: New → Invalid
Changed in notify-osd (Ubuntu):
assignee: David Barth (dbarth) → nobody
Changed in rhythmbox (Ubuntu Karmic):
status: Triaged → Fix Committed

Accepted rhythmbox into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
defunctzombie (defunctzombie) wrote :

I've applied the update, but now the bubble shows the Rhythmbox icon for everything even if it has art. The only way I can get the art to appear is if I press my keyboard's fast forward button. After that song finishes, though, the icon comes back.

Saivann Carignan (oxmosys) wrote :

Uh, after more testing, I am able to confirm this. It does not happen very often in my case. It seems to be because rhythmbox does not download the cover in time, or something such. However, if the problem is not permanent in my case, if one mp3 does not show right cover, the next one appears correctly and so on, in notify-osd.

defunctzombie (defunctzombie) wrote :

My situation seems to have improved, as now most of the covers come up. Maybe I just need to re-add the covers for the one playlist.

I can confirm this bug on Ubuntu 9.10 64-bit.

Sebastien Bacher (seb128) wrote :

there is no need to add new comments to confirm this bug

Changed in rhythmbox (Ubuntu Karmic):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Martin Pitt (pitti) wrote :

Can someone please test the proposed update? This is blocking the fix for bug 440828 to enter -proposed. Thanks!

Michael Gratton (mjog) wrote :

The package in -proposed seems to be behaving okay.

For notifications from a track with art to one without, the notification icon changes to the RB logo.

For notifications for a track with different art from the last, the icon changes to the new one.

There is a bit of a lag (~1s) between the notification being shown and the icon changing, but it gets there correctly in the end.

Michael Gratton (mjog) wrote :

Oddly, the lag seems to also occur for notifications between tracks with the same art - in this case the RB logo is displayed then the cover art appears.

Martin Pitt (pitti) on 2010-01-10
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 0.12.5-0ubuntu5.1

---------------
rhythmbox (0.12.5-0ubuntu5.1) karmic-proposed; urgency=low

  * debian/patches/06-notify-osd-cover.patch:
    - Always display a updated cover in notify-osd (LP: #451086)
 -- Saivann Carignan <email address hidden> Tue, 01 Dec 2009 09:40:36 -0500

Changed in rhythmbox (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
milestone: none → lucid-round-6
status: New → Fix Committed
status: Fix Committed → Fix Released
Rajoy (siberia-accanto) wrote :

I have Ubuntu 9.10 freshly installed, with Rhythmbox 0.12.5 (0.12.5-0ubuntu5.1), and the issue is still present. I've posted a screenshot above, from an earlier version, and the problem is exactly the same as it was before.

Rajoy (siberia-accanto) wrote :

Correction: I have -ubuntu5 package.

This bug was not fixed, please reconsider its status. After applying the update nothing changed.

Sebastien Bacher (seb128) wrote :

the bug described there was fixed, if somebody still has an issue I would recommend opening a new bug

It looks pretty pointless to me, it's still the same bug, the fix is clearly not working on none of my two computers: nothing changed really. But if you prefer to close a bug just because the fix was officially released, rather than to listen to users' experience, well, it becomes pretty pointless to keep writing at all...

Alex Ivasyuv (industral) wrote :

In my case, notify widget have disappeared at all. How there's no popup widget from libnotify (for example with pidgin works fine)
Looks like fixing this issue was consist in dropping this feature at all ;)
0.12.5-0ubuntu5.1

Alex Ivasyuv (industral) wrote :

Correcting my answer. Right now popup appeared with correct cover (only on 8th track). But next popups that appears, shows no cover (only text).

Saivann Carignan (oxmosys) wrote :

lelamal : Seems you don't have the right version of rhythmbox, the bug is fixed in package with version that ends with 5.1 . It is known that the current fix won't show covers for albums that does not have covers in rhythmbox (of course), and that in some circumstances, the cover won't appear (rhythmbox icon will appear instead), but most of the time, it will work perfectly.

This bug was "rhythmbox shows wrong cover", this is definitively fixed. Now another bug can be opened for the "no cover" bug if it is a problem for some users, but this bug can't be re-opened since the problem described in his description is fixed.

I see your point now, Saïvann Carignan, I admit the specific issue reported in the title does not occur anymore: sorry for misunderstanding, my fault!

However, in these months I had come to experience the issue as a whole, more as described in comment #13 than in the title. In fact, it was not only the wrong cover, but more randomly involved "sometimes wrong cover, sometimes no cover. Sometimes the false cover then carries over to subsequent songs..". When today I said that nothing changed, I was simply saying that RB is still failing to show an album cover for what I'm listening to even after today's update, and even though covers are (and most often, have always been) manually dropped in the dedicated space.

All in all, yeah, I have to admit that the update solves the issue: now Rhythmbox Notification Bubble does not show wrong cover art anymore - in fact, it does not show any cover art at all.

Alex Ivasyuv (industral) wrote :

+1

If this issue was fixed, it will be good idea to add regression tag, and continue working on this issue, while it will not be fixing.
Closing this issue, and open the new one, will just lost time and users that subscribe to it.
Having all comments, and users that are able to test it (and take feedback) related to this issue in one place,
IMHO it's good idea.

Saivann Carignan (oxmosys) wrote :

Thanks for clarifying! I'm not the good person to say what is the right thing to do in that situation. According to Mirco Müller previous comment, his patch simply clear the cover image so if rhythmbox does not provide any cover for the next notification, it won't show previous image. Now according to previous comments, it seems that rhythmbox don't provide cover at all in some cases (even when the album has a cover in rhythmbox). At a first glance, I think that it seems to be a related, but different bugs. I think that the most important thing is to make sure that upstream is aware of the problem, therefore I'm going to add a comment about this in the upstream bug tracker 598613.

Michael Stempin (mstempin) wrote :

It does work if I hit the "skip to next title"-button on my laptop (Dell XPS m1330) or in the right-click menu in the notification area (Rhythmbox icon in panel).
However, it does _not_ work when it is just automatically skipped to the next song.

defunctzombie (defunctzombie) wrote :

I am in the same boat as Michael Stempin. My laptop is a HP G60, but it does the exact same thing.

David Ashford (ashford-david) wrote :

I'm seeing the same behaviour as #37 after the update. Currently on version 0.12.5-0ubuntu5.1.

Vish (vish) on 2010-01-24
Changed in hundredpapercuts:
importance: Undecided → Medium
exzemat (exzemat) wrote :

same bug on ubuntu karmic amd 64 rhythmbox 0.12.5-0ubuntu5.2

It does work if
- I hit the "skip to next title" in awn(0.4)-media-icon-applet-control
- or in the right-click menu in the notification area (Rhythmbox icon in panel).
- or when I hit the "next title" in the rhythmbox-player's window

However, it does not work when it is just automatically skipped to the next song : no cover art (in notification bubble and in awn-media-icon-control).

It's the only player concern.
no problem with
-exaile
-banshee

Sebastien Bacher (seb128) wrote :

the issue seems to still be there sometime in lucid

Changed in rhythmbox (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Travis B. Hartwell (nafai)
status: Fix Released → Triaged
Changed in rhythmbox (Ubuntu):
milestone: karmic-updates → none

Not getting cover art in 10.04

Mirco Müller (macslow) wrote :

Turned out to be a bug in notify-osd after all. It's an edge-case in the blur-cache-regeneration-prevention. Working on a branch fixing this here lp:~macslow/notify-osd/fix-451086.

Mirco Müller (macslow) on 2010-04-07
Changed in notify-osd:
milestone: ubuntu-9.10 → ubuntu-10.04-beta-2
status: Invalid → In Progress
David Barth (dbarth) on 2010-04-07
Changed in notify-osd:
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
Mirco Müller (macslow) wrote :

As of notify-osd 0.9.29 this is fixed upstream. See https://edge.launchpad.net/notify-osd/trunk/ubuntu-10.04-beta-2

Changed in notify-osd:
status: In Progress → Fix Committed
Sebastien Bacher (seb128) wrote :

the issue was a notify-osd one after all, updating tasks to reflect the status of the bug there

Changed in notify-osd (Ubuntu):
status: Invalid → Fix Committed
Changed in rhythmbox (Ubuntu):
status: Triaged → Invalid
Changed in rhythmbox (Ubuntu):
assignee: Travis B. Hartwell (nafai) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notify-osd - 0.9.29-0ubuntu1

---------------
notify-osd (0.9.29-0ubuntu1) lucid; urgency=low

  * New upstream version:
    - change the way the "empty" 1x1 pixel large input-mask is created
    - fixed the masking out of the bubble on mouse-over for the non-composited
      desktop (lp: #546650)
    - reset the stored filename (or path) of an icon, when an icon is passed
      via a hint (lp: #451086)
    - added C-example testing updating the icon of a notification
      using all three possible approaches
      (image_path hint, image_data hint, icon-parameter)
 -- Sebastien Bacher <email address hidden> Thu, 08 Apr 2010 12:47:50 +0200

Changed in notify-osd (Ubuntu):
status: Fix Committed → Fix Released
Mirco Müller (macslow) on 2010-04-12
Changed in notify-osd:
status: Fix Committed → Fix Released
Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in notify-osd (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
no longer affects: notify-osd
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.