Confirmation bubbles can overlap notification bubbles

Bug #371422 reported by Eddie Padilla on 2009-05-03
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
notify-osd (Ubuntu)
Medium
Mirco Müller

Bug Description

If you turn the volume up, change the song so Rhythmbox will show a notification, let the volume notification disappear then turn the volume up again. The Rhythmbox and volume notification will be right on top of each other making them unreadable. Here's a video of it in action. http://www.youtube.com/watch?v=D6WyraRqujk

Don't know which package it is so I don't know what other information to send. Glad to send any anything else if needed.

Ubuntu 9.04 AMD64

Package: notify-osd
State: installed
Version: 0.9.11-0ubuntu3

Eddie Padilla (eddie-no) on 2009-05-04
summary: - of eNew notifications in ubuntu 9.04 stack on top of each other making
- them unreadable
+ New notifications in ubuntu 9.04 stack on top of each other making them
+ unreadable
Eddie Padilla (eddie-no) on 2009-05-04
description: updated
affects: ubuntu → notify-osd (Ubuntu)

I've not been able to reproduce this yet myself, but it appears to be another instance of notify-osd being started (probably by root) and displaying notification-bubbles. This is very likely a duplicate of 345251.

Steve Dodier-Lazaro (sidi) wrote :

I confirm it's not a duplicate, happens here too, and afaik I only have one notify-osd instance running (ps aux agrees with me).

Steve Dodier-Lazaro (sidi) wrote :
Steve Dodier-Lazaro (sidi) wrote :

The problem seems to be that the sync notification will notice the presence of an async one and calculate its vertical position by using the "default" one and adding the height of the async one, while it should use the position of the async + the async's height instead (or notice the space above is free and put itself there).

Ara Pulido (ara) wrote :

I can confirm that this is happening in Jaunty (same package version as the original reported)

Mirco, I found the pattern to reproduce this:

1. Click on Brightness Up
Outcome: The brightness notification shows up

2. Run notify-send "Notification 1" "This is ONE"
Outcome: The brightness notification shows below Brightness notification (correct behaviour)

3. '''BEFORE''' any of the above disappear, run notify-send "Notification 2" "This is TWO"
Outcome: The second notification goes to the queue (not appearing at the moment). The brightness notification goes to the second row of notification, behind the "Notification 1" and making it hard to read (BUG)

4. When "Notification 1" and brightness notification disappear, "Notification 2" appears correctly on the top row of notifications.

Mirco, please, try to reproduce it now with the steps above, and if you're not able, ping me during UDS and I will be able to show it to you on my machine ;-)

Changed in notify-osd (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → Medium
status: New → Triaged
Ara Pulido (ara) wrote :

Typo in Step 2. It should say:

2. Run notify-send "Notification 1" "This is ONE"
Outcome: The "Notification 1" shows below Brightness notification (correct behaviour)

Ara Pulido (ara) on 2009-07-22
summary: - New notifications in ubuntu 9.04 stack on top of each other making them
- unreadable
+ Confirmation bubbles can overlap notification bubbles
Steve Dodier-Lazaro (sidi) wrote :

Ara, I don't understand why you mean with this new summary. As far as I know, the problem is that sync and non-sync notification bubbles can end up in the same place under certain circumstances. I don't see what a confirmation bubble is.

Ara Pulido (ara) wrote :

Steve, confirmation bubbles are sync bubbles and notification bubbles are non-sync:
https://wiki.ubuntu.com/NotifyOSD#Bubble%20appearance%20and%20layout

Oh, that makes much more sense to me now :) Sorry for that.

David Barth (dbarth) on 2009-08-06
Changed in notify-osd:
status: New → Confirmed
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → Medium
Changed in notify-osd (Ubuntu):
status: Triaged → Confirmed
Changed in notify-osd (Ubuntu):
status: Confirmed → Triaged
Matthew Paul Thomas (mpt) wrote :

This bug would be fixed by implementing the new positioning. <https://wiki.ubuntu.com/NotifyOSD#Outside%20the%20bubble>

Michael Janos (spikeybadooks) wrote :

This also happens with banshee on karmic. Doesn't seem to happen with rhythmbox on karmic.

Mirco Müller (macslow) wrote :
Changed in notify-osd:
status: Confirmed → In Progress
Changed in notify-osd (Ubuntu):
status: Triaged → In Progress
Mirco Müller (macslow) on 2009-09-16
Changed in notify-osd:
status: In Progress → Fix Released
Changed in notify-osd (Ubuntu):
status: In Progress → Fix Released
no longer affects: notify-osd
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers