brightness flashes if at max whenever volume changes

Bug #344664 reported by Michael Rooney on 2009-03-18
4
Affects Status Importance Assigned to Milestone
notify-osd (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: notify-osd

If you change the brightness to be at the maximum, and then change the volume, the brightness notification will flash each time the volume changes (as it does when brightness hits the maximum). I imagine this is not intended and it is distracting as it draws your attention to the wrong notification.

Perhaps this is related to the bug that causes in this case the brightness notification to remain up forever as long as you are changing the volume. I would expect the brightness notification to stay static as I adjust the volume and disappear in the normal amount of time, with the volume notification sliding up in its place.

Ara Pulido (ara) wrote :

This happens to me with the latest version of notify-osd 0.9.5-0ubuntu1

But this happens because right now, due to bug 343553, brightness notifications are treated as asynchronous notifications, rather than synchronous. When this bug is fixed, volume & brightness won't appear at the same time.

I still prefer not set it as invalid, just in case it is related to a corner case that it is worth having a look.

Changed in notify-osd:
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

is that still an issue?

Michael Rooney (mrooney) wrote :

Nope, this appears to be fixed for me as brightness and volume cannot show up at the same time anymore!

Changed in notify-osd (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers