Notification is blanked on mouse over in vmware

Bug #336108 reported by Luc-Ace on 2009-03-01
32
This bug affects 1 person
Affects Status Importance Assigned to Milestone
notify-osd (Ubuntu)
Low
Mirco Müller

Bug Description

Notifications become hollow or blank on mouse-over. Most likely an artifact of using VMware. I believe the notification not showing in the correct location is caused by a known bug having to do with changing the screen resolution.

Luc-Ace (luc-ace) wrote :
Mirco Müller (macslow) wrote :

Luc, that is not a bug. This is the intended look of notify-osd's "click-through" feature. Since you running an non-composited desktop in your VMware session, "notify-osd" cannot use compositing to support alpha/transparency. It can either do opaque or fully transparent (nothing in between). Since the "click-through" works in both cases (composited and non-composited) you should be able to see what you clicking on. That's why the notification-bubbles contents are rendered "blank". Remember you cannot interact with the notification bubbles themselves. They are meant to never "get in your way (of workflow)".

Changed in notify-osd:
assignee: nobody → macslow
importance: Undecided → Low
status: New → Invalid
Mirco Müller (macslow) wrote :

You're correct that the big gap on the right side of the notification (towards the right screen-edge) is a known bug of notify-osd not dynamically picking up the desktop/panel strut atm (currently does it only once upon notify-osd's startup). This will be fixed in due time.

Luc-Ace (luc-ace) wrote :

Just a personal opinion, it might be cleaner if it just disappeared without the border.

Yes, having seen it in action, I think blanking might be more
appropriate. In the case where the mouse happens to be in the space
where the bubble appears, it should behave in an analogous fashion to
the composited version - displaying the bubble unless you move the mouse
off and back onto it.

So +1 to blanking without the outline.

Mark

Mirco Müller (macslow) wrote :

Ok, I pushed a change (notify-osd rev. 218) to get rid of the outline on mouse-over for non-composite bubbles. Now it completely blanks.

Mirco Müller (macslow) on 2009-03-04
Changed in notify-osd:
status: Invalid → Fix Committed

I agree, +1 to blank without outline. If your mouse is over the notification, you want to see what is under the notification. If there would be text under it, the outline would still be visible and make it hard to read the text.

Mirco Müller (macslow) wrote :

Hm... but the outline was just 2 pixels thick. That usually doesn't obscure too much of text. Your brains pattern matching can easily cope with that :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notify-osd - 0.9ubuntu2

---------------
notify-osd (0.9ubuntu2) jaunty; urgency=low

  * Merge bug fixes from trunk (r219):
    - Added max. limit of 10 lines for message-body text.
    - 3-line wrapping for summary text.
    - capability "truncation" now advertised to clients (LP: #337389)
    - non-composite mouse-hover effect now fully blanks (LP: #336108)
    - disable markup-filter if parsing fails (LP: #331019)

 -- Martin Pitt <email address hidden> Wed, 04 Mar 2009 19:47:24 +0100

Changed in notify-osd:
status: New → Fix Released
TJ (tj) wrote :

The hollow/blank on mouse-over is still occuring with metacity, multiple X-screens, nvidia.

apt-cache policy notify-osd
notify-osd:
  Installed: 0.9ubuntu2
  Candidate: 0.9ubuntu2

David Barth (dbarth) wrote :

@TJ: this is not a bug, this is the expected behavior. See https://wiki.ubuntu.com/NotifyOSD#mouseover

lavinog (lavinog) wrote :

With no compositing, if my mouse is in the region originally I get a quick flicker (<100ms) of the notification.
This does not seem to be the expected behavior per David's link: "Whenever the pointer moves into a bubble, whatever is behind the bubble should instantly become no longer blurred"
I know it wont have blurring, but it should display notifications if the user is not actively moving the mouse into that region.
notify-osd:
  Installed: 0.9.11-0ubuntu3
  Candidate: 0.9.11-0ubuntu3

This bug-report looks to be the same issue. Should this be filed as a different bug?

Jordan Erickson (lns) wrote :

Not sure if I should add a new bug for this, but I experience the same "issue" in a physical install of fully updated Jaunty 64-bit w/Compiz enabled. Mouse-over will 'hide' the notification, and taking the mouse cursor away will 'unhide' it. To me, this always appeared as a rendering bug. It just doesn't seem very useful to hide and unhide just because your mouse cursor hovers over it, it seems more invasive and distracting actually. Maybe if there was an option to set the opacity of *all* notifications via gconf..

Neil J. Patel (njpatel) on 2009-08-17
Changed in notify-osd:
status: Fix Committed → Fix Released

What happens if the mouse pointer is already in the area that the notification is going to appear? I've just tested this and It doesn't appear at all. I think that the notification hiding is not a good solution in no compositing environments. The purpose of a notification is ti be seen. Maybe in this case the notification should move or display a button that hides it when clicked or not dissappear at all.

Changed in notify-osd (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → Low
no longer affects: notify-osd
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers