osd notifications blurry

Bug #1374301 reported by Andrew Lin on 2014-09-26
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
notify-osd (Ubuntu)
High
Lars Karlitski

Bug Description

Recently clean installed Ubuntu 14.04.1 Trusty Tahr. With hidpi scale set to 2, and text scale set to .75, all on screen notifications have been blurry to the point of being unreadable. Any ideas on what could cause this?

Related branches

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1374301/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Andrew Lin (andrewhlin) on 2014-09-26
affects: ubuntu → notify-osd (Ubuntu)
Mirco Müller (macslow) wrote :

Can you provide a screenshot of the encountered issue, Andrew? Futhermore what type of session (desktop-environment) are you running?

tags: added: trusty
Andrew Lin (andrewhlin) wrote :

Here's a picture of the issue
while this notification from Spotify, the issue occurs on all notifications, including system ones

Steffen Coenen (tar-dingens) wrote :

It is possible to start notify-osd with GDK_SCALE=1 and to get high quality notifications. The notifications are not blurry this way and they are scaled correctly in any way. It could be a solution to disable GDK_SCALE for notify-osd, because it is not needed. It looks better without this integer scaling.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in notify-osd (Ubuntu):
status: New → Confirmed
Jamie Strandboge (jdstrand) wrote :

I see this too on a HiDPI display. I was able to workaround it by using Steffen's suggestion:
$ sudo cp /usr/lib/x86_64-linux-gnu/notify-osd /usr/lib/x86_64-linux-gnu/notify-osd.real

Then creating /usr/lib/x86_64-linux-gnu/notify-osd with:
#!/bin/sh
set -e
export GDK_SCALE=1.0
exec /usr/lib/x86_64-linux-gnu/notify-osd.real

Then:
sudo chmod 755 /usr/lib/x86_64-linux-gnu/notify-osd

Test with:
$ sudo killall notify-osd
$ notify-send test

Note: once you are using the above wrapper you will use 'sudo killall notify-osd.real' instead.

Lars Karlitski (larsu) wrote :

I gave this a shot by modifying notify-osd to take device scale into account. Please give the attached branch a go if you own a hidpi display.

Changed in notify-osd (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Lars Uebernickel (larsu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notify-osd - 0.9.35+15.10.20150915-0ubuntu1

---------------
notify-osd (0.9.35+15.10.20150915-0ubuntu1) wily; urgency=medium

  [ Lars Uebernickel ]
  * Render in native resolution on hidpi displays (LP: #1374301)

 -- Sebastien Bacher <email address hidden> Tue, 15 Sep 2015 09:24:19 +0000

Changed in notify-osd (Ubuntu):
status: In Progress → Fix Released
Jamie Strandboge (jdstrand) wrote :

I finally got around to testing this. I rebuilt the wily upload on vivid and the results are beautiful. Thanks! :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions