jockey-gtk crashed with GError in function(): GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files

Bug #819506 reported by Julien Lavergne on 2011-08-01
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
notification-daemon (Ubuntu)
Medium
Martin Pitt
Oneiric
Medium
Martin Pitt

Bug Description

Jokey crash when I start a live session of Lubuntu. When I start it after the session is entirely loaded, jockey start without problems. I suspect it's starting before notification-daemon, and crash because it can't find it on Dbus.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: jockey-gtk 0.9.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
Architecture: i386
CasperVersion: 1.272
Date: Mon Aug 1 20:13:10 2011
ExecutablePath: /usr/bin/jockey-gtk
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Lubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110801)
Lsusb: Error: command ['lsusb'] failed with exit code 1: unable to initialize libusb: -99
MachineType: innotek GmbH VirtualBox
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/jockey-gtk --check
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/lhostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- debian-installer/language=fr keyboard-configuration/layoutcode?=fr keyboard-configuration/variantcode?=oss
PythonArgs: ['/usr/bin/jockey-gtk', '--check']
SourcePackage: jockey
Title: jockey-gtk crashed with GError in function(): GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Julien Lavergne (gilir) wrote :
visibility: private → public
tags: added: iso-testing
Changed in jockey (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Brian could you look at this please, the test case seems reproducible. Does it affect Ubuntu as well or only Lubuntu ?

Changed in jockey (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
assignee: Brian Murray (brian-murray) → nobody
importance: Undecided → Medium
status: Confirmed → Incomplete
Changed in jockey (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
Changed in jockey (Ubuntu):
assignee: Brian Murray (brian-murray) → Martin Pitt (pitti)
status: Incomplete → Triaged
Martin Pitt (pitti) wrote :

This is strange indeed, as both notify-osd and notification-daemon get D-BUS activated when needed. What could happen is that they crash when being activated the first time, which would give the "The name org.freedesktop.Notifications was not provided by any .service files" error.

I could paper over this in Jockey by catching and ignoring the error, but that would just hide the actual problem. Do you get a crash of notify-osd in /var/crash/ and/or dmesg when this happens?

Changed in jockey (Ubuntu Oneiric):
status: Triaged → Incomplete
Julien Lavergne (gilir) wrote :

I'm using notification-daemon, but nothing in /var/crash except the jokey report.
I attached the dmesg file, but nothing seems to be relative to notification.

Martin Pitt (pitti) wrote :

I tried to locally reproduce this with

 killall notification-daemon
 sudo rm /var/cache/jockey/check
 jockey-gtk --check

but it properly spawns notification-daemon again. I'll download a current lubuntu daily image to debug this more, but that will take a bit.

Martin Pitt (pitti) wrote :

Reproduced on the lubuntu CD. notification-daemon doesn't ship a /usr/share/dbus-1/services/org.freedesktop.Notifications.service, so D-BUS activation cannot work. I. e. you won't ever see notifications in Lubuntu right now.

affects: jockey (Ubuntu Oneiric) → notification-daemon (Ubuntu Oneiric)
Changed in notification-daemon (Ubuntu Oneiric):
status: Incomplete → Triaged
Martin Pitt (pitti) wrote :

from notification-daemon NEWS:

NEW in 0.7.1:
==============
- Don't use DBus activation

So that would be it; I suppose it was disabled upstream because the functionality moved into gnome-shell.

Martin Pitt (pitti) wrote :
Changed in notification-daemon (Ubuntu Oneiric):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers