Short names in notification area render incorrectly

Bug #45632 reported by Darren Thiessen on 2006-05-19
32
Affects Status Importance Assigned to Milestone
notification-daemon (Ubuntu)
Low
Michael Vogt

Bug Description

When gnome-panel is on the bottom of the screen and a song plays with a short artist and title the box renders incorrectly.

To reproduce:

1. Tag a song with a short artist and title (2 to 3 characters each)
2. Add to rhythmbox
3. Minimize rhythmbox and play the song.

I will attach a screen shot also.

This happens with many short songs not just this one.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I can reproduce this here for bottom panel notification areas. I set the severity to "major" because it is a very ugly visual glitch that needs to be fixed before the release. When a new patch for this is done we need to be sure that it will not crop text for very long messages (that happend in the past with a patch that was initially designed to fix the problem).

Cheers
 Michael

Changed in notification-daemon:
assignee: nobody → mvo
status: Unconfirmed → Confirmed
Matt Zimmerman (mdz) wrote :

Downgrading to minor; the information is still visual and this is purely cosmetic.

However, if it is trivial and safe to fix, it can be considered for the RC

Michael Vogt (mvo) wrote :

I would like to upload a fix for this.

A debdiff is here http://people.ubuntu.com/~mvo/notification-daemon_0.3.4-0ubuntu8.debdiff:

The changes:
- undo the damage that cdbs-edit-patch did on me (merge 01_ubuntu_theme.diff.patch back into 01_ubuntu_theme.diff)
- make sure we always have a minimum width (as in the original theme)
  ++ gtk_widget_set_size_request(windata->content_hbox,
  ++ WIDTH - (IMAGE_SIZE + IMAGE_PADDING) - 10,
  ++ -1);
- 04_from_upstream_cvs_no_crop.diff: taken from upstream version 0.3.5, it ensures that the bubble always has a minimum height by changing the execution order of "set_notification_arrow()" to be run after a icon was set

Michael Vogt (mvo) wrote :

Uploaded.

Changed in notification-daemon:
status: Confirmed → Fix Released
Michael Vogt (mvo) wrote :

I reopen this bug because of this http://img141.imageshack.us/img141/9035/screenshot11qg.png

The problem happens only if the notification points to a location on right-buttom of the screen.

Changed in notification-daemon:
status: Fix Released → Confirmed
Piotr Gawrysiak (pgawrysiak) wrote :

It seems to be still present in released version of Dapper - apparently only notifications from bottom panel are affected, as mentioned previously.

This is a very annoying visual problem, and it seems to affect quite a number of people - many people configure their system to resemble Windows setup, with clock etc. at bottom right corner.

This is how it looks in released version of Dapper.

I experience this in lower resolutions (800x600), and the lower-right
notifications seems shrink into the screen, where the second line of text is
only half visible.

On 6/11/06, Piotr Gawrysiak <email address hidden> wrote:
>
> It seems to be still present in released version of Dapper - apparently
> only notifications from bottom panel are affected, as mentioned
> previously.
>
> This is a very annoying visual problem, and it seems to affect quite a
> number of people - many people configure their system to resemble
> Windows setup, with clock etc. at bottom right corner.
>
> ** Attachment added: "Notification in Dapper "
> http://librarian.launchpad.net/3024578/Screenshot.png
>
> --
> Short names in notification area render incorrectly
> https://launchpad.net/bugs/45632
>

--
gawk; grep; unzip; touch; strip; init, uncompress, gasp; finger; find,
route, whereis, which, mount; fsck; nice, more; yes; gasp; warnquota,
umount; head, halt, renice, restore, touch, whereis, which, route, mount,
more, yes, gasp, umount, expand, ping, bashbug, dump, make clean; sleep

Michael Vogt (mvo) wrote :

This should be fixed in the current edgy version. If you can still reproduce it, please reopen and attach a screenshot.

Changed in notification-daemon:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers